[问题]Intel 945G集成显卡

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
头像
FEE WANG
帖子: 66
注册时间: 2007-11-23 7:20
来自: 中国湖北省武汉市
送出感谢: 0
接收感谢: 0
联系:

[问题]Intel 945G集成显卡

#1

帖子 FEE WANG » 2008-04-13 12:18

我的电脑是Intel 945G集成显卡 刚安装好系统后 ,没有什么问题,驱动都安装好了.但我更新后就变得很卡,浏览网页很卡,在桌面拖动窗口也很卡,有人说是显卡要重装,我试了很多次,都不行.用git下载 不了.我自己下了个驱动,编译的时候,出现很多的缺失的软件包,在网上找了很长时间,搞了一个上午。还是没有完全安装好。

我的问题解决了。
我是在装好系统后,就想看一下Ubuntu的3D特效,所以安装了compizconfig-settings-manager

xserver-xgl两个软件包,然后更新了系统,以为是更新后的问题。我后来把这两个软件包卸载了,系统就不卡了。也许是集成显卡的显存太小不能够开3D特效。

最新修改:
看了别人的一些帖子,我的电脑现在能够实现3D特效了。12楼说得应该是对的,我现在没有安装xserver-xgl这个包。
建议还不能实现的朋友,看一下这个帖子:
图解Ubuntu最简便的显卡驱动安装和3D桌面启用方法,compiz fusion常见问题解答viewtopic.php?f=94&t=140531&st=0&sk=t&sd=a

希望大家一起努力把Ubuntu变得更强大。
上次由 FEE WANG 在 2008-09-27 18:28,总共编辑 4 次。
lyj518
帖子: 3
注册时间: 2008-04-09 15:47
送出感谢: 0
接收感谢: 0

#2

帖子 lyj518 » 2008-04-15 14:44

我也是,跟你一样,浏览网页拖动窗口都很卡,我刚玩UBUNTU几天,什么都不会,正提心吊胆的把各个软件装了卸卸了装.....
头像
charlesalex
帖子: 145
注册时间: 2008-04-02 21:58
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 charlesalex » 2008-04-16 2:13

我的也是intel 945,装完8.04后都能用,但都觉得不是很爽,估计系统自带驱动不是很匹配,从intel官网下了相应驱动,但解压后是个xc/lib文件夹,下面有N多的子文件夹,不知然后怎么装了。。。
头像
carbont
帖子: 3406
注册时间: 2007-11-22 10:20
来自: 北京
送出感谢: 0
接收感谢: 1 次

#4

帖子 carbont » 2008-04-16 2:35

我也是这个显卡,也是8.04,没有觉得有什么问题呀??
lenovo Thinkpad R60i 0657 LHC
windowsXP……准备换回ubuntu了。

Twitter: @carbont
Athlon64
帖子: 72
注册时间: 2006-04-13 13:43
送出感谢: 0
接收感谢: 1 次

#5

帖子 Athlon64 » 2008-04-17 0:26

估计你们用的是 video-xf86-intel 驱动,换成 video-xf86-i810 驱动就好了。
pdaeng
帖子: 67
注册时间: 2006-02-12 17:39
送出感谢: 0
接收感谢: 0

#6

帖子 pdaeng » 2008-04-17 1:38

i810和intel一回事, 暂时关闭compiz就好了.
Athlon64
帖子: 72
注册时间: 2006-04-13 13:43
送出感谢: 0
接收感谢: 1 次

#7

帖子 Athlon64 » 2008-04-17 18:25

pdaeng 写了:i810和intel一回事, 暂时关闭compiz就好了.
i810 是比较旧的驱动,已经不更新了,但 Bug 较少。
intel 是 Intel 开源的驱动,持续更新中,理论上要比 i810 更好,但 Bug 很多。

i810 开 compiz 没任何问题。
intel 开 compiz 卡的问题可以通过下面的方法解决:
在 /etc/X11/xorg.conf 文件中的 Section "Device" 字段中添加:Option "AccelMethod" "xaa"

但 intel 驱动在播放视频方面还有很多不足,所以目前仍推荐使用 i810 驱动。
fzhx
帖子: 142
注册时间: 2007-10-21 17:59
送出感谢: 0
接收感谢: 0

#8

帖子 fzhx » 2008-04-17 18:39

我也是这个显卡,装后更新后都没啥不爽的问题阿
purewater
帖子: 686
注册时间: 2007-11-30 15:17
来自: 福建
送出感谢: 0
接收感谢: 0

#9

帖子 purewater » 2008-04-19 0:43

最新的livecd已经没有这个问题了,不卡了
头像
justincnn
帖子: 152
注册时间: 2007-01-12 12:02
送出感谢: 0
接收感谢: 0

#10

帖子 justincnn » 2008-04-20 11:15

我的这个显卡在8.04下特效都开 不起来,

一直都不晓得怎么回事阿
squall724
帖子: 126
注册时间: 2007-06-13 9:36
送出感谢: 0
接收感谢: 5 次

#11

帖子 squall724 » 2008-07-24 13:23

Athlon64 写了:
i810 是比较旧的驱动,已经不更新了,但 Bug 较少。
intel 是 Intel 开源的驱动,持续更新中,理论上要比 i810 更好,但 Bug 很多。

i810 开 compiz 没任何问题。
intel 开 compiz 卡的问题可以通过下面的方法解决:
在 /etc/X11/xorg.conf 文件中的 Section "Device" 字段中添加:Option "AccelMethod" "xaa"

但 intel 驱动在播放视频方面还有很多不足,所以目前仍推荐使用 i810 驱动。
加了xaa后视频播放不能使用xv了
deomaxville
帖子: 38
注册时间: 2007-08-17 15:18
送出感谢: 0
接收感谢: 0

#12

帖子 deomaxville » 2008-07-27 10:53

to:楼主
945集成显卡绝对可以开3D 玩compiz的特效
你只要卸载xserver-xgl就可以了 这个装了就会很卡
头像
qqcxz2008
帖子: 126
注册时间: 2006-08-01 18:59
来自: 浙江温州
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 qqcxz2008 » 2008-07-27 13:48

我的显卡是945的 我重装了系统, 系统没有安装显卡(第一次可以)
我也下了 最新的驱动 安装了驱动 不过没有安装好 DRM 和 其他的 不知道 要怎么搞啊
-------------------------------------
今年真的很倒霉啊!!!!
chenlei188
帖子: 4
注册时间: 2008-07-30 17:11
送出感谢: 0
接收感谢: 0

#14

帖子 chenlei188 » 2008-07-30 18:41

我的也是存在这个情况,昨天刚装好的时候还不卡,怎么自动更新后就变的卡了,拖动网页的时候跟毛毛虫爬一样,一拱一拱的。
楼上说的方法具体怎么操作阿,怎么删除那个包,我不是太清楚!~~
deomaxville
帖子: 38
注册时间: 2007-08-17 15:18
送出感谢: 0
接收感谢: 0

#15

帖子 deomaxville » 2008-07-30 20:16

sudo apt-get remove --purge xserver-xorg然后重新进X就可以了 实在不行在xorg.conf里面设定driver吧
回复

回到 “常用硬件支持”