当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 风扇控制的奇怪问题
帖子发表于 : 2006-03-25 22:30 

注册: 2006-03-17 20:06
帖子: 50
送出感谢: 0 次
接收感谢: 0 次
我的本子是联想V32,也就是后来的E200,安装ubuntu系统,感觉都挺不错的,
就是风扇的控制有些小问题,具体症状是:
1.机器启动后风扇一直在转,从噪音的大小判断,应该属于低速状态。哪怕cpu的温度很低,也不会停止。
2.如果让CPU全速运行一段时间,温度升高后,转速就会加大,直至全速旋转。此后,风扇管理,开始正常化。也就是说,温度下降后,转速会下降,再继续下降,风扇会停止,这个时候就根windows系统对风扇的控制一样了。

我觉得可能是因为控制风扇的软件没有对什么东西进行初试化的原因,不知道有没有大侠知道怎么解决这个问题?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-03-26 10:54 
头像

注册: 2005-09-01 20:48
帖子: 510
送出感谢: 0 次
接收感谢: 0 次
内核驱动的bug吧。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-03-26 20:45 

注册: 2006-03-17 20:06
帖子: 50
送出感谢: 0 次
接收感谢: 0 次
paul 写道:
内核驱动的bug吧。

谁知道呢,我从2.4.26内核的时候就有这个问题。
那时候是用红旗的,现在到了2.6.12的内核,这个问题还是存在的。
估计老外没有发现这个问题,或者这根本就不是bug。
因为我发现,过很长时间以后,有时侯也会回复正常的。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-03-26 20:52 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
我记得win下面,启动时,就是一直低速,过一段就停。说不定就是这么指定的运行规则的。


_________________
● 鸣学


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-04-05 20:30 

注册: 2006-03-17 20:06
帖子: 50
送出感谢: 0 次
接收感谢: 0 次
不是这样的, 我的机器在windows下面的时候,一进入windows系统风扇就会收到控制,有时侯就会立即停止。
而在linux系统则不行,只有当cpu温度超过42度(左右)以后风扇才会得到控制,此后则一切正常,跟windows一样。
我怀疑是不是windows系统设置的两个温度的limit值设置的不一样,可能linux设置的比较高。可是我也找补到哪里可以更改这个值,到acpi的网站上找了好久也没有找到。

eexpress 写道:
我记得win下面,启动时,就是一直低速,过一段就停。说不定就是这么指定的运行规则的。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-04-22 3:03 

注册: 2005-08-21 0:41
帖子: 59
地址: 北京
送出感谢: 0 次
接收感谢: 0 次
哈,,怪了。。我的ASUS本本,风扇不存在这个问题。。
我想可以 写一个启动脚本 来对/proc 进行操作 从而初始化风扇。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译