当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu下Biostar TForce6100-939主板显卡声卡驱动的安装经验
帖子发表于 : 2006-03-27 10:04 

注册: 2006-03-27 9:48
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
论坛中也有兄弟专门说过解决方案,但大都语焉不详,也有不少兄弟仍在困惑,所以我这里把我的安装过程写下来,供大家参考。
我的机器是AMD64 3000+, Biostar TForce6100-939主板。使用板载的显卡,声卡和网卡。
主板集成的网卡在安装过程中就识别并正常了,所以网络无问题,后来的网卡驱动在安装过程中也没有安装。这一点需要注意,在这一点有不一样问题的朋友请注意解决方案可能会稍有调整。
主要参考的是这个地址的内容:General - HOWTO: Latest NVIDIA drivers,只是根据新版本驱动,作了稍微的调整。过程如下:
一. 显卡的安装:
1. 根据文章中的提示首先浏览NOTES SECTION自己的显卡并不位于下面的列表中,所以采取方法二。
* Below are the legacy GPUs that are no longer supported in the unified driver.
These GPUs will continue to be maintained through the special legacy NVIDIA
GPU driver releases.

NVIDIA chip name Device PCI ID
------------------------------- -------------------------------
RIVA TNT 0x0020
RIVA TNT2/TNT2 Pro 0x0028
RIVA TNT2 Ultra 0x0029
Vanta/Vanta LT 0x002C
RIVA TNT2 Model 64/Model 64 Pro 0x002D
Aladdin TNT2 0x00A0
GeForce 256 0x0100
GeForce DDR 0x0101
Quadro 0x0103
GeForce2 GTS/GeForce2 Pro 0x0150
GeForce2 Ti 0x0151
GeForce2 Ultra 0x0152
Quadro2 Pro 0x0153
2. 按照方法二的提示逐步进行操作:
1) 根据你的CPU架构(32位或者是64位),从该地址下载驱动程序http://www.nvidia.com/object/unix.html。因为我安装的是32位的ubuntu,虽然我的CPU是64位的,但我选择的是Linux IA32 Latest Version: 1.0-8178Archive
2) 打开终端,输入:
代码:
sudo apt-get install build-essential gcc gcc-3.4

3)设置后边需要的root密码。
代码:
sudo passwd root

4)
代码:
uname -r

你会得到类似这样的输出:"2.6.12-10-386",我们关心的输出的最后一部分,该例子中是386,代表你的CPU架构。
5)在下面的命令里将386换成你"uname -r"得到的CPU架构。
代码:
sudo apt-get install linux-image-386 linux-headers-386

6)重新启动计算机,系统用新内核启动,
7)然后打开一个终端,输入:
代码:
sudo apt-get --purge remove nvidia-glx nvidia-settings nvidia-kernel-common

8)手动删除以下文件:
代码:
sudo rm /etc/init.d/nvidia-*

9)然后
代码:
sudo apt-get --purge remove linux-restricted-modules-`uname -r`

10) 按Ctrl+ALT+F1进入字符界面。登录进去
代码:
sudo /etc/init.d/gdm stop
cd “nvidia驱动目录”
su
CC=gcc-3.4
export CC
exit
CC=gcc-3.4
export CC
sudo sh NVIDIA-Linux-x86-1.0-8178-pkg1.run

根据相关提示进行安装,需要为内核编译模块的时候选择yes。
11)
代码:
sudo /etc/init.d/gdm start

现在你使用的是刚安装的一个新的nvidia驱动
12)打开终端,输入:
代码:
sudo apt-get install nvidia-settings
sudo gedit /usr/share/applications/NVIDIA-Settings.desktop

内容如下:
代码:
[Desktop Entry]Name=NVIDIA Settings
Comment=NVIDIA Settings
Exec=nvidia-settings
Icon=
Terminal=false
Type=Application
Categories=Application;System;

保存退出。
13)登出,按Ctrl+Alt+Backspace重新启动xserver。在菜单栏就会看到"Nvidia settings"
注意:每次内核升级或者改变都要重新安装驱动。

二. 声卡的安装:
1)显卡驱动安装完毕,声卡打了一个叉,OK,下个要对付的就是它了。

2)下载NForce的驱动,我根据情况选择下载的是32位版的驱动,版本是1.0-0310,NFORCE-Linux-x86-1.0-0310-pkg1.run

3)仿照前边的工作:

代码:
cd “nforce驱动目录”
su
CC=gcc-3.4
export CC
exit
CC=gcc-3.4
export CC
sudo sh NFORCE-Linux-x86-1.0-0310-pkg1.run

因为我的网卡工作正常,所以我在驱动的安装过程中没有选择网卡。

4)重新启动后,小喇叭上的红叉去掉了,测试一下,声音OK了!


最后由 kicker 编辑于 2006-04-03 13:38,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-04-01 2:45 

注册: 2006-03-31 21:31
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
我用的是TForce6100-754,网卡型号RTL8201BL。
网卡无法驱动(你的怎么工作正常?!),用了这个办法也不行。

对C51无言了,除了MagicLinux外,其它版本的Linux都无法直接使用驱动,只能编译内核吗?


_________________
图片


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-04-02 20:56 

注册: 2006-03-27 9:48
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
ocf6 写道:
我用的是TForce6100-754,网卡型号RTL8201BL。
网卡无法驱动(你的怎么工作正常?!),用了这个办法也不行。

对C51无言了,除了MagicLinux外,其它版本的Linux都无法直接使用驱动,只能编译内核吗?

我的主板好像是TForce6100-939。不知道为什么可以认出网卡。
能否先从别的地方拆一块PCI的网卡,先解决网络的问题就方便多了。
也许只要用一会就解决问题了。
全部搞定再拆掉也没问题啦。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-04-04 22:27 

注册: 2006-04-04 13:38
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
晕,我的TForce6100-754也认不出来网卡。去映泰看了一下,754和939除了CPU接口、内存槽数量外完全一样……
LZ用的盘是5.10吗?


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-04-08 13:06 

注册: 2006-03-27 9:48
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
难道安装也跟人品有关系,开玩笑了。
我的其他硬件:
512M*2英飞凌内存,160G希捷,别的就没什么了。
不妨用U盘或者刻录光盘先把驱动弄进系统里去再说。
我的是ubuntu5.10,是ubuntu寄过来的版本,不知道是否跟网上下载的有少许的区别?


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-04-10 16:53 

注册: 2006-03-14 8:57
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
我用的是TForce6100-754,我按lz的方法去安装显卡驱动,不过有几个问题:
(1)我的ubuntu5.1默认的是gcc-4.0,安装之后就出现:No precompiled kernel interface was found to match your kernel;

我现在装了一个gcc-3.4,之后还是有问题:
(1) gcc-version-check failed:
./usr/src/nv/conftest sh :line 19: cc :command not found

(2)set the cc environment variable to then name of the compiler used to compile your kernel

(3)unable to find the development tool `cc`in your path;


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-04-11 14:46 

注册: 2006-03-27 9:48
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
bisha 写道:
我用的是TForce6100-754,我按lz的方法去安装显卡驱动,不过有几个问题:
(1)我的ubuntu5.1默认的是gcc-4.0,安装之后就出现:No precompiled kernel interface was found to match your kernel;

我现在装了一个gcc-3.4,之后还是有问题:
(1) gcc-version-check failed:
./usr/src/nv/conftest sh :line 19: cc :command not found

(2)set the cc environment variable to then name of the compiler used to compile your kernel

(3)unable to find the development tool `cc`in your path;

一定不要省略某些步骤。gcc-3.4前边要设置环境变量。缺cc要安装一下。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-04-13 15:54 

注册: 2006-03-14 8:57
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
我的系统是新装的,要安装那些软件才可以安装驱动?


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-04-21 20:22 

注册: 2005-12-18 20:30
帖子: 5
地址: 厦门
送出感谢: 0 次
接收感谢: 0 次
ERROR: Unable to find the system utility `ld`; please make sure you have the
package 'binutils' installed. If you do have binutils installed,
then please check that `ld` is in your PATH.

OK


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-04-21 22:38 

注册: 2006-03-14 8:57
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
js917 写道:
ERROR: Unable to find the system utility `ld`; please make sure you have the
package 'binutils' installed. If you do have binutils installed,
then please check that `ld` is in your PATH.

OK

这个我已经安装了,现在的问题是,要用gcc-3.4才可以编译安装驱动,不过现在安装不了gcc-3.4(现在装的是gcc-4.0系统默认安装的).我在论坛上看过一些贴用ln -s这个命令,不过不太详细,所以还是没有办法.


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2006-04-25 23:19 

注册: 2006-03-27 9:48
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
代码:
sudo apt-get install build-essential gcc gcc-3.4

这一句注意到了么?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译