当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [已解决!]佳能打印机LBP2900无法使用!!!
帖子发表于 : 2008-05-18 16:01 

注册: 2008-05-09 12:31
帖子: 32
送出感谢: 0 次
接收感谢: 0 次
引用:
无论是Google还是Wiki都看过了,也下载了v1.6的DEB包并安装了,但就是打不出东西,打印机状态只是个空列表!

系统可以自动认出LBP2900,但就是无法打印,状态一直是Idle……


方法找到了,只是没时间测试,有LBP2900以及LBP3xxx装不上驱动的可以试试!

适用机型:

引用:
This printer driver can be used with the following hardware environment.

Hardware: Computer that is enable to operate Linux, with x86 compatible CPU
(32-bit)

Object Printer: LBP5100
LBP5300
LBP3500
LBP3300
LBP5000
LBP3210
LBP3000
LBP2900
LBP3200
LBP-1120/1210


Please see the online manual about the install method and the concrete usage.


引用:
- If you are using Ubuntu7.10, you may fail to print because it introduces
security software called AppArmor.
As the workaround, disable the AppArmor CUPS profile by running
sudo aa-complain cupsd to enable printing.
For more details, see Ubuntu7.10 Release Notes.


如果您使用Ubuntu 7.10,您可能无法打印,因为Ubuntu增加了安全防卫软件AppArmor。
您需要关闭AppArmor CUPS,在终端中执行以下命令:
代码:
sudo aa-complain cupsd

更多细节请阅读Ubuntu7.10发行说明。

驱动下载:

http://software.canon-europe.com/softwa ... asp?model=

:twisted:


_________________
引用:
你他*的天下所有的人都該死


什么?骂人?我没有!这是Ubuntu的一个发行版!

代码:
zgrep "The.*Release" /usr/share/doc/dpkg/changelog.Debian.gz


最后由 锅盖小克 编辑于 2008-06-03 14:17,总共编辑了 2 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-06-03 13:29 

注册: 2008-05-09 12:31
帖子: 32
送出感谢: 0 次
接收感谢: 0 次
AppArmor Protection of the printing system

From Gutsy on the security of the CUPS printing system is improved by using App``Armor. Unfortunately, the configuration is not perfect yet, especially if third-party printer drivers are used. If you have any problems with printing, try deactivating the App``Armor protection with sudo aa-complain cupsd. If this helps, look for messages containing audit in the /var/log/messages file. These show which components are accessed by the printing system for which there is no explicit permission given in /etc/apparmor.d/usr.sbin.cupsd. You can re-activate App``Armor via sudo aa-enforce cupsd. Report a bug (package "cupsys" so that we can correct the default configuration of App``Armor.

也就是说要执行sudo aa-complain cupsd,这和Canon官方说明中一致。OK,我去试一试。。。

(貌似Canon LBP3xxx也可以这么用,大家试试!)


页首
 用户资料  
 
3 楼 
 文章标题 : Re: [已解决!]佳能打印机LBP2900无法使用!!!
帖子发表于 : 2010-06-03 11:56 

注册: 2006-09-25 15:08
帖子: 167
送出感谢: 0 次
接收感谢: 0 次
viewtopic.php?f=42&t=245716


页首
 用户资料  
 
4 楼 
 文章标题 : Re: [已解决!]佳能打印机LBP2900无法使用!!!
帖子发表于 : 2011-01-28 18:29 

注册: 2011-01-28 10:48
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
我lbp2900驱动装上了,打印队列里也有,可打印机就是不动,,怎么回事呢


页首
 用户资料  
 
5 楼 
 文章标题 : Re: [已解决!]佳能打印机LBP2900无法使用!!!
帖子发表于 : 2014-07-01 16:56 

注册: 2008-12-09 23:59
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
锅盖小克 写道:
引用:
无论是Google还是Wiki都看过了,也下载了v1.6的DEB包并安装了,但就是打不出东西,打印机状态只是个空列表!

系统可以自动认出LBP2900,但就是无法打印,状态一直是Idle……


方法找到了,只是没时间测试,有LBP2900以及LBP3xxx装不上驱动的可以试试!

适用机型:

引用:
This printer driver can be used with the following hardware environment.

Hardware: Computer that is enable to operate Linux, with x86 compatible CPU
(32-bit)

Object Printer: LBP5100
LBP5300
LBP3500
LBP3300
LBP5000
LBP3210
LBP3000
LBP2900
LBP3200
LBP-1120/1210


Please see the online manual about the install method and the concrete usage.


引用:
- If you are using Ubuntu7.10, you may fail to print because it introduces
security software called AppArmor.
As the workaround, disable the AppArmor CUPS profile by running
sudo aa-complain cupsd to enable printing.
For more details, see Ubuntu7.10 Release Notes.


如果您使用Ubuntu 7.10,您可能无法打印,因为Ubuntu增加了安全防卫软件AppArmor。
您需要关闭AppArmor CUPS,在终端中执行以下命令:
代码:
sudo aa-complain cupsd

更多细节请阅读Ubuntu7.10发行说明。

驱动下载:

http://software.canon-europe.com/softwa ... asp?model=

:twisted:



你可以试试这个脚本,可能是权限没有添加
#To add a user to the lpadmin group, run at the terminal prompt:
#在终端里输入一下脚本,将username换成你自己的登录用户。
sudo usermod -aG lpadmin username


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译