当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 17 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 升级内核到18的RT后,原来编译安装的NVIDIA显卡不可用了
帖子发表于 : 2008-06-04 12:21 

注册: 2008-02-05 13:51
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
表现:升级后进入系统提示显卡不能 正常工作,进入GNOME桌面环境后只有800*600分辨率
选择启用效果提示不可以
打开NVIDIA X Server Settings后,错误提示信息如下:
You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.

本人不知道要怎么做了,望大大提点下,谢谢。
哦,对了,系统自带的NVIDIA-GLX以及什么MODULES和受限驱动管理器都删除了。
驱动是下的 NVIDIA官网的RUN驱动编译安装的。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-06-04 12:24 
头像

注册: 2006-09-02 14:18
帖子: 5308
地址: 汉桑城
送出感谢: 1
接收感谢: 1
你说的不是废话吗,换内核必须同时更换与内核相关的自定义的软件,重新编译吧


_________________
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-06-04 12:28 

注册: 2008-02-05 13:51
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
虽然你回答了我的问题,但是我对你没什么好感
回答别人的问题固然是好,但你没必要指责别人
如果别人别人懂的话 能解决问题的话就不会问了。


另,已经重新编译过了,无效


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-06-04 12:36 

注册: 2008-02-05 13:51
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
哦,对了,至于升级内核后要更换与内核相关的自定义的软件本人没什么经验

UBUNTU才试着接触


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-06-04 12:49 
头像

注册: 2007-05-06 2:46
帖子: 15634
送出感谢: 0 次
接收感谢: 2
ldxforever 写道:
哦,对了,至于升级内核后要更换与内核相关的自定义的软件本人没什么经验

UBUNTU才试着接触


N卡就用受限的吧,足够3D了


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-06-04 12:53 
头像

注册: 2007-09-06 11:41
帖子: 796
地址: Bergen
送出感谢: 0 次
接收感谢: 0 次
nvidia173的驱动似乎跟2.6.25内核搭配不错,ub下面还是直接用源里的省心啊。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-06-04 12:57 

注册: 2008-02-05 13:51
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
可是,我在编译安装之前已经将其全部删除了,包括受限驱动管理器在内


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-06-04 13:35 

注册: 2008-02-05 13:51
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
请高手帮忙下哈


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-06-05 16:12 

注册: 2008-01-05 8:54
帖子: 47
送出感谢: 0 次
接收感谢: 0 次
国外网站也说要编译,但我还没试过,今晚回去看看再说吧


_________________
AMD Sempron 3200+
Unika Radeon 1650GT DDR3 256m
Kinstone 1G667x2 Duel Channel
Seagate 7200.9 160G
Onda A69T(690G chip,ATI 1250 integrated)
Philips 190cw7


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-06-05 16:44 
头像

注册: 2008-05-02 19:50
帖子: 734
送出感谢: 0 次
接收感谢: 0 次
那的提示是要你运行一下nvidia-xconfig. 再重新起动一下x-server。
我也是遇到这个问题,按照提示所做,但问题没有得到解决。我又用回来之前的内核了。
楼主可以试试,按照提示做一下。如果不行,先用回之前的内核,再慢慢想办法。。


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-06-06 10:44 
头像

注册: 2008-05-02 19:50
帖子: 734
送出感谢: 0 次
接收感谢: 0 次
可以KK这个目录/lib/modules/2.6.24-18-generic/kernel/drivers/video/ 下有没有nvidia.ko 这个文件。
这是驱动模块。
另外,很有可能是这个模块里和新升级的内核版本PI配问题。
所以我想直接把的17版本内核下的显卡驱动模块直接修改一下与内核的版本号。再在18里挂载。


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-06-06 10:57 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
用源的吧。比官方的好。


_________________
● 鸣学


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-06-06 14:24 
头像

注册: 2008-05-02 19:50
帖子: 734
送出感谢: 0 次
接收感谢: 0 次
eexpress 写道:
用源的吧。比官方的好。

不是很明白,请明示之。。。


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2008-06-06 16:19 
头像

注册: 2008-06-03 15:00
帖子: 26
送出感谢: 0 次
接收感谢: 0 次
我的也是一样,现在只能用回16的内核,17的是声卡有问题


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2008-06-06 18:01 
头像

注册: 2007-03-15 16:58
帖子: 2796
地址: 湖北武汉
送出感谢: 2
接收感谢: 4
为什么要自己编译……


_________________
引用:


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 17 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译