[问题]刚装好的UBUNTU检测硬盘时每次都要卡几分钟(已解决)

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
tivooooli
帖子: 88
注册时间: 2008-06-04 12:50
来自: Beckosecurity
送出感谢: 0
接收感谢: 0
联系:

[问题]刚装好的UBUNTU检测硬盘时每次都要卡几分钟(已解决)

#1

帖子 tivooooli » 2008-06-04 12:56

以下是dmesg中的部分内容:
[ 34.493159] scsi 4:0:0:0: Direct-Access ATA SAMSUNG HD161HJ JF10 PQ: 0
ANSI: 5
[ 34.493510] scsi 5:0:0:0: Direct-Access ATA SAMSUNG HD160JJ ZM10 PQ: 0
ANSI: 5
[ 34.506272] Driver 'sr' needs updating - please use bus_type methods
[ 34.515888] Driver 'sd' needs updating - please use bus_type methods
[ 64.500506] ata3.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
[ 64.500516] ata3.00: cmd a0/01:00:00:80:00/00:00:00:00:00/a0 tag 0 dma 128 in
[ 64.500518] cdb 5a 00 2a 00 00 00 00 00 80 00 00 00 00 00 00 00
[ 64.500519] res 40/00:03:00:00:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
[ 64.500522] ata3.00: status: { DRDY }
[ 69.539767] ata3: port is slow to respond, please be patient (Status 0xd0)
[ 74.523056] ata3: device not ready (errno=-16), forcing hardreset
[ 74.523059] ata3: soft resetting link
[ 75.007241] ata3.00: configured for MWDMA2
[ 75.007252] ata3: EH complete
[ 105.002722] ata3.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
[ 105.002731] ata3.00: cmd a0/01:00:00:80:00/00:00:00:00:00/a0 tag 0 dma 128 in
[ 105.002733] cdb 5a 00 2a 00 00 00 00 00 80 00 00 00 00 00 00 00
[ 105.002734] res 40/00:03:00:00:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
[ 105.002737] ata3.00: status: { DRDY }
[ 110.041983] ata3: port is slow to respond, please be patient (Status 0xd0)
[ 115.025274] ata3: device not ready (errno=-16), forcing hardreset
[ 115.025277] ata3: soft resetting link
[ 115.509457] ata3.00: configured for MWDMA2
[ 115.509467] ata3: EH complete
[ 145.504938] ata3.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
[ 145.504947] ata3.00: cmd a0/01:00:00:80:00/00:00:00:00:00/a0 tag 0 dma 128 in
[ 145.504948] cdb 5a 00 2a 00 00 00 00 00 80 00 00 00 00 00 00 00
[ 145.504950] res 40/00:03:00:00:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
[ 145.504952] ata3.00: status: { DRDY }
[ 150.544198] ata3: port is slow to respond, please be patient (Status 0xd0)
[ 155.527486] ata3: device not ready (errno=-16), forcing hardreset
[ 155.527490] ata3: soft resetting link
[ 156.011673] ata3.00: configured for MWDMA2
[ 156.011683] ata3: EH complete
[ 186.007152] ata3.00: limiting speed to MWDMA1:PIO4
[ 186.007157] ata3.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
[ 186.007165] ata3.00: cmd a0/01:00:00:80:00/00:00:00:00:00/a0 tag 0 dma 128 in
[ 186.007166] cdb 5a 00 2a 00 00 00 00 00 80 00 00 00 00 00 00 00
[ 186.007167] res 40/00:03:00:00:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
[ 186.007170] ata3.00: status: { DRDY }
[ 191.046413] ata3: port is slow to respond, please be patient (Status 0xd0)
[ 196.029704] ata3: device not ready (errno=-16), forcing hardreset
[ 196.029707] ata3: soft resetting link
[ 196.513894] ata3.00: configured for MWDMA1
[ 196.513908] ata3: EH complete
[ 196.513916] sr0: scsi-1 drive
每次一启动系统到这里就要卡几分钟,请问高手什么原因?
上次由 tivooooli 在 2008-06-05 16:15,总共编辑 1 次。
头像
hcym
帖子: 15634
注册时间: 2007-05-06 2:46
送出感谢: 0
接收感谢: 2 次

#2

帖子 hcym » 2008-06-04 13:00

fstab里面

我是连 / 都设置为0

:roll:

哪么多码等待高手看看
头像
sfbi
帖子: 796
注册时间: 2007-09-06 11:41
来自: Bergen
送出感谢: 0
接收感谢: 0

#3

帖子 sfbi » 2008-06-04 13:03

有点像一个bug,之前在哪个地方看过类似的问题。
tivooooli
帖子: 88
注册时间: 2008-06-04 12:50
来自: Beckosecurity
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 tivooooli » 2008-06-04 13:12

好像不是fstab里设置的问题。
从启动上看,就是在loading hardware drivers那里开始,大概要停四个30秒那么长时间
只是显示:
[ 105.002722] ata3.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
[ 105.002731] ata3.00: cmd a0/01:00:00:80:00/00:00:00:00:00/a0 tag 0 dma 128 in
[ 105.002733] cdb 5a 00 2a 00 00 00 00 00 80 00 00 00 00 00 00 00
[ 105.002734] res 40/00:03:00:00:00/00:00:00:00:00/a0 Emask 0x4 (timeout)
[ 105.002737] ata3.00: status: { DRDY }
之类的信息。
这次安装用的是ubuntu.cn99.com的源网络安装,会不会是源有问题?(应该可以排除硬件损坏,因为进入系统后是好的,windows启动也很顺畅)
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#5

帖子 BigSnake.NET » 2008-06-04 13:14

[ 105.002722] ata3.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
[ 105.002731] ata3.00: cmd a0/01:00:00:80:00/00:00:00:00:00/a0 tag 0 dma 128 in
[ 105.002733] cdb 5a 00 2a 00 00 00 00 00 80 00 00 00 00 00 00 00
[ 105.002734] res 40/00:03:00:00:00/00:00:00:00:00/a0 Emask 0x4 (timeout)

磁盘出错, 是不是物理损坏了
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
tivooooli
帖子: 88
注册时间: 2008-06-04 12:50
来自: Beckosecurity
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 tivooooli » 2008-06-05 14:52

问题已经解决,但原因还是不太清楚。
我只是把光驱卸了下来,重装了一下UBUNTU,一切OK。
可能是IDE的光驱和SATA硬盘在一起的问题吧,网上有人这么说。但DEBIAN安装没有任何问题,看来UBUNTU的驱动还是有缺陷。OVER
回复

回到 “常用硬件支持”