当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 14 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装dapper6.04 失败!!经验和教训。。。。(已解决)
帖子发表于 : 2006-04-21 21:13 

注册: 2006-04-21 20:56
帖子: 21
送出感谢: 0 次
接收感谢: 0 次
我的是笔记本,显卡集成intel 82852/82855 GM/GME Graphics Controller,512M内存,

先前安装的是5.10,然后在线更新到dapper 6.04,重起后进入不了图形化界面了,想着可能kernel更新不完全,

于是就用windows下了个6.04的ISO,刻盘,然后重装系统,还是进不了图形界面,

现在的状况是,在启动的最后,显示器屏幕上一闪,然后就什么也没有了,连个提示符也没有。

然后重起,进入recovery mode,进入提示符界面后,用startx启动图形,这时候屏幕上也是一闪过后,就什么也没有

了,一片黑暗。不知道大家有什么想法和建议。。。。。


感激不尽呢!!!!!

在网上搜索了,也看到有人用82852/82855 的显卡,跑起来6.04了,不知道我的为什么不行。。。。郁闷!


解决办法:进入recovery mode,type:dpkg-reconfig xserver-xorg
在选择显卡驱动的时候用 vesa的就可以了,而不是用默认的i810(针对intel 825/855显卡)

参见 http://forum.ubuntu.org.cn/viewtopic.php?t=12638


最后由 Zero_Luo 编辑于 2006-04-29 22:28,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-04-21 22:13 
头像

注册: 2005-08-02 7:23
帖子: 773
地址: 上海
送出感谢: 0 次
接收感谢: 1
有可能是显示器没有识别正确造成超过扫描频率超过正常范围,引起的黑屏.看一下Xorg.0.log,如果是这样的话,按你的显示器改一下xorg.conf的monitor节.


_________________
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-04-21 23:44 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
看log是最好的。另外还可以当时再开个终端出来,ps -A|grep gdm,看gdm是否启动了。


_________________
● 鸣学


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-04-22 1:03 

注册: 2006-04-21 20:56
帖子: 21
送出感谢: 0 次
接收感谢: 0 次
看了log,还是不明白,我对linux不怎么熟悉,装linux有很大一部分是为了学习linux,

现在我把log&xorg.conf 贴上,还望大家帮忙看看.


谢谢!

谢谢!


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-04-22 1:08 

注册: 2006-04-21 20:56
帖子: 21
送出感谢: 0 次
接收感谢: 0 次
log 太长不知道怎么穿上来 :([/code]


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-04-22 1:09 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
贴这些结果。
less /var/log/Xorg.0.log|grep EE
ps -A|grep gdm


_________________
● 鸣学


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-04-22 1:25 

注册: 2006-04-21 20:56
帖子: 21
送出感谢: 0 次
接收感谢: 0 次
ps -A|grep gdm
这条命令我有做,没有回显呢,(就是什么也没有返回)


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-04-22 1:28 

注册: 2006-04-21 20:56
帖子: 21
送出感谢: 0 次
接收感谢: 0 次
这是我在windows下,搜索log中"EE"的结果:

Current Operating System: Linux ZERO 2.6.15-19-386 #1 PREEMPT Mon Mar 20 16:46:02 UTC 2006 i686
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(**) |-->Screen "Default Screen" (0)
(II) Loading extension XFree86-DRI
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) LoadModule: "freetype"
(II) Loading /usr/lib/xorg/modules/fonts/libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
(II) Loading font FreeType
(II) Setting vga for screen 0.
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 6
GreenFieldPosition: 5
LinGreenMaskSize: 6
LinGreenFieldPosition: 5
GreenMaskSize: 6
GreenFieldPosition: 5
LinGreenMaskSize: 6
LinGreenFieldPosition: 5
GreenMaskSize: 6
GreenFieldPosition: 5
LinGreenMaskSize: 6
LinGreenFieldPosition: 5
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 8
GreenFieldPosition: 8
LinGreenMaskSize: 8
LinGreenFieldPosition: 8
GreenMaskSize: 8
GreenFieldPosition: 8
LinGreenMaskSize: 8
LinGreenFieldPosition: 8
GreenMaskSize: 8
GreenFieldPosition: 8
LinGreenMaskSize: 8
LinGreenFieldPosition: 8
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
GreenMaskSize: 0
GreenFieldPosition: 0
LinGreenMaskSize: 0
LinGreenFieldPosition: 0
(II) do I need RAC? No, I don't.
(II) I810(0): Using XFree86 Acceleration Architecture (XAA)
Screen to screen bit blits
Indirect CPU to Screen color expansion
Offscreen Pixmaps
3: /usr/bin/X11/X(AddScreen+0x1df) [0x806e5c9]


页首
 用户资料  
 
9 楼 
 文章标题 : 附件 log
帖子发表于 : 2006-04-22 1:33 

注册: 2006-04-21 20:56
帖子: 21
送出感谢: 0 次
接收感谢: 0 次
原来可以在回复中添加附件的,faint!


附件:
文件注释: xorg.log
Xorg.0.zip [8.5 KiB]
被下载 7 次
页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-04-22 8:41 

注册: 2006-04-21 20:56
帖子: 21
送出感谢: 0 次
接收感谢: 0 次
早晨,我一醒,就来看结果啦,还望大家不吝赐教呢,全拜托大家了


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2006-04-22 11:50 

注册: 2006-04-21 20:56
帖子: 21
送出感谢: 0 次
接收感谢: 0 次
我已经绝望了,怎么会这样呢,我重装了5.10,把5.10 的xorg.conf copy出来,然后又重装了6.04,把6.04的xorg.conf 替换为5.10的,还是出不来图形。。。。。。。


页首
 用户资料  
 
12 楼 
 文章标题 : 5.10xrog。conf,log & 6.04 xorg.conf ,log
帖子发表于 : 2006-04-22 11:55 

注册: 2006-04-21 20:56
帖子: 21
送出感谢: 0 次
接收感谢: 0 次
5.10xrog。conf,log & 6.04 xorg.conf ,log


附件:
6.04.zip [9.55 KiB]
被下载 8 次
5.10.zip [9.99 KiB]
被下载 9 次
页首
 用户资料  
 
13 楼 
 文章标题 : 用这个办法,应该可以
帖子发表于 : 2006-04-25 14:22 
头像

注册: 2005-10-09 21:10
帖子: 59
地址: Guangzhou
送出感谢: 0 次
接收感谢: 0 次
使用6.06的live cd启动,然后把原来安装的分区mount到/mnt下,将/mnt/etc/X11,先作一个备份,然后,用sudo rm -fr /mnt/etc/X11, 删除原来的X11, 将live cd的X11拷过去: sudo cp -fr /etc/X11 /mnt/etc. 重新启动,应该就可以进入图形界面了。


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2006-04-29 22:30 

注册: 2006-04-21 20:56
帖子: 21
送出感谢: 0 次
接收感谢: 0 次
终于解决了,顶一下,不过我用fc5,安装的时候,也是不能进入图形安装界面, 不知道该怎么解决呢 。。。。

烂机器,毛病多多阿


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 14 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译