我的nvidia geforce 6500显卡驱不上,哪位大侠帮忙看一下,谢谢了。

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
youyouxianrne
帖子: 13
注册时间: 2006-04-23 10:33
送出感谢: 0
接收感谢: 0

我的nvidia geforce 6500显卡驱不上,哪位大侠帮忙看一下,谢谢了。

#1

帖子 youyouxianrne » 2006-04-23 10:40

安装驱动时nvidia-glx和nividia-settings总是互相冲突,颜色也只能24位。下面是安装驱动的提示信息:
ja

simon@Taliban:~$ apt-get install nvidia-glx
E: Could not open lock file /var/lib/dpkg/lock - open (13 Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
simon@Taliban:~$ sudo apt-get install nvidia-glx
Password:
Reading package lists... Done
Building dependency tree... Done
The following extra packages will be installed:
libgl1-mesa libglu1-mesa
Suggested packages:
nvidia-kernel-source
The following NEW packages will be installed:
libgl1-mesa libglu1-mesa nvidia-glx
0 upgraded, 3 newly installed, 0 to remove and 305 not upgraded.
Need to get 385kB/4436kB of archives.
After unpacking 13.6MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://ubuntu.cn99.com dapper/main libgl1-mesa 6.4.1-0ubuntu7 [162kB]
Get:2 http://ubuntu.cn99.com dapper/main libglu1-mesa 6.4.1-0ubuntu7 [223kB]
Fetched 385kB in 7s (53.1kB/s)
Selecting previously deselected package libgl1-mesa.
(Reading database ... 68663 files and directories currently installed.)
Unpacking libgl1-mesa (from .../libgl1-mesa_6.4.1-0ubuntu7_i386.deb) ...
Selecting previously deselected package libglu1-mesa.
Unpacking libglu1-mesa (from .../libglu1-mesa_6.4.1-0ubuntu7_i386.deb) ...
Selecting previously deselected package nvidia-glx.
Unpacking nvidia-glx (from .../nvidia-glx_1.0.8756+2.6.15.8-1_i386.deb) ...
Setting up libgl1-mesa (6.4.1-0ubuntu7) ...

Setting up libglu1-mesa (6.4.1-0ubuntu7) ...

Setting up nvidia-glx (1.0.8756+2.6.15.8-1) ...

simon@Taliban:~$ sudo apt-get install nvidia-settings
Reading package lists... Done
Building dependency tree... Done
The following packages will be REMOVED:
nvidia-glx

The following NEW packages will be installed:
nvidia-settings

0 upgraded, 1 newly installed, 1 to remove and 305 not upgraded.
Need to get 0B/504kB of archives.
After unpacking 11.5MB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 68719 files and directories currently installed.)
Removing nvidia-glx ...
Selecting previously deselected package nvidia-settings.
(Reading database ... 68675 files and directories currently installed.)
Unpacking nvidia-settings (from .../nvidia-settings_1.0-3ubuntu7_i386.deb) ...
Setting up nvidia-settings (1.0-3ubuntu7) ...

simon@Taliban:~$ sudo /usr/sbin/nvidia-glx-config enable
sudo: /usr/sbin/nvidia-glx-config: command not found
:( :( :( :(
youyouxianrne
帖子: 13
注册时间: 2006-04-23 10:33
送出感谢: 0
接收感谢: 0

#2

帖子 youyouxianrne » 2006-04-23 10:41

我用的是ubuntu 6.04,之前用的5.10不会出现这种问题啊
头像
oneleaf
论坛管理员
帖子: 10237
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 106 次

#3

帖子 oneleaf » 2006-04-23 11:14

应该是源的问题,等几天再试试.
头像
catinsnow
帖子: 773
注册时间: 2005-08-02 7:23
来自: 上海
送出感谢: 0
接收感谢: 1 次

#4

帖子 catinsnow » 2006-04-24 15:43

youyouxianrne 写了:我用的是ubuntu 6.04,之前用的5.10不会出现这种问题啊
nvidia-settings 在NVIDIA新的驱动中已经被并入,不能再单独装了. 直接执行,不要加/usr/sbin/

32bpp就是24位色.每通道8位,乘以3,32位含有一个alpha通道.xorg的log里有这一句:
(--) Depth 24 pixmap format is 32 bpp
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.
youyouxianrne
帖子: 13
注册时间: 2006-04-23 10:33
送出感谢: 0
接收感谢: 0

#5

帖子 youyouxianrne » 2006-05-10 9:56

我按上面的方法做了,可为什么执行完nvidia-glx-config enable
之后,屏幕的刷新率就只有60HZ了,而已整个屏幕都变形,,,

大侠帮忙啊
头像
catinsnow
帖子: 773
注册时间: 2005-08-02 7:23
来自: 上海
送出感谢: 0
接收感谢: 1 次

#6

帖子 catinsnow » 2006-05-12 0:34

修改xorg.conf文件,把里面的分辨率后面加上刷新率.比如
1024x768_85
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.
回复

回到 “常用硬件支持”