当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求助,nvidia显卡驱动问题!
帖子发表于 : 2008-07-15 0:05 

注册: 2007-07-28 3:06
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
机器上显卡是 NVIDIA RIVA TNT2 Model 64/Model 64 Pro,新装了8.04,可分辨率只能在800*600@60HZ下工作,看着很不舒服。
启用硬件更新找到的是这个驱动:nviddia-glx-legacy,问题还是一样。
从别的地方找了些资料看到我的显卡好像只能用 Linux 1.0-7184。
然后就不知道该怎么处理了,头大啊!
请回帖的朋友尽可能详细的说下步骤,刚接触ubuntu几天,问题太多了。 :evil: :evil: :evil:


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-07-15 13:52 

注册: 2008-06-12 20:34
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
试试看下载官方的驱动,然后关闭图形系统,输入 sh *.run(就是下载的驱动名称)


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-07-15 15:37 
头像

注册: 2005-11-06 1:51
帖子: 1795
地址: 七彩云世界
送出感谢: 0 次
接收感谢: 0 次
水煮活鱼 写道:
试试看下载官方的驱动,然后关闭图形系统,输入 sh *.run(就是下载的驱动名称)

还要超级用户权限。

sudo sh NV....run(TAB)


_________________
佛出寺,求索真世界 For_Truth:Free_Open_Share
OPEN GPG KEY:03D18D95


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-07-16 10:48 

注册: 2007-07-28 3:06
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
谢谢楼上2位。
问题有了进展,我这样作的:
1、sudo /etc/init.d/gdm stop
2、sudo sh NVIDIA-Linux-x86-1.0-7184-pkg1.run
出现了问题,如下提示:
You do not appear to have libc header files installed on your system.
Please install your distribution's libc development package.
接着搜了下
3、sudo apt-get install libc6 libc6-dev xorg-dev linux-headers-`uname -r` make
然后重复 1、2步,新的问题又来了 :shock:

提示 nvidia kernel moudle 怎么了,给了个安装报告:
/var/log/nvidia-installer.log

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Wed Jul 16 10:31:40 2008

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
precompiled interfaces : true
no ncurses color : false
query latest version : false
OpenGL header files : true
no questions : false
silent : false
no recursion : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false


谢谢大家,再帮我看看。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-07-19 20:35 

注册: 2008-07-19 20:21
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
我也是找了半天
試試看 http://blog.pixnet.net/Nelson/post/17221914
(先將套件管理程式中 設定裡面套件庫點開 將社群協力維護開放原始碼軟體universe勾選 )

滿不錯的喔!
做好後重新開機 到桌面後 點選系統 偏好設定 螢幕解析度 應該就可以有很多選項可以選擇了!

如果這樣還不行 再說囉!
祝您好運!


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-07-19 22:52 

注册: 2008-07-19 20:21
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
我看您還是別試
http://blog.pixnet.net/Nelson/post/17221914
(先將套件管理程式中 設定裡面套件庫點開 將社群協力維護開放原始碼軟體universe勾選 )
以上的東西了!我後來從應用程式 系統工具中 找到EnvyNG並執行它 不知道版本代號 弄得一頭霧水 花了好幾個小時 眼睛快瞎了

我看您先用以下方式 試試看 比較不會太恐怖
先將/etc/X11/xorg.conf 先作備份 有問題隨時可以複製回來
加上其中 紅色部份
SubSection "Display"
Depth 24
Virtual 1600 1200
Modes "1440x900@75" "800x600@72" "800x600@75" "800x600@56" "800x600@60" "640x480@75" "832x624@75" "640x480@72" "1024x768@75" "640x480@60" "1024x768@70" "1024x768@60" "1152x864@75" "1280x1024@75" "1280x960@60" "1280x1024@60" "1280x960@75" "1400x1050@60" "1400x1050@75" "1600x1200@65" "1600x1200@60"
EndSubSection

還有我還改了一個地方 加了一個#符號(是參考網站得來的資訊 不知道為何要改 之前沒有改也還好 目前我是有改)
Section "Module"
Load "glx"
# Load "GLcore"
Load "v4l"
EndSection

將它存檔後重新啟動電腦 應該就可以修改顯示模式了 加油!


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-07-20 11:07 

注册: 2008-07-19 20:21
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
"1440x900@75" 是我螢幕最佳顯示模式 您可以依照您的螢幕自行調整
昨天設定好 今天又跑掉 所以我將成功的xorg.conf 儲存起來
系統將xorg改掉時 再複製過去 重新開機就行了!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译