安装nvidia受限驱动遇到的奇怪问题,这到底算不算成功装了驱动?

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
头像
yq-ysy
论坛版主
帖子: 3585
注册时间: 2008-07-19 12:44
来自: 广西(桂)南宁(邕)
送出感谢: 0
接收感谢: 77 次

安装nvidia受限驱动遇到的奇怪问题,这到底算不算成功装了驱动?

#1

帖子 yq-ysy » 2008-07-21 21:56

我的电脑是AMD64 X2 3800+ 和 NVIDIA GFORCE 7600GT
光盘安装的UBUNTU 8.04.1 AMD64 DVD 版。
装上后默认第一次启动显示器就能自动达到了最高分辨率,
但是看xorg.conf里并没有nvidia的字样,
我想启动3D桌面,于是就在“系统”-“系统管理”-“硬件驱动”里勾选上"NVIDIA"
自动下载安装,重启电脑后进入不了Xwindows,怪现象有四个:

(1)在xorg.conf里
我把Section "Device"的 Driver "nvidia"改为 Driver "nv“就能启动Xwindows
且显示器能自动达到了最高分辨率,1680x1050
运行nvidia-xconfig后结果也是一样,要改为 Driver "nv“才能启动Xwindows
(2)在“系统”-“系统管理”-“硬件驱动”里
"NVIDIA"的“状态”是打了绿色的勾“使用中”,但前面的“已启用”方框里却没有勾。
(3)在/var/log/Xorg.0.log里有报错误:
Failed to load /usr/lib/xorg/modules/extensions//libglx.so
UnloadModule: "glx"
(4)装了compiz fusion却开启不了3D桌面,
“系统”-“首选项”-“外观”-“视觉效果”里,选“正常”或“扩展”提示“无法启用桌面效果”

为了解决问题,我还安装了nvidia-glx-new和linux-restricted-modules-amd64-k8
但情况依旧同上,无法进入Xwindows,该为 Driver "nv“就能进入Xwindows但启动不了3D桌面。

我的nvidia显卡受限驱动到底算是装成功没有?
我从来没有看见Xwindows启动时出现什么nvidia的LOGO,好像现在默认是不显示的?
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 BigSnake.NET » 2008-07-21 21:58

很明显不成功

Failed to load /usr/lib/xorg/modules/extensions//libglx.so
UnloadModule: "glx"
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
yq-ysy
论坛版主
帖子: 3585
注册时间: 2008-07-19 12:44
来自: 广西(桂)南宁(邕)
送出感谢: 0
接收感谢: 77 次

#3

帖子 yq-ysy » 2008-07-21 22:22

那我该怎么办? 有哪一步没有做对吗?
如果运行compiz --replace总是提示
Checking for Xgl: not present.
No whitelisted driver found
aborting and using fallback: /usr/bin/metacity
回复

回到 “常用硬件支持”