当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]UBUNTU下ATI官方驱动的一些神奇问题,高手帮忙解答下
帖子发表于 : 2008-08-01 9:21 

注册: 2008-07-26 13:31
帖子: 74
送出感谢: 0 次
接收感谢: 1
首先,AMD官网上的催化剂版本说是8.7,下载下来文件名也是8.7,但是安装时却显示是8.512,不知道是为什么?难道是ATI安装包的BUG?还是我下载错了??


另外,按照置顶帖的提示运行
代码:
glxinfo |grep -e 'direct' -e 'OpenGL'


返回值中direct rendering一项是NO,而置顶帖中说是YES??其它没错。。。

不知道这个direct rendering是什么意思?为什么会这样?


P。S:安装应该没问题,已经卸载了包括LINUX受限驱动包在内所有含有FGLRX的软件,然后再安装官方安装包,也已经
代码:
sudo aticonfig --initial
初始化了。

但是安装后没有马上执行
代码:
sudo aticonfig --overlay-type=Xv
,后来看过置顶帖以后再运行时提示:
引用:
Warning: Option 'VideoOverlay' doesn't affect running session.
Warning: Option 'OpenGLOverlay' doesn't affect running session.
Using xorg.conf
Saved back-up to xorg.conf.fglrx-6
段错误


不知道是什么意思?这个命令没有成功执行会有什么影响??


_________________
Welcome to my blog: Robot Shell

Contact me: bob1211@gmail.com


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-08-01 9:23 

注册: 2008-07-26 13:31
帖子: 74
送出感谢: 0 次
接收感谢: 1
阿,RP阿………………

大牛能告诉我这是为什么?


_________________
Welcome to my blog: Robot Shell

Contact me: bob1211@gmail.com


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-08-01 9:24 

注册: 2008-07-26 13:31
帖子: 74
送出感谢: 0 次
接收感谢: 1
另外,现在运行3D特效等都很正常,没有发现有什么问题


_________________
Welcome to my blog: Robot Shell

Contact me: bob1211@gmail.com


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-08-01 10:23 

注册: 2007-11-10 14:29
帖子: 110
送出感谢: 1
接收感谢: 1
你这是集成显卡啊~
驱动版本靠前点没有问题,因为这几次更新并没有更新驱动,而是更新的控制中心。
你可以在看看我的最新修改:http://forum.ubuntu.org.cn/viewtopic.php?t=119945


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-08-01 17:07 

注册: 2008-07-26 13:31
帖子: 74
送出感谢: 0 次
接收感谢: 1
对阿,是集显……

我的安装过程就是这样的阿,而且还先卸载掉所有的FGLRX驱动包了。

但是执行
glxinfo |grep -e 'direct' -e 'OpenGL'
后提示
direct rendering: No (LIBGL_ALWAYS_INDIRECT set)
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 3200 Graphics
OpenGL version string: 1.4 (2.1.7769 Release)
OpenGL extensions:

第一行为什么会那样???
这是和集显有关吗?


_________________
Welcome to my blog: Robot Shell

Contact me: bob1211@gmail.com


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-08-24 15:17 

注册: 2008-06-17 2:37
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
我的也是a78gt的板子,基本上毛病都一样`


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-08-24 16:37 
头像

注册: 2005-08-14 19:53
帖子: 3998
送出感谢: 1
接收感谢: 2
......

这个说明是否启用了opengl加速,你居然3D打开了?神奇


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-08-26 13:04 

注册: 2008-07-26 13:31
帖子: 74
送出感谢: 0 次
接收感谢: 1
居然没有启动OPENGL加速?

3D是打开了,但是期间白屏N次,最后甚至无法进入X,只好用RECOVERY MODE里头那啥修复了……

后来进去以后认不到显卡,居然最高分辨率只有640*3??(MS是这个数,忘了),在那个神奇的情况下居然有一个对话框可以让我选择显卡驱动,然后手动选择显卡驱动为FGLRX,然后乱搞,就搞定了,还成功开了3D。

让我再做一次都不一定会成功了,所以我把我现在的系统备份下来了……


_________________
Welcome to my blog: Robot Shell

Contact me: bob1211@gmail.com


页首
 用户资料  
 
9 楼 
 文章标题 : Re: [问题]UBUNTU下ATI官方驱动的一些神奇问题,高手帮忙解答下
帖子发表于 : 2008-09-23 14:32 

注册: 2008-02-20 9:43
帖子: 147
地址: Wuhan
送出感谢: 0 次
接收感谢: 0 次
配置一样,
问题也一样,

14 VirusCamp Commented @ 2008-01-20 1:44 pm
也就是这样启动 compiz ,凡是用 aiglx 的要这样,intel ,ati开源, 和 fglrx。 nvidia 的不知道

LIBGL_ALWAYS_INDIRECT=true compiz --replace --indirect-rendering --sm-disable ccp &


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译