当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [已解决]z99d上让ubuntu发声
帖子发表于 : 2008-08-04 12:37 

注册: 2008-02-10 7:21
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
安装了ubuntu8.04,识别了硬件,没有声音,今天解决了,分享一下,也希望有高手给点明下原因。
我的本本是华硕z99d系列的,主板是nvidia mcp67,声卡检测出来是nVidia Corporation MCP67 High Definition Audio但应该是realtek的(有什么原因吗,这俩不同)。
没有下载最新的alsa声卡驱动,因为使用命令
$alsactl -v
看到版本是1.0.15,挺高的其实(觉得不高就去下1.0.17)。
使用命令看解码芯片
$ tail -2 /proc/asound/oss/sndstat
我的显示
Mixers:
0: Realtek ALC660-VD
好了,这个ALC660-VD很有用。
到相应的alsa-driver-1.0.**/sound/Documentation/ALSA-Configuration.txt里找ALC660-VD对应的模块,我的是hda-intel,模式是lenovo。(下载安装了1.0.17,就到那个文件夹里找)
用z99的朋有们,用mcp67的朋友们,下面是这次解决的关键。
添加 /etc/modprobe.d/sound 文件,内容为:
alias snd-card-0 snd-MODULE_NAME
alias sound-slot-0 snd-MODULE_NAME
比如我的就是:
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

在 /etc/modprobe.d/alsa-base 中最后一行添加:
options snd-MODULE_NAME model=MODEL_NAME
比如我的就是:
options snd-hda-intel model=lenovo

重启,哈,非洲音乐来了!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译