[问题]用不了开源驱动,难道9550也分RP么?

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
kappa8086
帖子: 308
注册时间: 2008-06-23 14:42
送出感谢: 0
接收感谢: 0

[问题]用不了开源驱动,难道9550也分RP么?

#1

帖子 kappa8086 » 2008-08-07 0:06

按照置顶,以及我所能掌握到的资料来看,9550应该是系统自带驱动即可很好的运行
可是我的情况,别说compiz,连屏幕刷新率都不够
glxinfo: direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)

又试了6,9,0版,卸载6.8,编译安装,一切按流程进行,xorg.conf改了又改,结果一点用都没有。。。
czj
帖子: 88
注册时间: 2008-01-28 12:48
送出感谢: 0
接收感谢: 0

#2

帖子 czj » 2008-08-07 10:08

8.04.1的安装盘?live CD也没有compiz效果?

可能开源驱动不支持你的9550,

如果BIOS是可刷新的,刷新ID为ATI原厂ID,或自己修改代码编译驱动。

具体操作google查询。

或者,直接安装ATI官方驱动,官方的兼容性不会比开源差吧。
头像
luojie-dune
帖子: 22033
注册时间: 2007-07-30 18:28
系统: Linux
来自: 空气中
送出感谢: 9 次
接收感谢: 61 次

#3

帖子 luojie-dune » 2008-08-07 10:20

国内很多非公版的设计.。。也许不支持那么多.如果会改,lz自己修改驱动也可以.~~~
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议
kappa8086
帖子: 308
注册时间: 2008-06-23 14:42
送出感谢: 0
接收感谢: 0

#4

帖子 kappa8086 » 2008-08-07 12:26

8.04.1 DVD,9550铭瑄的,一直认为是公版的,虽然连超频到350Mhz都做到不到。。。

不过有线索就好,谢了,有空改驱动,改BIOS都试试

官方驱动不要了,一看电视之类的就得关compiz,我这基本不玩游戏的家伙,不想连桌面的快乐也没有 :D
头像
jarryson
帖子: 4002
注册时间: 2005-08-14 19:53
送出感谢: 1 次
接收感谢: 2 次
联系:

#5

帖子 jarryson » 2008-08-07 20:03

无论是不是工版的,只要芯片是就可以。驱动认芯片不认显存。

这个显卡开源驱动是铁定支持的我X700都非常非常非常稳定,9550还能不稳定?
kappa8086
帖子: 308
注册时间: 2008-06-23 14:42
送出感谢: 0
接收感谢: 0

#6

帖子 kappa8086 » 2008-08-07 21:27

看了,非常标准的ID[1002:4153]
没有改BIOS或者驱动的余地,这回又麻爪了。。。
看Xorg.0.log分析了半天,没看出个所以然来,RADEON驱动就留下的信息来看似乎已经加载,但就效果来看和没加载一个样,只有VESA支持

TO LS:
不是不稳定,是根本没效果啊T-T


对了,既然LS用的是开源驱动,能不能帮我看下dmesg | grep radeon的结果
我这里居然显示
[drm] Initialized radeon 1.28.0 20060524 on minor 0
20060524...怎么像很旧的驱动?
kappa8086
帖子: 308
注册时间: 2008-06-23 14:42
送出感谢: 0
接收感谢: 0

#7

帖子 kappa8086 » 2008-08-08 0:07

好了好了,原来是包冲突
xorg-driver-fglrx
删除这个包后3D能开了
奇怪了,我记得没装官方驱动之前也开启不了的


现在的问题变成了,屏幕刷新率没法上100Hz了
怎么写xorg.conf,系统就是不认,只认85Hz
回复

回到 “常用硬件支持”