[分享]ATI显卡在自编译2.6.26上驱动安装

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
头像
20sanguo
帖子: 777
注册时间: 2008-05-10 9:53
送出感谢: 0
接收感谢: 2 次

[分享]ATI显卡在自编译2.6.26上驱动安装

#1

帖子 20sanguo » 2008-08-19 22:00

参考http://www.debianforum.de/forum/viewtopic.php?f=2&p=635576
1、下载8.6驱动http://www2.ati.com/drivers/linux/ati-driver-installer-8-6-x86.x86_64.run,最新8.7好像按下面的方法还不行,可以在这查找他的补丁http://code.google.com/p/smxi/source/browse/trunk/patches/

2、下载补丁
http://techpatterns.com/downloads/distr ... 6.26.patch
http://techpatterns.com/downloads/distr ... 6.26.patch
http://techpatterns.com/downloads/distr ... 6.26.patch

3、在终端执行
sh ati-driver-installer-8-6-x86.x86_64.run --extract ~/ati_8.6

4、把3个补丁放到ati_8.6文件夹里
在终端执行
cd ~/ati_8.6
patch -p0 < 0001-catalyst-8.6-linux-2.6.26.patch
patch -p0 < 0002-catalyst-8.6-linux-2.6.26.patch
patch -p0 < 0003-catalyst-8.6-linux-2.6.26.patch

5、原帖中是建立deb文件,安装。
./ati-installer.sh 8.501 --buildpkg Debian/sid

而我用比较笨的办法:是这样做的sudo ./ati-driver-installer-8-6-x86.x86_64.run图形化操作。
当执行到kernel部分、/lib/modules/fglrx文件夹建立时把/ati_8.6/common/lib/modules/fglrx 覆盖过去。然后安装成功,重启就行了。

如果启动仍不能加载fglrx.ko,则需要在编译内核时加上
Kernel hacking
CONFIG_UNUSED_SYMBOLS=y 这一项。
还是希望ATI驱动做得和N卡一样兼容性强些就好了,其实他前面安装部分已经很不错的,傻瓜式安装,问题一般会出在内核模块方面。
回复

回到 “常用硬件支持”