[问题]在ubuntu 8.04下如何安装摄像头?

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
hefei2
帖子: 9
注册时间: 2007-08-23 10:25
送出感谢: 0
接收感谢: 0

[问题]在ubuntu 8.04下如何安装摄像头?

#1

帖子 hefei2 » 2008-09-13 12:41

我的系统是ubuntu8.04,插上摄像头以后没有反应,使用lsusb查看设备结果如下:
Bus 005 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 002 Device 005: ID 1c4f:3000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
1c4f:3000就是我的摄像头了,貌似没有识别出来。

用dmesg查看得到信息:
Linux video capture interface: v2.00
uvcvideo: Found UVC 1.00 device USB Web Camera (1c4f:3000)
uvcvideo: Failed to query (135) UVC control 1 (unit 0) : -32 (exp. 26).
uvcvideo: Failed to initialize the device (-5).
usbcore: registered new interface driver uvcvideo
USB Video Class driver (v0.1.0)
usbcore: deregistering interface driver uvcvideo
usb 2-2: USB disconnect, address 3
usb 2-2: new full speed USB device using uhci_hcd and address 4
usb 2-2: configuration #1 chosen from 1 choice
usb 2-2: can't set config #1, error -71
usb 2-2: USB disconnect, address 4
usb 2-2: new full speed USB device using uhci_hcd and address 5
usb 2-2: configuration #1 chosen from 1 choice
Linux video capture interface: v2.00
uvcvideo: Found UVC 1.00 device USB Web Camera (1c4f:3000)
uvcvideo: Failed to query (135) UVC control 1 (unit 0) : -32 (exp. 26).
uvcvideo: Failed to initialize the device (-5).
usbcore: registered new interface driver uvcvideo
USB Video Class driver (v0.1.0)

尝试安装了linux-uvc driver似乎也没用,不知该怎么解决,轻大家帮帮忙,谢谢了。
hefei2
帖子: 9
注册时间: 2007-08-23 10:25
送出感谢: 0
接收感谢: 0

#2

帖子 hefei2 » 2008-09-14 8:31

自己顶一下
hefei2
帖子: 9
注册时间: 2007-08-23 10:25
送出感谢: 0
接收感谢: 0

#3

帖子 hefei2 » 2008-09-16 9:05

还是自己顶一下
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#4

帖子 eexpress » 2008-09-16 10:02

设备识别都不行。硬件问题,没办法啊。
● 鸣学
头像
ilv4
帖子: 76
注册时间: 2007-06-16 23:25
来自: 新加坡
送出感谢: 0
接收感谢: 0

#5

帖子 ilv4 » 2008-09-16 14:36

Ubuntu不带摄像头驱动,可以参考我的帖子:
viewtopic.php?t=148665&highlight=
CCIE (RS, SEC & SP), JNCIE
ThinkPad TW510: i720, 8GB RAM, 256GB SSD, 15.4in 1920x1080 LCD, 1GB nVIDIA Quadro FX 880M, DVDRW, Intel 802.11agn wireless, Bluetooth, Modem, 1Gb Ethernet, UltraNav, Secure chip, FPR, 9c Li-Ion
1234qw
帖子: 389
注册时间: 2007-12-31 11:40
送出感谢: 0
接收感谢: 0

#6

帖子 1234qw » 2008-09-16 21:03

Ubuntu系统中要摄像头的进来
编译了源里自带的万能驱动源代码,并且顺利安装了

# apt-get source gspca-source
# sudo apt-get install build-essential
# ! go to source dir
# sudo make
# sudo make install
# sudo modprobe gspca

有一个可供调节摄像头的小工具camorama
摘自http://www.linuxdiyf.com/bbs/viewthread.php?tid=45461
Manny
帖子: 27
注册时间: 2008-09-09 23:17
送出感谢: 0
接收感谢: 0
联系:

Re: [问题]在ubuntu 8.04下如何安装摄像头?

#7

帖子 Manny » 2008-09-25 20:31

我的摄像头一直亮着 就是不能用 只能作台灯用阿
hefei2
帖子: 9
注册时间: 2007-08-23 10:25
送出感谢: 0
接收感谢: 0

Re: [问题]在ubuntu 8.04下如何安装摄像头?

#8

帖子 hefei2 » 2008-09-26 16:24

照着5楼的做了,还是不行。

照着6楼的做结果显示:
make -C /lib/modules/`uname -r`/build SUBDIRS=/home/hefei/gspca-01.00.18 CC=cc modules
make[1]: 正在进入目录 `/usr/src/linux-headers-2.6.24-21-generic'
scripts/Makefile.build:46: *** CFLAGS was changed in "/home/hefei/gspca-01.00.18/Makefile". Fix it to use EXTRA_CFLAGS。 停止。
make[1]: *** [_module_/home/hefei/gspca-01.00.18] 错误 2
make[1]:正在离开目录 `/usr/src/linux-headers-2.6.24-21-generic'
make: *** [default] 错误 2
无法编译通过。。。
dan0977
帖子: 7
注册时间: 2008-01-26 9:02
送出感谢: 0
接收感谢: 0

Re: [问题]在ubuntu 8.04下如何安装摄像头?

#9

帖子 dan0977 » 2008-10-01 23:55

我的摄像头和7楼的一样,一直亮这,按照5楼的方法使用了,结果和我楼上的一样,编译不通过。
回复

回到 “常用硬件支持”