当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]在ubuntu 8.04下如何安装摄像头?
帖子发表于 : 2008-09-13 12:41 

注册: 2007-08-23 10:25
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
我的系统是ubuntu8.04,插上摄像头以后没有反应,使用lsusb查看设备结果如下:
Bus 005 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 002 Device 005: ID 1c4f:3000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
1c4f:3000就是我的摄像头了,貌似没有识别出来。

用dmesg查看得到信息:
Linux video capture interface: v2.00
uvcvideo: Found UVC 1.00 device USB Web Camera (1c4f:3000)
uvcvideo: Failed to query (135) UVC control 1 (unit 0) : -32 (exp. 26).
uvcvideo: Failed to initialize the device (-5).
usbcore: registered new interface driver uvcvideo
USB Video Class driver (v0.1.0)
usbcore: deregistering interface driver uvcvideo
usb 2-2: USB disconnect, address 3
usb 2-2: new full speed USB device using uhci_hcd and address 4
usb 2-2: configuration #1 chosen from 1 choice
usb 2-2: can't set config #1, error -71
usb 2-2: USB disconnect, address 4
usb 2-2: new full speed USB device using uhci_hcd and address 5
usb 2-2: configuration #1 chosen from 1 choice
Linux video capture interface: v2.00
uvcvideo: Found UVC 1.00 device USB Web Camera (1c4f:3000)
uvcvideo: Failed to query (135) UVC control 1 (unit 0) : -32 (exp. 26).
uvcvideo: Failed to initialize the device (-5).
usbcore: registered new interface driver uvcvideo
USB Video Class driver (v0.1.0)

尝试安装了linux-uvc driver似乎也没用,不知该怎么解决,轻大家帮帮忙,谢谢了。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-09-14 8:31 

注册: 2007-08-23 10:25
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
自己顶一下


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-09-16 9:05 

注册: 2007-08-23 10:25
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
还是自己顶一下


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-09-16 10:02 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
设备识别都不行。硬件问题,没办法啊。


_________________
● 鸣学


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-09-16 14:36 
头像

注册: 2007-06-16 23:25
帖子: 76
地址: 新加坡
送出感谢: 0 次
接收感谢: 0 次
Ubuntu不带摄像头驱动,可以参考我的帖子:
http://forum.ubuntu.org.cn/viewtopic.php?t=148665&highlight=


_________________
CCIE (RS, SEC & SP), JNCIE
ThinkPad TW510: i720, 8GB RAM, 256GB SSD, 15.4in 1920x1080 LCD, 1GB nVIDIA Quadro FX 880M, DVDRW, Intel 802.11agn wireless, Bluetooth, Modem, 1Gb Ethernet, UltraNav, Secure chip, FPR, 9c Li-Ion


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-09-16 21:03 

注册: 2007-12-31 11:40
帖子: 389
送出感谢: 0 次
接收感谢: 0 次
Ubuntu系统中要摄像头的进来
编译了源里自带的万能驱动源代码,并且顺利安装了

# apt-get source gspca-source
# sudo apt-get install build-essential
# ! go to source dir
# sudo make
# sudo make install
# sudo modprobe gspca

有一个可供调节摄像头的小工具camorama
摘自http://www.linuxdiyf.com/bbs/viewthread.php?tid=45461


页首
 用户资料  
 
7 楼 
 文章标题 : Re: [问题]在ubuntu 8.04下如何安装摄像头?
帖子发表于 : 2008-09-25 20:31 

注册: 2008-09-09 23:17
帖子: 27
送出感谢: 0 次
接收感谢: 0 次
我的摄像头一直亮着 就是不能用 只能作台灯用阿


页首
 用户资料  
 
8 楼 
 文章标题 : Re: [问题]在ubuntu 8.04下如何安装摄像头?
帖子发表于 : 2008-09-26 16:24 

注册: 2007-08-23 10:25
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
照着5楼的做了,还是不行。

照着6楼的做结果显示:
make -C /lib/modules/`uname -r`/build SUBDIRS=/home/hefei/gspca-01.00.18 CC=cc modules
make[1]: 正在进入目录 `/usr/src/linux-headers-2.6.24-21-generic'
scripts/Makefile.build:46: *** CFLAGS was changed in "/home/hefei/gspca-01.00.18/Makefile". Fix it to use EXTRA_CFLAGS。 停止。
make[1]: *** [_module_/home/hefei/gspca-01.00.18] 错误 2
make[1]:正在离开目录 `/usr/src/linux-headers-2.6.24-21-generic'
make: *** [default] 错误 2
无法编译通过。。。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: [问题]在ubuntu 8.04下如何安装摄像头?
帖子发表于 : 2008-10-01 23:55 

注册: 2008-01-26 9:02
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
我的摄像头和7楼的一样,一直亮这,按照5楼的方法使用了,结果和我楼上的一样,编译不通过。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译