关于显示分辨率的问题

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
dan0977
帖子: 7
注册时间: 2008-01-26 9:02
送出感谢: 0
接收感谢: 0

关于显示分辨率的问题

#1

帖子 dan0977 » 2008-10-02 7:09

我的显卡是FX5200,N板的,系统装好后显示分辨率最高是800*600的。
经一翻折腾后已经可以运行1024*768了,可新的问题出来了,系统从新启动后分辨率就变了,现有2 个版本的xorg.conf。
先说第一个,具体内容如下:
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "cn"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Configured Video Device"
Boardname "NVIDIA GeForce FX (generic)"
Busid "PCI:1:0:0"
Driver "nvidia"
Screen 0
Vendorname "NVIDIA"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
Vendorname "AST"
Modelname "AST Sabre"
Horizsync 30.0-64.0
Vertrefresh 50.0-90.0
modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
modeline "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
modeline "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
modeline "640x480@85" 36.0 640 696 752 832 480 481 484 509 -vsync -hsync
modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
modeline "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
modeline "800x600@85" 56.3 800 832 896 1048 600 601 604 631 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
modeline "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
modeline "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
modeline "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
modeline "1024x768@43" 44.9 1024 1032 1208 1264 768 768 776 817 +hsync interlace +vsync
modeline "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
modeline "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
SubSection "Display"
Depth 24
Virtual 1024 768
Modes "1024x768@70" "1024x768@60" "1024x768@75" "1024x768@43" "832x624@75" "1280x960@60" "800x600@60" "1280x1024@60" "800x600@85" "800x600@75" "800x600@72" "800x600@56" "640x480@85" "640x480@75" "640x480@72" "640x480@60"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
EndSection
Section "Module"
Load "glx"
Load "v4l"
EndSection
Section "device" #
Identifier "device1"
Boardname "NVIDIA GeForce FX (generic)"
Busid "PCI:1:0:0"
Driver "nvidia"
Screen 1
Vendorname "NVIDIA"
EndSection
Section "screen" #
Identifier "screen1"
Device "device1"
Defaultdepth 24
Monitor "monitor1"
SubSection "Display"
Depth 24
Modes "1024x768@70"
EndSubSection
EndSection
Section "monitor" #
Identifier "monitor1"
Vendorname "Plug 'n' Play"
Modelname "Plug 'n' Play"
modeline "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
Gamma 1.0
EndSection
Section "ServerFlags"
EndSection
这个使用后从起系统后,登录是正常,登录后到桌面时分辨率变成了800*600的了。不过我的显示器还能显示出来使用。
第2 个版本,具体内容是:
Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
EndSection

Section "Module"
Load "glx"
Load "v4l"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "cn"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
VendorName "AST"
ModelName "AST Sabre"
HorizSync 30.0 - 64.0
VertRefresh 50.0 - 90.0
Gamma 1
ModeLine "640x480@60" 25.2 640 656 752 800 480 490 492 525 -hsync -vsync
ModeLine "640x480@72" 31.5 640 664 704 832 480 489 491 520 -hsync -vsync
ModeLine "640x480@75" 31.5 640 656 720 840 480 481 484 500 -hsync -vsync
ModeLine "640x480@85" 36.0 640 696 752 832 480 481 484 509 -hsync -vsync
ModeLine "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
ModeLine "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
ModeLine "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
ModeLine "800x600@85" 56.3 800 832 896 1048 600 601 604 631 +hsync +vsync
ModeLine "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
ModeLine "832x624@75" 57.3 832 864 928 1152 624 625 628 667 -hsync -vsync
ModeLine "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
ModeLine "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -hsync -vsync
ModeLine "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -hsync -vsync
ModeLine "1024x768@43" 44.9 1024 1032 1208 1264 768 768 776 817 +hsync +vsync interlace
ModeLine "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
ModeLine "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
EndSection

Section "Monitor"
#
Identifier "monitor1"
VendorName "Plug 'n' Play"
ModelName "Plug 'n' Play"
Gamma 1
ModeLine "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -hsync -vsync
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "CRT-0"
HorizSync 30.0 - 64.0
VertRefresh 50.0 - 90.0
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
VendorName "NVIDIA"
BoardName "NVIDIA GeForce FX (generic)"
BusID "PCI:1:0:0"
Screen 0
EndSection

Section "Device"
#
Identifier "device1"
Driver "nvidia"
VendorName "NVIDIA"
BoardName "NVIDIA GeForce FX (generic)"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce FX 5200"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
SubSection "Display"
Virtual 1024 768
Depth 24
Modes "1024x768@70" "1024x768@60" "1024x768@75" "1024x768@43" "832x624@75" "1280x960@60" "800x600@60" "1280x1024@60" "800x600@85" "800x600@75" "800x600@72" "800x600@56" "640x480@85" "640x480@75" "640x480@72" "640x480@60"
EndSubSection
EndSection

Section "Screen"
#
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768@70"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "metamodes" "CRT: 1024x768@70 +0+0; CRT: 1024x768@60 +0+0; CRT: 1024x768@75 +0+0; CRT: 1024x768@43 +0+0; CRT: 832x624@75 +0+0; CRT: 800x600@60 +0+0; CRT: 800x600@85 +0+0; CRT: 800x600@75 +0+0; CRT: 800x600@72 +0+0; CRT: 800x600@56 +0+0; CRT: 640x480@85 +0+0; CRT: 640x480@75 +0+0; CRT: 640x480@72 +0+0; CRT: 640x480@60 +0+0"
EndSection
这个版本我可用不了了,登录界面是可以的,可登录后的桌面其分辨率就不对了,具体是多少我也不知道了,反正是我的液晶看不到了,只能在CRT上去设置回来(CRT上也是看不太明显的)然后使用第一个,这里面具体有什么问题还请高手帮助阿,看看是什么问题。
dan0977
帖子: 7
注册时间: 2008-01-26 9:02
送出感谢: 0
接收感谢: 0

Re: 关于显示分辨率的问题

#2

帖子 dan0977 » 2008-10-04 12:36

怎么没人帮我的啊,自己顶上去。
回复

回到 “常用硬件支持”