显卡、显示器、3D---升级后出来的问题

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
macromedia007
帖子: 17
注册时间: 2008-10-18 19:43
送出感谢: 0
接收感谢: 0

显卡、显示器、3D---升级后出来的问题

#1

帖子 macromedia007 » 2008-10-18 20:17

事件的经过是这样的:

昨天中午,安装好Ubuntu8.04 Desktop,显示器自动被设置为1440*900,正常LCD宽屏显示。无异常。

昨天下午,中文输入升级完成,自动提示更新几个小补丁。无异常。

昨天晚上,打开"硬件驱动",使用了“受限驱动设备”,叫NVidia加速驱动,然后是自动更新。升级完成,随后打开所有能够打开的3D,分辨率仍然为1440*900,正常LCD宽屏显示。无异常。

昨天深夜,因为自动更新的补丁太多,所以有空闲时间我就开着机器自动在更新,睡觉前,我让机器开着“更新管理器”自动更新检测的所有补丁,睡觉了。无异常。

今天早上,更新未完成,起来重新启动电脑,LCD闪了几下提示错误,大致意思是说检测不到合适的显卡,叫我手动选择,我按我的配置,选择了Acer X 193W LCD,分辨率选择为1440*900的正常的宽屏LCD显示,结果提示设置不成功,我只好用默认的800*600分辨率。进入系统之后,以前设置的3D已经不能使用,进入设置分辨率,里面也没有1440*900的选择项了。现在我用着800*600的,点击时,上下闪来闪去,点不准。

现在的问题就很明显了:
1。我想改回到正常的LCD宽屏显示模式。
2。在改回到正常的1440*900之后,3D能打开使用。

主板:
技嘉M61P ME-S2
该款主板集成显卡、声卡、网卡。
显示器:
Acer X 193W LCD (17寸液)

帮帮忙看看吧。现在3D效果用不成,而且也改不成1440*900的正常显示。
头像
想入非非
论坛版主
帖子: 8078
注册时间: 2008-07-14 22:42
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

Re: 显卡、显示器、3D---升级后出来的问题

#2

帖子 想入非非 » 2008-10-18 20:53

删除受限驱动。。。安装官方的 :em05
Ubuntu User
macromedia007
帖子: 17
注册时间: 2008-10-18 19:43
送出感谢: 0
接收感谢: 0

Re: 显卡、显示器、3D---升级后出来的问题

#3

帖子 macromedia007 » 2008-10-18 21:13

晕。
可以解决分辨率,但是不能解决3D启用的问题呀。
如果能两个问题一起解决是最优美的了,要是实在不能,我也只好不用3D,停了受限设备的驱动了。
macromedia007
帖子: 17
注册时间: 2008-10-18 19:43
送出感谢: 0
接收感谢: 0

Re: 显卡、显示器、3D---升级后出来的问题

#4

帖子 macromedia007 » 2008-10-19 10:38

唉。。。

总算弄出来1440*900,而且3D也可以用了
沙里飞
帖子: 7
注册时间: 2008-10-20 10:45
送出感谢: 0
接收感谢: 0

Re: 显卡、显示器、3D---升级后出来的问题

#5

帖子 沙里飞 » 2008-10-20 15:18

楼主讲讲怎么弄的啊!
急人啊!
macromedia007
帖子: 17
注册时间: 2008-10-18 19:43
送出感谢: 0
接收感谢: 0

Re: 显卡、显示器、3D---升级后出来的问题

#6

帖子 macromedia007 » 2008-10-20 19:59

沙里飞 写了:楼主讲讲怎么弄的啊!
急人啊!
这个。。。不太好说,可能是我乱碰,碰着的吧。
我先把NVidia那个受限驱动去掉不要,卸载掉了。重启,再安装了一次受限驱动,还是没有改过来。
再用一个nvidia-settings,看了一下 Display Configuratin里面的Advance,自定义了Paning1440*900。
然后再sudo gedit /etc/X11/xorg.conf
大致看了一下里面的内容。按别人说的,边猜边修理。
Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Acer X193W"
HorizSync 30.0 - 83.0
VertRefresh 55.0 - 75.0 //(1)

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
SubSection "Display"
Virtual 1440 900 //自己从800 600改成1440 900的
Depth 24
Modes "1440x900@51" "1024x768@60" "800x600@56" "640x480@60" //开始没有1440X900这一项,因为看到(1)处刷新率的范围,我就写了个1440*900@51

退出重启,就好了。现在就是1440*900。不过,我也是才使用这个系统,所以,我不知道上面我做这些动作,哪些才是真正使显示恢复正常的。瞎蒙的。
yyu0378
帖子: 208
注册时间: 2008-03-24 19:06
送出感谢: 0
接收感谢: 1 次

Re: 显卡、显示器、3D---升级后出来的问题

#7

帖子 yyu0378 » 2008-10-20 20:09

可能是核心升级了,你需要重新吧驱动在安装一遍就好了
回复

回到 “常用硬件支持”