当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 显卡、显示器、3D---升级后出来的问题
帖子发表于 : 2008-10-18 20:17 

注册: 2008-10-18 19:43
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
事件的经过是这样的:

昨天中午,安装好Ubuntu8.04 Desktop,显示器自动被设置为1440*900,正常LCD宽屏显示。无异常。

昨天下午,中文输入升级完成,自动提示更新几个小补丁。无异常。

昨天晚上,打开"硬件驱动",使用了“受限驱动设备”,叫NVidia加速驱动,然后是自动更新。升级完成,随后打开所有能够打开的3D,分辨率仍然为1440*900,正常LCD宽屏显示。无异常。

昨天深夜,因为自动更新的补丁太多,所以有空闲时间我就开着机器自动在更新,睡觉前,我让机器开着“更新管理器”自动更新检测的所有补丁,睡觉了。无异常。

今天早上,更新未完成,起来重新启动电脑,LCD闪了几下提示错误,大致意思是说检测不到合适的显卡,叫我手动选择,我按我的配置,选择了Acer X 193W LCD,分辨率选择为1440*900的正常的宽屏LCD显示,结果提示设置不成功,我只好用默认的800*600分辨率。进入系统之后,以前设置的3D已经不能使用,进入设置分辨率,里面也没有1440*900的选择项了。现在我用着800*600的,点击时,上下闪来闪去,点不准。

现在的问题就很明显了:
1。我想改回到正常的LCD宽屏显示模式。
2。在改回到正常的1440*900之后,3D能打开使用。

主板:
技嘉M61P ME-S2
该款主板集成显卡、声卡、网卡。
显示器:
Acer X 193W LCD (17寸液)

帮帮忙看看吧。现在3D效果用不成,而且也改不成1440*900的正常显示。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 显卡、显示器、3D---升级后出来的问题
帖子发表于 : 2008-10-18 20:53 
头像

注册: 2008-07-14 22:42
帖子: 8078
地址: Beijing
送出感谢: 0 次
接收感谢: 0 次
删除受限驱动。。。安装官方的 :em05


_________________
Ubuntu User


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 显卡、显示器、3D---升级后出来的问题
帖子发表于 : 2008-10-18 21:13 

注册: 2008-10-18 19:43
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
晕。
可以解决分辨率,但是不能解决3D启用的问题呀。
如果能两个问题一起解决是最优美的了,要是实在不能,我也只好不用3D,停了受限设备的驱动了。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 显卡、显示器、3D---升级后出来的问题
帖子发表于 : 2008-10-19 10:38 

注册: 2008-10-18 19:43
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
唉。。。

总算弄出来1440*900,而且3D也可以用了


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 显卡、显示器、3D---升级后出来的问题
帖子发表于 : 2008-10-20 15:18 

注册: 2008-10-20 10:45
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
楼主讲讲怎么弄的啊!
急人啊!


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 显卡、显示器、3D---升级后出来的问题
帖子发表于 : 2008-10-20 19:59 

注册: 2008-10-18 19:43
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
沙里飞 写道:
楼主讲讲怎么弄的啊!
急人啊!

这个。。。不太好说,可能是我乱碰,碰着的吧。
我先把NVidia那个受限驱动去掉不要,卸载掉了。重启,再安装了一次受限驱动,还是没有改过来。
再用一个nvidia-settings,看了一下 Display Configuratin里面的Advance,自定义了Paning1440*900。
然后再sudo gedit /etc/X11/xorg.conf
大致看了一下里面的内容。按别人说的,边猜边修理。
Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Acer X193W"
HorizSync 30.0 - 83.0
VertRefresh 55.0 - 75.0 //(1)

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
SubSection "Display"
Virtual 1440 900 //自己从800 600改成1440 900的
Depth 24
Modes "1440x900@51" "1024x768@60" "800x600@56" "640x480@60" //开始没有1440X900这一项,因为看到(1)处刷新率的范围,我就写了个1440*900@51

退出重启,就好了。现在就是1440*900。不过,我也是才使用这个系统,所以,我不知道上面我做这些动作,哪些才是真正使显示恢复正常的。瞎蒙的。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 显卡、显示器、3D---升级后出来的问题
帖子发表于 : 2008-10-20 20:09 

注册: 2008-03-24 19:06
帖子: 208
送出感谢: 0 次
接收感谢: 1
可能是核心升级了,你需要重新吧驱动在安装一遍就好了


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译