当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]如何在Ubuntu 6.06里手动安装ATI最新的官方驱动?
帖子发表于 : 2006-05-27 16:03 

注册: 2006-05-06 8:09
帖子: 22
送出感谢: 0 次
接收感谢: 0 次
默认安装后的Ubuntu 6.06要想安装ATI的官方驱动ati-driver-installer-8.25.18-x86.run,(非apt-get install安装)还需要先安装那些软件?

之所以舍近求远,因为我需要用到TV-OUT,用apt-get安装的好象没有ATI的控制面板,也没找到调整电视输入的选项。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-05-27 17:07 
头像

注册: 2006-05-02 2:11
帖子: 58
送出感谢: 0 次
接收感谢: 0 次
一想起这个就火大,下面是wiki上的方法,我照着这个一步一步装的,搞了好多次fglrxinfo里显示的还是Mesa Indirect !!!



Method 2: Generating/Installing Ubuntu packages for the 8.25.18 drivers in Ubuntu Dapper Manually

Important Change: Installation of this driver no longer requires removing the linux-restricted-modules package in order to work. There is a new blacklist feature in Ubuntu Dapper that you can use to go around this.
[edit]
Blacklist old fglrx module from linux-restricted-modules

sudo gedit /etc/default/linux-restricted-modules-common

Edit DISABLED_MODULES to include fglrx
File: /etc/default/linux-restricted-modules-common

DISABLED_MODULES="fglrx"

[edit]
Installing the new driver

Download the ATI driver installer: 32bit Installer

This guide refers to the 32bit version of the driver. If you are using a x86_64 System you need the 64bit Installer. The installation procedure should be the same as for 32bit, except some filenames will differ slightly.

Change to the download directory. Make sure that you have the universe and multiverse repositories enabled in /etc/apt/sources.list before doing these steps.

Install necessary tools:

sudo apt-get update
sudo apt-get install module-assistant build-essential
sudo apt-get install fakeroot dh-make debconf libstdc++5 gcc-3.3-base

Create .deb packages:

chmod +x ati-driver-installer-8.25.18-x86.run
./ati-driver-installer-8.25.18-x86.run --buildpkg Ubuntu/dapper

Install .deb packages:

sudo dpkg -i xorg-driver-fglrx_8.25.18-1_i386.deb
sudo dpkg -i fglrx-kernel-source_8.25.18-1_i386.deb
sudo dpkg -i fglrx-control_8.25.18-1_i386.deb

Remove any old fglrx deb's from /usr/src/:

sudo rm /usr/src/fglrx-kernel*.deb

Compile the kernel module:

sudo module-assistant prepare,update
sudo module-assistant build,install fglrx

Note: You have to recompile the kernel module after each kernel update!

Update the xorg.conf file:

sudo aticonfig --initial
sudo aticonfig --overlay-type=Xv

Reboot.
[edit]
Confirm that it worked

$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9700 Generic
OpenGL version string: 2.0.5814 (8.25.18)

[edit]
Troubleshooting
[edit]
General

The output of dmesg | grep fglrx and /var/log/Xorg.0.log are most useful when looking for errors.
[edit]
HP Notebook PC

If you have an HP Notebook Computer (or Compaq) such as the HP dv5029dvus or zv6000 series, it is needed to modify the BIOS configuration. It seems for some reason using sideport memory (the card's onboard memory only) leads to an apparent system crash although the logs show successful initialization of DRI. It is needed to run the BIOS setup screen, go to memory options, and select UMA+Sideport memory and assign a value to it (I assigned an extra 128M from the system RAM). Boot the computer and the fglrx driver will work. FGLRX version is 8.24.8 on an i386 Ubuntu Dapper install.
[edit]
HP zt3000 / Compaq (???)

Beginning with ATI driver version 8.19, the drivers fail to properly detect modelines that are compatible with the LCD screen of the HP zt3000 (and equivalent Compaq model), and they must be inserted into xorg.conf manually. For the 1680x1050 LCD screen, inserting the following modelines into the "Monitor" section works:

Modeline "640x350" 119.12 640 1728 1760 1840 350 1052 1058 1080
Modeline "640x400" 119.12 640 1728 1760 1840 400 1052 1058 1080
Modeline "720x400" 119.12 720 1728 1760 1840 400 1052 1058 1080
Modeline "640x480" 119.12 640 1728 1760 1840 480 1052 1058 1080
Modeline "800x600" 119.12 800 1728 1760 1840 600 1052 1058 1080
Modeline "1024x768" 119.12 1024 1728 1760 1840 768 1052 1058 1080
Modeline "1152x864" 119.12 1152 1728 1760 1840 864 1052 1058 1080
Modeline "1280x960" 119.12 1280 1728 1760 1840 960 1052 1058 1080
Modeline "1280x1024" 119.12 1280 1728 1760 1840 1024 1052 1058 1080
Modeline "832x624" 119.12 832 1728 1760 1840 624 1052 1058 1080
Modeline "1280x768" 119.12 1280 1728 1760 1840 768 1052 1058 1080
Modeline "1280x800" 119.12 1280 1728 1760 1840 800 1052 1058 1080
Modeline "1152x768" 119.12 1152 1728 1760 1840 768 1052 1058 1080
Modeline "1400x1050" 119.12 1400 1728 1760 1840 1050 1052 1058 1080
Modeline "1440x900" 119.12 1440 1728 1760 1840 900 1052 1058 1080
Modeline "1600x1024" 119.12 1600 1728 1760 1840 1024 1052 1058 1080
Modeline "1680x1050" 119.12 1680 1728 1760 1840 1050 1052 1058 1080

[edit]
Revert to Xorg driver

If (for any reason) the fglrx install fails, you can revert to the Xorg driver by executing

sudo dpkg-reconfigure xserver-xorg

and selecting the "ati" driver.
Retrieved from "http://wiki.cchtml.com/index.php/Ubuntu_Dapper_Installation_Guide"


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-05-27 21:49 
头像

注册: 2005-09-10 16:04
帖子: 3537
地址: DG-GD-China
送出感谢: 0 次
接收感谢: 0 次
你这是非官方的wiki。


_________________
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-05-28 16:33 
头像

注册: 2006-05-02 2:11
帖子: 58
送出感谢: 0 次
接收感谢: 0 次
这个驱动绝对有点问题,我在Dapper下和SuSE10.1上都装过,都没成功,特别是在SuSE下装的时候,安装和编译一点错误都没有,但是fglrxinfo显示一大堆错误:Dapper下也一样.
[fglrx] API ERROR: could not register entrypoint for SelectTextureSGIS
[fglrx] API ERROR: could not register entrypoint for SelectTextureTransformSGIS
[fglrx] API ERROR: could not register entrypoint for ClientActiveVertexStreamATI[fglrx] API ERROR: could not register entrypoint for VertexBlendEnviATI
[fglrx] API ERROR: could not register entrypoint for VertexBlendEnvfATI
[fglrx] API ERROR: could not register entrypoint for VertexStream2sATI
[fglrx] API ERROR: could not register entrypoint for VertexStream2svATI
[fglrx] API ERROR: could not register entrypoint for VertexStream2iATI
[fglrx] API ERROR: could not register entrypoint for VertexStream2ivATI
[fglrx] API ERROR: could not register entrypoint for VertexStream2fATI
[fglrx] API ERROR: could not register entrypoint for VertexStream2fvATI
后面还有一大堆,我不粘了 :(


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-05-29 7:38 

注册: 2006-05-29 7:31
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
我也搞不定


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-05-29 8:34 

注册: 2005-09-09 18:13
帖子: 141
送出感谢: 0 次
接收感谢: 0 次
等着官方源吧


_________________
给我一个支点,我可以撬起地球仪!
Ubuntu Edgy Eft
Thinkpad T60
T2300(1.66G) 512M(667MHz) X1300(64M) 60G


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-05-29 16:35 

注册: 2006-05-25 12:00
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
成功驱动,ubuntu6.06 for 64AMD ,ati x200M
我是卸载原来的驱动后,sh ./ati-driver-installer-8.25.18-x86_64.run --buildpkg Ubuntu/6.06.
找到生成deb包目录,dpkg -i *.deb,
再编译核心驱动,好在没什么错误.但进入桌面,ati控制面板打不开,从终端输入fireglcontrolpanel,显示找不到libGl.**<--叫什么记不清了,只好reboot,再自动安装,呵呵,行了。


附件:
Screenshot-1.png
Screenshot-1.png [ 244.68 KiB | 被浏览 642 次 ]

Screenshot.png
Screenshot.png [ 80.5 KiB | 被浏览 630 次 ]

页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-05-29 17:04 
头像

注册: 2005-09-10 16:04
帖子: 3537
地址: DG-GD-China
送出感谢: 0 次
接收感谢: 0 次
ellickif 写道:
这个驱动绝对有点问题,我在Dapper下和SuSE10.1上都装过,都没成功,特别是在SuSE下装的时候,安装和编译一点错误都没有,但是fglrxinfo显示一大堆错误:Dapper下也一样.
[fglrx] API ERROR: could not register entrypoint for SelectTextureSGIS
[fglrx] API ERROR: could not register entrypoint for SelectTextureTransformSGIS
[fglrx] API ERROR: could not register entrypoint for ClientActiveVertexStreamATI[fglrx] API ERROR: could not register entrypoint for VertexBlendEnviATI
[fglrx] API ERROR: could not register entrypoint for VertexBlendEnvfATI
[fglrx] API ERROR: could not register entrypoint for VertexStream2sATI
[fglrx] API ERROR: could not register entrypoint for VertexStream2svATI
[fglrx] API ERROR: could not register entrypoint for VertexStream2iATI
[fglrx] API ERROR: could not register entrypoint for VertexStream2ivATI
[fglrx] API ERROR: could not register entrypoint for VertexStream2fATI
[fglrx] API ERROR: could not register entrypoint for VertexStream2fvATI
后面还有一大堆,我不粘了 :(


你的CPU是32还是64的,你下载的驱动是32还是64的?驱动版本正确没?
既然有人成功,那说明驱动应该没问题的。


_________________
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-05-31 23:52 
头像

注册: 2005-09-10 16:04
帖子: 3537
地址: DG-GD-China
送出感谢: 0 次
接收感谢: 0 次
调出ATI control panel 的命令是什么?


_________________
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-06-05 12:39 

注册: 2006-02-02 13:55
帖子: 26
送出感谢: 0 次
接收感谢: 0 次
fireglcontrol


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2006-06-09 11:24 

注册: 2006-03-24 20:22
帖子: 21
送出感谢: 0 次
接收感谢: 0 次
我也没有成功过,安装了两次。结果还是老老实实的用源里的驱动。哪位大虾安装成功了贴出分享下。
我的是x300.
另外,这个驱动有什么好的?反正用linux也很少玩游戏。


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2006-06-09 13:22 

注册: 2005-11-08 10:12
帖子: 224
送出感谢: 0 次
接收感谢: 0 次
安装了内核对应的模块没有?
没有的话,装上看看。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译