当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu 8.04安装madwifi注入驱动的问题,airmon-ng start wifi0 没用,求助!
帖子发表于 : 2008-10-30 10:48 

注册: 2008-05-09 15:36
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
ubuntu 8.04系统内核更新到2.6.24-21,Cisco CB21AG-A-K9网卡,安装过程如下:

ifconfig ath0 down
ifconfig wifi0 down
svn -r 3745 checkout http://svn.madwifi.org/madwifi/trunk/ madwifi-ng
wget http://patches.aircrack-ng.org/madwifi-ng-r3745.patch
cd madwifi-ng
patch -Np1 -i ../madwifi-ng-r3745.patch
./scripts/madwifi-unload
make
make install
depmod -ae
modprobe ath_pci


按照aircrack-ng网站的教程安装的,输入airmon-ng start wifi0显示
airmon-ng start wifi0


Interface Chipset Driver

eth1 Intel 2200BG ipw2200
ath0 Atheros madwifi-ng VAP (parent: wifi0)


没有出现ath1 就是那个监听monitor的端口,只能手动输入下面命令才能打开监听端口

ifconfig ath0 down
wlanconfig ath0 destroy
wlanconfig ath0 create wlandev wifi0 wlanmode monitor
ifconfig ath0 up
现在ath0处于监听状态,但是就不能上网了要上网的话只能再手动切换回来,不过所有aircrack-ng 套件都能正常使用;我试了在backtrack 3 beta 里面写在驱动再安装在输入airmon-ng start wifi0命令也出现错误,但能打开监听端口,请问诸位是怎么安装注入驱动的,还请告知,谢谢!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: ubuntu 8.04安装madwifi注入驱动的问题,airmon-ng start wifi0 没用,求助!
帖子发表于 : 2008-10-30 10:50 

注册: 2008-05-09 15:36
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
网卡列表:
ifconfig -a
ath0 Link encap:以太网 硬件地址 00:XX:XX:a5:b3:42
UP BROADCAST MULTICAST MTU:1500 跃点数:1
接收数据包:48 错误:0 丢弃:0 过载:0 帧数:0
发送数据包:71 错误:0 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:0
接收字节:6614 (6.4 KB) 发送字节:9211 (8.9 KB)

eth0 Link encap:以太网 硬件地址 00:XX:XX:0b:XX:ec
inet 地址:192.168.13.142 广播:192.168.13.255 掩码:255.255.255.0
inet6 地址: fe80::215:58ff:fe0b:eeec/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 跃点数:1
接收数据包:2193 错误:0 丢弃:0 过载:0 帧数:0
发送数据包:2420 错误:0 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:1000
接收字节:2286963 (2.1 MB) 发送字节:338655 (330.7 KB)
中断:16

eth1 Link encap:以太网 硬件地址 00:XX:XX:0b:XX:XX
UP BROADCAST MULTICAST MTU:1500 跃点数:1
接收数据包:20888 错误:0 丢弃:0 过载:0 帧数:0
发送数据包:2397 错误:0 丢弃:0 过载:0 载波:1
碰撞:0 发送队列长度:1000
接收字节:4230 (4.1 KB) 发送字节:9244 (9.0 KB)
中断:23 基本地址:0xa000 Memory:a8401000-a8401fff

lo Link encap:本地环回
inet 地址:127.0.0.1 掩码:255.0.0.0
inet6 地址: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 跃点数:1
接收数据包:4748 错误:0 丢弃:0 过载:0 帧数:0
发送数据包:4748 错误:0 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:0
接收字节:237400 (231.8 KB) 发送字节:237400 (231.8 KB)

rtap0 Link encap:未指定 硬件地址 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
BROADCAST MULTICAST MTU:1500 跃点数:1
接收数据包:0 错误:0 丢弃:0 过载:0 帧数:0
发送数据包:0 错误:0 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:1000
接收字节:0 (0.0 B) 发送字节:0 (0.0 B)

wifi0 Link encap:未指定 硬件地址 XX:XX:XX:XX:XX-00-00-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 跃点数:1
接收数据包:8673 错误:0 丢弃:0 过载:0 帧数:373
发送数据包:1343 错误:14 丢弃:0 过载:0 载波:0
碰撞:0 发送队列长度:280
接收字节:1170950 (1.1 MB) 发送字节:91797 (89.6 KB)
中断:16


页首
 用户资料  
 
3 楼 
 文章标题 : Re: ubuntu 8.04安装madwifi注入驱动的问题,airmon-ng start wifi0 没用,求助!
帖子发表于 : 2009-01-26 21:24 

注册: 2008-01-05 12:31
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
我用8.10也遇到了同样的问题,不过好像只需要wlanconfig ath1 create wlandev wifi0 wlanmode monitor就可以打开ath1?airodump-ng中也能截取到数据。。。但是同时就不能上网了,也就是说aircrack-ng和网络浏览不能同时起作用。。。希望得到高人指教~
(我在8.04的时候完全没有你所遇到的问题可是。。。网卡是Atheros5424)


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Bing [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译