安装ATI显卡驱动时第一步就遇到sh版本不对的错误

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
netmask254
帖子: 24
注册时间: 2008-11-05 22:11
送出感谢: 0
接收感谢: 0

安装ATI显卡驱动时第一步就遇到sh版本不对的错误

#1

帖子 netmask254 » 2008-11-05 22:14

哪位神仙帮忙看看?不知道什么意思。

yuhao@ubuntu:~/drivers$ ls
ati-driver-installer-8-10-x86.x86_64.run
yuhao@ubuntu:~/drivers$ sudo sh ati-driver-installer-8-10-x86.x86_64.run
Created directory fglrx-install.P12271
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.542...........................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
==================================================
ATI Technologies Linux Driver Installer/Packager
==================================================

Error: ./default_policy.sh does not support version
default:v2:x86_64:lib::none:2.6.27-7-generic; make sure that the version is being
correctly set by --iscurrentdistro

Removing temporary directory: fglrx-install.P12271
hfsp
帖子: 21
注册时间: 2008-10-31 18:26
送出感谢: 0
接收感谢: 0

Re: 安装ATI显卡驱动时第一步就遇到sh版本不对的错误

#2

帖子 hfsp » 2008-11-05 23:07

我也一直没出现那个安装界面,提示与楼主的差不多。用从网上能找到的各种方法都试过就是安装不上。只有用8.04加强V2版时自动 安装过开源驱动的。但刷新率也太低了点,现在用的8.10怎么也安装不上9200SE的驱动。
netmask254
帖子: 24
注册时间: 2008-11-05 22:11
送出感谢: 0
接收感谢: 0

Re: 安装ATI显卡驱动时第一步就遇到sh版本不对的错误

#3

帖子 netmask254 » 2008-11-06 9:23

BTW, 我装的是Ubuntu 8.10 64-bit简体中文版,是wubi安装模式,显卡是HD3650。以前8.04版本时成功搞定过,这次没想到第一步就卡住了。

楼上的你有强制打开过受限驱动么,会不会黑屏。
netmask254
帖子: 24
注册时间: 2008-11-05 22:11
送出感谢: 0
接收感谢: 0

Re: 安装ATI显卡驱动时第一步就遇到sh版本不对的错误

#4

帖子 netmask254 » 2008-11-06 10:48

之前已经有帖子了 :em03

viewtopic.php?f=42&t=162547
kane_9909
帖子: 88
注册时间: 2007-05-09 14:34
送出感谢: 0
接收感谢: 0

Re: 安装ATI显卡驱动时第一步就遇到sh版本不对的错误

#5

帖子 kane_9909 » 2008-11-06 12:58

用buildpkg Ubuntu/8.10 把deb编译出来手动装或者直接下Ubuntu 8.10自带的fglrx,那个比这个ms还新一点
hfsp
帖子: 21
注册时间: 2008-10-31 18:26
送出感谢: 0
接收感谢: 0

Re: 安装ATI显卡驱动时第一步就遇到sh版本不对的错误

#6

帖子 hfsp » 2008-11-06 17:39

kane_9909 写了:用buildpkg Ubuntu/8.10 把deb编译出来手动装或者直接下Ubuntu 8.10自带的fglrx,那个比这个ms还新一点
能不能说清楚点呀,怎么下ubuntu 8.10自带的fglrx,我按网上的教程没一个方法成功的。我的显卡是9200SE的哟。五楼的能不能说清楚点,“buildpkg Ubuntu/8.10”是什么意思?我是菜鸟呀!
kane_9909
帖子: 88
注册时间: 2007-05-09 14:34
送出感谢: 0
接收感谢: 0

Re: 安装ATI显卡驱动时第一步就遇到sh版本不对的错误

#7

帖子 kane_9909 » 2008-11-06 17:52

ubuntu 8.10 里面带了一个xorg-driver-fglrx,用那个就可以吧,比官方网页上的还新一点,是8.543的。
上次由 kane_9909 在 2008-11-06 18:11,总共编辑 1 次。
kane_9909
帖子: 88
注册时间: 2007-05-09 14:34
送出感谢: 0
接收感谢: 0

Re: 安装ATI显卡驱动时第一步就遇到sh版本不对的错误

#8

帖子 kane_9909 » 2008-11-06 18:10

lwcmain
帖子: 81
注册时间: 2008-07-13 10:09
送出感谢: 0
接收感谢: 0

Re: 安装ATI显卡驱动时第一步就遇到sh版本不对的错误

#9

帖子 lwcmain » 2008-11-06 19:15

楼上所说的方式经测试在我的机子上行不通,我的是移动版9600
kane_9909
帖子: 88
注册时间: 2007-05-09 14:34
送出感谢: 0
接收感谢: 0

Re: 安装ATI显卡驱动时第一步就遇到sh版本不对的错误

#10

帖子 kane_9909 » 2008-11-06 19:53

你的是8.10吗?装完后试试sudo aticonfig --initial再sudo aticonfig --ovt=Xv然后重启一下。
lwcmain
帖子: 81
注册时间: 2008-07-13 10:09
送出感谢: 0
接收感谢: 0

Re: 安装ATI显卡驱动时第一步就遇到sh版本不对的错误

#11

帖子 lwcmain » 2008-11-06 20:26

输入楼上给的命令后,出现以下数据,
lwcmain@lwcmain-desktop:~$ sudo aticonfig --initial
Uninitialised file found, configuring.
段错误
lwcmain@lwcmain-desktop:~$ sudo aticonfig --ovt=Xv
No layout section was found in the file: '/etc/X11/xorg.conf'.
Please run 'aticonfig --initial' first or modify your configurationfile manually and run aticonfig again.
aticonfig: parsing the command-line failed.

看不懂是什么意思
lwcmain
帖子: 81
注册时间: 2008-07-13 10:09
送出感谢: 0
接收感谢: 0

Re: 安装ATI显卡驱动时第一步就遇到sh版本不对的错误

#12

帖子 lwcmain » 2008-11-06 20:26

我的系统是8.10版本的
kane_9909
帖子: 88
注册时间: 2007-05-09 14:34
送出感谢: 0
接收感谢: 0

Re: 安装ATI显卡驱动时第一步就遇到sh版本不对的错误

#13

帖子 kane_9909 » 2008-11-09 12:03

你的sudo aticonfig --initial这一步出错了,是最新的ati驱动吗?是源里面的那个还是官网上的呢?可以换一个试试。
lwcmain
帖子: 81
注册时间: 2008-07-13 10:09
送出感谢: 0
接收感谢: 0

Re: 安装ATI显卡驱动时第一步就遇到sh版本不对的错误

#14

帖子 lwcmain » 2008-11-09 12:07

是源里的,最新的,是8.543的
kane_9909
帖子: 88
注册时间: 2007-05-09 14:34
送出感谢: 0
接收感谢: 0

Re: 安装ATI显卡驱动时第一步就遇到sh版本不对的错误

#15

帖子 kane_9909 » 2008-11-09 15:34

有段错误这个不太清楚怎么回事,可以试试用官网上的吗?要不envy的呢?
回复

回到 “常用硬件支持”