当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 15 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 蓝牙适配器问题
帖子发表于 : 2008-11-12 11:06 

注册: 2007-08-29 22:44
帖子: 320
送出感谢: 0 次
接收感谢: 0 次
系统是ubuntu8.10,适配器是USB接口的。前面几个版本的Ubuntu都可以正常使用这个蓝牙适配器,主要就是用来传一些文件到我的手机。
现在的问题是用电脑搜手机可以搜到,但就是配对不了。用手机也可以搜到电脑,也可以配对,但是只能到这一步,配对完之后文件什么的都传不了。什么事都干不了,
该装的软件都装了。还请高手帮忙。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 蓝牙适配器问题
帖子发表于 : 2008-11-17 19:33 
头像

注册: 2008-11-13 20:27
帖子: 257
地址: 台灣
送出感谢: 0 次
接收感谢: 2
同問題
:em11


_________________
ASUS W7SG
UBUNTU 13.04


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 蓝牙适配器问题
帖子发表于 : 2008-11-18 9:05 

注册: 2007-05-11 9:21
帖子: 65
送出感谢: 0 次
接收感谢: 0 次
推荐使用blueman,感觉比系统自带的蓝牙管理好用


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 蓝牙适配器问题
帖子发表于 : 2008-11-19 16:27 

注册: 2007-08-29 22:44
帖子: 320
送出感谢: 0 次
接收感谢: 0 次
ausun 写道:
推荐使用blueman,感觉比系统自带的蓝牙管理好用

blueman在ubuntu8.10中无法安装。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 蓝牙适配器问题
帖子发表于 : 2008-11-20 20:25 

注册: 2007-05-11 9:21
帖子: 65
送出感谢: 0 次
接收感谢: 0 次
在 /etc/apt/sources.list 里面加上下面这句,然后在新立德里reload,这样就可以安装blueman了。我在8.10 amd64里用的不错。
代码:
deb http://ppa.launchpad.net/blueman/ubuntu intrepid main


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 蓝牙适配器问题
帖子发表于 : 2008-11-20 20:51 
头像

注册: 2008-11-13 20:27
帖子: 257
地址: 台灣
送出感谢: 0 次
接收感谢: 2
ausun大大
你可以使用藍芽免持耳機跟立體聲耳機嗎?
我是連接的上但聲音不知如何切換
我是在服務內的聲音連接的


_________________
ASUS W7SG
UBUNTU 13.04


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 蓝牙适配器问题
帖子发表于 : 2008-11-21 8:42 

注册: 2007-05-11 9:21
帖子: 65
送出感谢: 0 次
接收感谢: 0 次
我用过蓝牙立体声耳机,连接后用下面的命令可以测试
代码:
aplay -D bluetooth test.wav

可能还需要事先修改 ~/.asoundrc 文件,记不清了,很早前试的。在其他播放器里使用要选择蓝牙作为音频播放设备,一般的播放软件都有相关设置


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 蓝牙适配器问题
帖子发表于 : 2008-11-21 10:59 
头像

注册: 2008-11-13 20:27
帖子: 257
地址: 台灣
送出感谢: 0 次
接收感谢: 2
下達指令後~出現
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM bluetooth
aplay: main:546: audio open error: 沒有此一檔案或目錄

怎麼回事


_________________
ASUS W7SG
UBUNTU 13.04


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 蓝牙适配器问题
帖子发表于 : 2008-11-21 11:25 

注册: 2007-08-29 22:44
帖子: 320
送出感谢: 0 次
接收感谢: 0 次
ausun 写道:
在 /etc/apt/sources.list 里面加上下面这句,然后在新立德里reload,这样就可以安装blueman了。我在8.10 amd64里用的不错。
代码:
deb http://ppa.launchpad.net/blueman/ubuntu intrepid main

我也是添加源后安装的,可是你看。
lj@lj-desktop:~$ sudo apt-get install blueman
[sudo] password for lj:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
blueman: 依赖: libbluetooth2 (>= 3.14) 但却无法安装它
E: 无法安装的软件包


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 蓝牙适配器问题
帖子发表于 : 2008-11-21 11:59 
头像

注册: 2008-11-13 20:27
帖子: 257
地址: 台灣
送出感谢: 0 次
接收感谢: 2
我是8.04
照官網上的指示就可以再套件庫找到

代码:
wget -q http://download.tuxfamily.org/blueman/blueman.gpg -O- | sudo apt-key add -
sudo wget http://download.tuxfamily.org/blueman/hardy.list -O /etc/apt/sources.list.d/blueman.list
sudo apt-get update


然後去套件庫找就有了


_________________
ASUS W7SG
UBUNTU 13.04


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 蓝牙适配器问题
帖子发表于 : 2008-11-21 12:09 

注册: 2007-05-11 9:21
帖子: 65
送出感谢: 0 次
接收感谢: 0 次
平凡達人 写道:
下達指令後~出現
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM bluetooth
aplay: main:546: audio open error: 沒有此一檔案或目錄

怎麼回事


在 ~/.asoundrc(没有就创建)里添加下面这段:
代码:
pcm.bluetooth {
  type bluetooth
  device xx:xx:xx:xx:xx:xx
  profile "auto"
}

其中device后面是你的蓝牙设备地址。现在应该可以用aplay播放了。如果还不行参考下面这个网页,执行一下前面的9个步骤
http://ubuntuforums.org/showthread.php?t=786640


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 蓝牙适配器问题
帖子发表于 : 2008-11-21 12:17 

注册: 2007-08-29 22:44
帖子: 320
送出感谢: 0 次
接收感谢: 0 次
平凡達人 写道:
我是8.04
照官網上的指示就可以再套件庫找到

代码:
wget -q http://download.tuxfamily.org/blueman/blueman.gpg -O- | sudo apt-key add -
sudo wget http://download.tuxfamily.org/blueman/hardy.list -O /etc/apt/sources.list.d/blueman.list
sudo apt-get update


然後去套件庫找就有了

问题是我现在用的是ubuntu8.10的,那个软件的版本太高,既然也不能安装的。


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 蓝牙适配器问题
帖子发表于 : 2008-11-21 14:54 
头像

注册: 2008-11-13 20:27
帖子: 257
地址: 台灣
送出感谢: 0 次
接收感谢: 2
ausun 写道:
平凡達人 写道:
下達指令後~出現
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM bluetooth
aplay: main:546: audio open error: 沒有此一檔案或目錄

怎麼回事


在 ~/.asoundrc(没有就创建)里添加下面这段:
代码:
pcm.bluetooth {
  type bluetooth
  device xx:xx:xx:xx:xx:xx
  profile "auto"
}

其中device后面是你的蓝牙设备地址。现在应该可以用aplay播放了。如果还不行参考下面这个网页,执行一下前面的9个步骤
http://ubuntuforums.org/showthread.php?t=786640



依照他的方式
執行測試時
代码:
arecord -D bluetooth -f s16_LE test.wav


有聽到耳機出現嘶~~的聲音
是否表示測試成功呢?
但我開其他播放氣時依然是從喇叭出來
還是需要做設定
我用的播放器是amarok
謝謝


_________________
ASUS W7SG
UBUNTU 13.04


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 蓝牙适配器问题
帖子发表于 : 2008-11-21 21:10 

注册: 2007-05-11 9:21
帖子: 65
送出感谢: 0 次
接收感谢: 0 次
arecord是用来录音的,播放要使用aplay。可以用pidgin带的wav进行测试
代码:
cd /usr/share/sounds/purple
aplay -D bluetooth login.wav


音乐播放软件的选项里一般有音频设备的设置,amarok没用过,不知道有没有


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 蓝牙适配器问题
帖子发表于 : 2008-11-21 21:29 
头像

注册: 2008-11-13 20:27
帖子: 257
地址: 台灣
送出感谢: 0 次
接收感谢: 2
ausun 大大
你是用哪一套播放軟件


_________________
ASUS W7SG
UBUNTU 13.04


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 15 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译