当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 37 篇帖子 ]  前往页数 1, 2, 3  下一页
作者 内容
1 楼 
 文章标题 : ATI受限驱动与开源驱动使用感觉
帖子发表于 : 2008-11-12 13:31 

注册: 2008-09-12 10:07
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
我的机器是IBM T43,ATI Mobility Radeon X300 显卡,按照论坛置顶贴的建议,一直使用开源驱动,到8.10后双屏显示的问题从“屏幕分辨率“就可以解决了,视频播放也很好,但就是不能开动画和特效,一开就经常死机,还好我也不是很追求桌面炫丽,所以就一直关闭动画和特效使用,一切正常。但前两天还是经不住手痒,装了Mac4lin的主题和AWN桌面导航,再开启动画和特效,按照系统提示安装了受限显卡驱动,桌面变得漂亮了很多,也不会死机了,但却出现了一个新问题,用mplayer播放视频不行了,原来开源驱动的时候用的是xv模式,装了受限驱动后改用x11模式才可以,但视频不能放大,只能用原始尺寸观看,而且所有3D的屏保一开屏幕都会闪烁得非常严重。难道这是受限驱动所固有的问题吗,是否有什么好的解决办法呢,请高人赐教!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: ATI受限驱动与开源驱动使用感觉
帖子发表于 : 2008-11-12 14:31 

注册: 2007-09-27 13:31
帖子: 52
送出感谢: 0 次
接收感谢: 0 次
我和楼主的本本一样,8.10目前就只能这样了,无论是开源,受限的闭源还是amd网站上最新的2进制驱动(这个8.10版本的驱动我根本就装不了,提示版本错误),你这样都已经是最好状况了。Mplayer的听说可以用打补丁的方式解决闪烁问题,我在8.04试过是OK的。

有个帖子是说需要驱动升级,现在没法子。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: ATI受限驱动与开源驱动使用感觉
帖子发表于 : 2008-11-12 14:52 
头像

注册: 2006-11-23 15:47
帖子: 164
送出感谢: 0 次
接收感谢: 2
一样的,屏幕闪烁在N个版本前就有了,官方的闭源驱动bug多得可以用“一堆”来形容~~~~~
相比,看看N卡那边的驱动要完善多了。无论从安装人性化方面,还是驱动稳定性上面都比A卡强

反正楼主那快也是块老显卡了,开源驱动是楼主的唯一选择,bug比官方的少多了。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: ATI受限驱动与开源驱动使用感觉
帖子发表于 : 2008-12-23 21:38 

注册: 2008-09-12 10:07
帖子: 46
送出感谢: 0 次
接收感谢: 0 次
我有换回开源驱动了,compiz, awn照样能用,只是好象3D反应稍慢一点,但视频不卡了,权衡利弊,还是换回来吧。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: ATI受限驱动与开源驱动使用感觉
帖子发表于 : 2008-12-23 21:43 
头像

注册: 2008-12-19 13:44
帖子: 2337
地址: 东8区
送出感谢: 0 次
接收感谢: 0 次
为了性能舍弃华丽好了。ATI用户的悲哀,我的是HD3200装受限的驱动开特效,登录界面会缩小
看电影也会一闪一闪的。其他的好说


_________________
代码:
 
       \   ,__,
        \  (oo)____
           (__)    )\
              ||--|| * 
 


页首
 用户资料  
 
6 楼 
 文章标题 : Re: ATI受限驱动与开源驱动使用感觉
帖子发表于 : 2008-12-25 0:06 

注册: 2008-07-01 22:53
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
官方驱动
看视频闪烁的问题可以解决的
你只要把特效关闭的话
看视频就可以了

反正电影和特效不能同时出现


页首
 用户资料  
 
7 楼 
 文章标题 : Re: ATI受限驱动与开源驱动使用感觉
帖子发表于 : 2008-12-27 1:19 

注册: 2008-10-28 20:18
帖子: 3249
送出感谢: 0 次
接收感谢: 0 次
ATI 官方发布的安装官方驱动指南 : http://wiki.cchtml.com/index.php/Ubuntu ... tion_Guide

第一步:下载官方驱动,假设我们驱动下载后存放的位置在 /home 目录下,驱动下载后的文件名为 ati-driver-installer-8-12-x86.x86_64.run

第二步:创建 deb 安装包 , 打开终端如下操作
cd /home
sudo sh ati-driver-installer-8-12-x86.x86_64.run --buildpkg Ubuntu/intrepid

第三步:安装 deb 包
32位操作系统下:
sudo dpkg -i xorg-driver-fglrx_8.561-0ubuntu1_i386.deb fglrx-kernel-source_8.561-0ubuntu1_i386.deb fglrx-amdcccle_8.561-0ubuntu1_i386.deb

64位操作系统下:(INTEL的64位处理器也一样)
sudo dpkg -i xorg-driver-fglrx_8.561-0ubuntu1_amd64.deb fglrx-kernel-source_8.561-0ubuntu1_amd64.deb fglrx-amdcccle_8.561-0ubuntu1_amd64.deb

第四步:在 /etc/X11/xorg.conf 中关联 ATI 官方驱动 及启用 Xv 视频模式
sudo aticonfig --initial -f
sudo aticonfig --overlay-type=Xv

第五步: 重启计算机


最后由 ryoohki 编辑于 2009-01-10 3:25,总共编辑了 2 次

页首
 用户资料  
 
8 楼 
 文章标题 : Re: ATI受限驱动与开源驱动使用感觉
帖子发表于 : 2008-12-27 9:44 
头像

注册: 2008-07-21 9:44
帖子: 2371
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
ryoohki 写道:
ATI 官方发布的安装官方驱动指南 : http://wiki.cchtml.com/index.php/Ubuntu ... tion_Guide

第一步:下载官方驱动,假设我们驱动下载的位置在 /home 目录下,驱动的文件名为 ati-driver-installer-8-12-x86.x86_64.run

第二步:创建 deb 安装包 , 打开终端如下操作
cd /home
sudo sh ati-driver-installer-8-12-x86.x86_64.run --buildpkg Ubuntu/intrepid

第三步:安装 deb 包
32位操作系统下:
sudo dpkg -i xorg-driver-fglrx_8.561-0ubuntu1_i386.deb fglrx-kernel-source_8.561-0ubuntu1_i386.deb fglrx-amdcccle_8.561-0ubuntu1_i386.deb

64位操作系统下:
sudo dpkg -i xorg-driver-fglrx_8.561-0ubuntu1_amd64.deb fglrx-kernel-source_8.561-0ubuntu1_amd64.deb fglrx-amdcccle_8.561-0ubuntu1_amd64.deb

第四步:在 /etc/X11/xorg.conf 中关联 ATI 官方驱动 及启用 Xv 视频模式
sudo aticonfig --initial -f
sudo aticonfig --overlay-type=Xv

第五步: 重启操作系统


学习了……


页首
 用户资料  
 
9 楼 
 文章标题 : Re: ATI受限驱动与开源驱动使用感觉
帖子发表于 : 2008-12-27 11:16 

注册: 2008-07-13 10:09
帖子: 79
送出感谢: 0 次
接收感谢: 0 次
楼上的帮我看看,我照着要求做了,出现了错误

lwcmain@lwcmain-desktop:~$ sudo sh ati-driver-installer-8-12-x86.x86_64.run --buildpkg Ubuntu/intrepid
Created directory fglrx-install.HM5582
Verifying archive integrity...Error in MD5 checksums: 9bb7110fec9cc9d0a034c9fa4f6182ff is different from 6cdbeb70d9046ad9dd5e5636a2db7c79
lwcmain@lwcmain-desktop:~$ sudo dpkg -i xorg-driver-fglrx_8.561-0ubuntu1_i386.deb fglrx-kernel-source_8.561-0ubuntu1_i386.deb fglrx-amdcccle_8.561-0ubuntu1_i386.deb
dpkg:处理 xorg-driver-fglrx_8.561-0ubuntu1_i386.deb (--install)时出错:
无法访问打包文件: 没有该文件或目录
dpkg:处理 fglrx-kernel-source_8.561-0ubuntu1_i386.deb (--install)时出错:
无法访问打包文件: 没有该文件或目录
dpkg:处理 fglrx-amdcccle_8.561-0ubuntu1_i386.deb (--install)时出错:
无法访问打包文件: 没有该文件或目录
在处理时有错误发生:
xorg-driver-fglrx_8.561-0ubuntu1_i386.deb
fglrx-kernel-source_8.561-0ubuntu1_i386.deb
fglrx-amdcccle_8.561-0ubuntu1_i386.deb

我的系统是8.10的,32位。显卡是ATI Mobility 9600
能不能帮我看一下是哪的问题


页首
 用户资料  
 
10 楼 
 文章标题 : Re: ATI受限驱动与开源驱动使用感觉
帖子发表于 : 2008-12-30 11:20 
头像

注册: 2008-12-30 11:13
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
ati的真悲哀 :em06


_________________
神说,多好是好啊……


页首
 用户资料  
 
11 楼 
 文章标题 : Re: ATI受限驱动与开源驱动使用感觉
帖子发表于 : 2008-12-30 11:21 
头像

注册: 2008-12-30 11:13
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
ati的真悲哀 :em06


_________________
神说,多好是好啊……


页首
 用户资料  
 
12 楼 
 文章标题 : Re: ATI受限驱动与开源驱动使用感觉
帖子发表于 : 2009-01-01 18:48 
头像

注册: 2008-12-19 13:44
帖子: 2337
地址: 东8区
送出感谢: 0 次
接收感谢: 0 次
:em09 多样化才不会垄断阿


_________________
代码:
 
       \   ,__,
        \  (oo)____
           (__)    )\
              ||--|| * 
 


页首
 用户资料  
 
13 楼 
 文章标题 : Re: ATI受限驱动与开源驱动使用感觉
帖子发表于 : 2009-01-10 3:24 

注册: 2008-10-28 20:18
帖子: 3249
送出感谢: 0 次
接收感谢: 0 次
lwcmain 写道:
楼上的帮我看看,我照着要求做了,出现了错误

lwcmain@lwcmain-desktop:~$ sudo sh ati-driver-installer-8-12-x86.x86_64.run --buildpkg Ubuntu/intrepid
Created directory fglrx-install.HM5582
Verifying archive integrity...Error in MD5 checksums: 9bb7110fec9cc9d0a034c9fa4f6182ff is different from 6cdbeb70d9046ad9dd5e5636a2db7c79
lwcmain@lwcmain-desktop:~$ sudo dpkg -i xorg-driver-fglrx_8.561-0ubuntu1_i386.deb fglrx-kernel-source_8.561-0ubuntu1_i386.deb fglrx-amdcccle_8.561-0ubuntu1_i386.deb
dpkg:处理 xorg-driver-fglrx_8.561-0ubuntu1_i386.deb (--install)时出错:
无法访问打包文件: 没有该文件或目录
dpkg:处理 fglrx-kernel-source_8.561-0ubuntu1_i386.deb (--install)时出错:
无法访问打包文件: 没有该文件或目录
dpkg:处理 fglrx-amdcccle_8.561-0ubuntu1_i386.deb (--install)时出错:
无法访问打包文件: 没有该文件或目录
在处理时有错误发生:
xorg-driver-fglrx_8.561-0ubuntu1_i386.deb
fglrx-kernel-source_8.561-0ubuntu1_i386.deb
fglrx-amdcccle_8.561-0ubuntu1_i386.deb

我的系统是8.10的,32位。显卡是ATI Mobility 9600
能不能帮我看一下是哪的问题


你下载的驱动文件名 是 ati-driver-installer-8-12-x86.x86_64.run 吗?
请确一下文件名以及该文件存放的位置是否正确


页首
 用户资料  
 
14 楼 
 文章标题 : Re: ATI受限驱动与开源驱动使用感觉
帖子发表于 : 2009-01-10 10:01 

注册: 2008-07-13 10:09
帖子: 79
送出感谢: 0 次
接收感谢: 0 次
从官方网页下载的,没有错。目录也没错


页首
 用户资料  
 
15 楼 
 文章标题 : Re: ATI受限驱动与开源驱动使用感觉
帖子发表于 : 2009-01-11 12:26 

注册: 2009-01-02 18:18
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
学习了,谢谢 :em09


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 37 篇帖子 ]  前往页数 1, 2, 3  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译