当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [已解决]成功解决笔记本耳机无声问题
帖子发表于 : 2008-11-25 7:53 

注册: 2008-11-23 4:40
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
我的笔记本声卡AL880,音响是正常的,但是插上耳机之后耳机没声音(耳机是好的),而且音量控制里面没有headphone的选项。相信论坛上很多朋友都遇到了类似的问题。

我经过一番折腾,终于找到了解决的办法,如果想直接看方法,可以跳过前面直接看后面的红字部分

按照这个帖子9楼的回复
http://forum.ubuntu.org.cn/viewtopic.php?f=126&t=163400

引用:
我这有解决方法 我也是这个问题 用这个方法解决了 你可以试试看:

打开/etc/modprobe.d目录,编辑下面的aliases文件,将上面以alias开头的行加入其中
代码:
# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-hda-intel
options snd-hda-intel model=z71v position_fix=1

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss


然后重新启动,打开alsamixer看一下,应该有headphone这一项了。


照着这个做,耳机有声音了,而且选项卡里有headphone的选项了。但是有一个问题就是启动的时候要读一大堆东西,而且非常非常慢……

后来经过一番google,终于找到更详细的解决方法。帖子在这里:
http://www.blog.edu.cn/user3/HareCat/archives/2006/1532728.shtml

引用:
参考http://www.fedoraforum.org/forum/showthread.php?t=109654

我的ASUS A6000V上用的是这一款声卡,在安装linux的过程中,内核会将其自动识别为Intel HD Audio,安装之后,出现的问题是外放能出声,但插上耳机却没有声音,在音量调节中(不管是alsa mixer还是gmixer还是kmix其它的)也没有Headphone这一项。

如果你的/etc/目录下有modprobe.conf或者modules.conf或者conf.modules,那么只要将其中有关声卡的部分用#注释掉,然后加入以下内容:

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-hda-intel
options snd-hda-intel model=z71v position_fix=1

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

然后重新启动,打开alsamixer看一下,应该有headphone这一项了。

如果你用的是Ubuntu,在/etc/目录下找不到那些文件,这时候需要打开/etc/modprobe.d目录,编辑下面的aliases文件,将上面以alias开头的行加入其中,同时将
options snd-hda-intel model=z71v position_fix=1
加到/etc/modprobe.d/options里,然后重启,这样耳机应该能够使用了。


下面是我总结的ubuntu8.04里笔记本音响正常,耳机没声音的解决办法。

1.运行
代码:
sudo gedit /etc/modprobe.d/aliases

把# character devices 那部分下面的以alias char-major开头的每一行都用#注释掉。然后在后面加入下面的代码,最后保存。
# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-hda-intel
options snd-hda-intel model=z71v position_fix=1

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

基本上做完这个就算是完成了,但是这样的话启动的时候会非常之慢,而且在你调出音量控制器,以及用mplayer打开视频文件的时候,也要有一个比较长的读取过程。所以,为了优化速度,可以做第2步。

2.运行
代码:
sudo gedit /etc/modprobe.d/options

在其中加入
options snd-hda-intel model=z71v position_fix=1
保存,退出。

这样,就成功的解决了笔记本在ubuntu8.04下(估计8.10方法类似)耳机不出声的问题了。


我之所以在前面引用那么多别人的方法主要是尊重别人的劳动成果,别嫌我罗嗦阿,呵呵。

另外,小提示,用mplayer看电影的时候,如果没有声音,只要在preferences里audio选项里选择oss或alsa,选应用,就会有声音了。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: [已解决]成功解决笔记本耳机无声问题
帖子发表于 : 2008-11-25 22:30 
头像

注册: 2008-09-10 17:35
帖子: 14
地址: Hong Kong
送出感谢: 0 次
接收感谢: 0 次
我依樓主的方法去做,我的VIA VT82XX耳機孔仍舊是沒有聲音 :em20
不知是否裝置有問題?

Terminal打lspci -vv資料如下:
代码:
Audio device: VIA Technologies, Inc. VIA High Definition Audio Controller (rev 10)
   Subsystem: Unknown device 1e40:1509
   Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
   Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
   Latency: 0, Cache Line Size: 32 bytes
   Interrupt: pin A routed to IRQ 23
   Region 0: Memory at c9100000 (64-bit, non-prefetchable) [size=16K]
   Capabilities: <access denied>


Terminal打aplay -l資料如下:
代码:
**** PLAYBACK 硬體裝置清單 ****
card 0: VT82xx [HDA VIA VT82xx], device 0: VT1708 Analog [VT1708 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


subsystem是unknown,不知是不是這個出問題?


_________________
打死以後都不用買VIA的產品!


页首
 用户资料  
 
3 楼 
 文章标题 : Re: [已解决]成功解决笔记本耳机无声问题
帖子发表于 : 2008-11-26 0:59 

注册: 2008-11-23 4:40
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
我的是这个
代码:
 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 04)
   Subsystem: ASUSTeK Computer Inc. Unknown device 1114
   Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
   Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
   Latency: 0, Cache Line Size: 64 bytes
   Interrupt: pin A routed to IRQ 16
   Region 0: Memory at febfc000 (64-bit, non-prefetchable) [size=16K]
   Capabilities: <access denied>

所以我觉得这个应该没有太大的问题,可能是别的地方出问题了……


页首
 用户资料  
 
4 楼 
 文章标题 : Re: [已解决]成功解决笔记本耳机无声问题
帖子发表于 : 2008-11-26 10:58 
头像

注册: 2008-09-10 17:35
帖子: 14
地址: Hong Kong
送出感谢: 0 次
接收感谢: 0 次
lovecanon 写道:
所以我觉得这个应该没有太大的问题,可能是别的地方出问题了……


但不知道是那一個部分出了問題,而我已經報告給launchpad,但到現在還未有回覆。

https://bugs.launchpad.net/ubuntu/+bug/286803


_________________
打死以後都不用買VIA的產品!


页首
 用户资料  
 
5 楼 
 文章标题 : Re: [已解决]成功解决笔记本耳机无声问题
帖子发表于 : 2008-11-26 13:02 

注册: 2007-05-06 2:10
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
感谢,成功解决了,因为本不一样,手动改了model=vaio,3x :em11


页首
 用户资料  
 
6 楼 
 文章标题 : Re: [已解决]成功解决笔记本耳机无声问题
帖子发表于 : 2008-11-28 2:09 

注册: 2008-11-23 4:40
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
我昨天改着玩,把model=z71v改成model=asus,然后系统就没声音了……
无奈又改回去了


页首
 用户资料  
 
7 楼 
 文章标题 : Re: [已解决]成功解决笔记本耳机无声问题
帖子发表于 : 2009-01-04 20:19 

注册: 2009-01-02 16:09
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
感谢LZ 我的问题解决了 :em11


页首
 用户资料  
 
8 楼 
 文章标题 : Re: [已解决]成功解决笔记本耳机无声问题
帖子发表于 : 2009-03-16 15:26 

注册: 2009-03-13 22:09
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
我连编辑都编不了啊。提示说我没权限。这是为什么啊?


页首
 用户资料  
 
9 楼 
 文章标题 : Re: [已解决]成功解决笔记本耳机无声问题
帖子发表于 : 2009-03-16 15:34 
头像

注册: 2007-07-30 18:28
帖子: 22033
地址: 空气中
系统: Linux
送出感谢: 17
接收感谢: 68
说明是你声卡的一个bug


_________________
『这个世界都是我的 ,我爱你们』

ENTP ⥂ INTP ⥄ INFP ⇦ INTJ

在此发布的文章使用 Creative Commons Attribution-ShareAlike 4.0 协议


页首
 用户资料  
 
10 楼 
 文章标题 : Re: [已解决]成功解决笔记本耳机无声问题
帖子发表于 : 2009-03-16 15:48 

注册: 2009-03-13 22:09
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
.......
还有什么方法没?


页首
 用户资料  
 
11 楼 
 文章标题 : Re: [已解决]成功解决笔记本耳机无声问题
帖子发表于 : 2009-03-16 15:50 

注册: 2009-03-13 22:09
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
难道修改要在终端进行????
我是直接文档打开的


页首
 用户资料  
 
12 楼 
 文章标题 : Re: [已解决]成功解决笔记本耳机无声问题
帖子发表于 : 2009-03-16 16:08 
头像

注册: 2006-12-17 13:34
帖子: 1818
地址: 武汉
送出感谢: 1
接收感谢: 0 次
summer_autumn 写道:
难道修改要在终端进行????
我是直接文档打开的

或者右键→以管理员身份打开 :em03


_________________
人生长恨水长东;
远近高低各不同.


页首
 用户资料  
 
13 楼 
 文章标题 : Re: [已解决]成功解决笔记本耳机无声问题
帖子发表于 : 2009-03-16 16:13 

注册: 2009-03-13 22:09
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
sunningv 写道:
summer_autumn 写道:
难道修改要在终端进行????
我是直接文档打开的

或者右键→以管理员身份打开 :em03

我在终端里改好了,耳机有声音了,真是惭愧啊。。。。。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译