超级奇怪的声卡问题。。。。装了驱动能放声音,但任何音频软件都会死掉

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
noah1987
帖子: 17
注册时间: 2008-12-12 16:19
送出感谢: 0
接收感谢: 0

超级奇怪的声卡问题。。。。装了驱动能放声音,但任何音频软件都会死掉

#1

帖子 noah1987 » 2008-12-13 9:39

我的是8.10的ubuntu,x40机器,声卡集成在这个芯片里: Intel 82801DBM

This is a Intel ICH4-M I/O Controller Hub
Features

* ATA-100 IDE
* PCI bus 2.2 32-bit, 33MHz
* Ethernet MAC
* USB 2.0
* AC '97

怎么也想不到,intel的烂大街的集成声卡,居然不能正常工作。。。 :em20 :em20 :em20
装上ubuntu后,有小喇叭,但是没声音,比如,在shell中敲错命令,会有刺耳的”滴滴“声,说明声卡驱动不正常。
打开音频软件,可以播放mp3之类,进度条往前走,就是一点声音都没有。
cat /etc/sndstat,显示没装音频驱动。奇怪了,没装音频驱动,为什么小喇叭什么的都正常,还都能调?

没办法,我去下载了oss的deb包,装上。重启。
这下更奇怪了。。。
再次cat /etc/sndstat,正常,驱动装上了。
执行/usr/bin/osstest,居然可以播放它自己的测试音频,第一次在ubuntu中听到美妙的音乐!!!虽然它播放的什么东西,我并不清楚。
问题是:1。在shell中敲错命令,还是会有刺耳的”滴滴“声,说明声卡驱动还是不正常。
2。所有音频播放软件,打开任何音频文件,进度条都不走了,一点点的音都没有,全不响应,关都关不掉。连小喇叭的测试都是如此。

被折磨了好久了,帮帮忙把 :em20 :em20 :em20
上次由 noah1987 在 2008-12-13 9:44,总共编辑 1 次。
noah1987
帖子: 17
注册时间: 2008-12-12 16:19
送出感谢: 0
接收感谢: 0

Re: 超级奇怪的声卡问题。。。。装了驱动能放声音,但任何音频软件都会死掉

#2

帖子 noah1987 » 2008-12-13 9:42

补充一下:

任何音频文件,包括wav,全都不能播放,一播放,就死,一点声音都没有。。

谢谢大家了。

我是不是要卸掉oss,装alsa?
怎么卸?
noah1987
帖子: 17
注册时间: 2008-12-12 16:19
送出感谢: 0
接收感谢: 0

Re: 超级奇怪的声卡问题。。。。装了驱动能放声音,但任何音频软件都会死掉

#3

帖子 noah1987 » 2008-12-13 12:20

ok了,问题解决了!!!

是我自己搞错了。。
levelksk
帖子: 32
注册时间: 2008-05-16 15:12
送出感谢: 0
接收感谢: 0

Re: 超级奇怪的声卡问题。。。。装了驱动能放声音,但任何音频软件都会死掉

#4

帖子 levelksk » 2008-12-27 0:48

- -能麻烦楼猪告诉我是怎么解决的马
noah1987
帖子: 17
注册时间: 2008-12-12 16:19
送出感谢: 0
接收感谢: 0

Re: 超级奇怪的声卡问题。。。。装了驱动能放声音,但任何音频软件都会死掉

#5

帖子 noah1987 » 2008-12-29 18:32

levelksk 写了:- -能麻烦楼猪告诉我是怎么解决的马
重装了就好了。。。。。
:em06
回复

回到 “常用硬件支持”