摄像头驱动,求助!

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
llc
帖子: 33
注册时间: 2008-09-08 12:08
送出感谢: 0
接收感谢: 0

摄像头驱动,求助!

#1

帖子 llc » 2008-12-20 22:54

我是朋友给的一个摄像头,原来在winXP下是用驱动人生自动找的驱动,可用。
IMG0112A.jpg
摄像头就这个样子的哈,我也不知道是什么牌子的。
跟军wiki的指导,安装了easycam2。操作如下:
1.png
2.png
下拉选项只有一项,即USB PC Camera34
3.png
lancer installation,点一下,等了很久。那个进度条还是不动。点前进,
4.png
用cheese打开
5.png
是麻点,抓图后 这里变成了一片黑。

参照http://forum.ubuntu.org.cn/viewtopic.php?f=77&t=161444&view=next中 irc 的做法(卸载掉gspca-source),依然没有成功。

又在网上搜索。运行lsusb命令。
Screenshot-root-desktop.png
本栏目luojie-dune整理的ubuntu硬件支持列表中,好像没有 :em20 viewtopic.php?f=42&t=141041

继续搜索,大都提到了一个网站http://mxhaard.free.fr/ 但是打不开。 汗 一个先。

不知这些信息够不? 俺的摄像头如何才能装好阿。
补充:系统是ubuntu8.04
hotloo
帖子: 38
注册时间: 2007-10-18 18:54
来自: NANJING UNIVERSITY
送出感谢: 0
接收感谢: 0
联系:

Re: 摄像头驱动,求助!

#2

帖子 hotloo » 2008-12-21 11:05

费这么大劲,还不如重新买一个呢~~你那个摄像头应该是0.3M的吧~~换个新的吧~~
q5651331
帖子: 15
注册时间: 2008-12-04 22:18
送出感谢: 0
接收感谢: 0

Re: 摄像头驱动,求助!

#3

帖子 q5651331 » 2008-12-31 19:34

帮楼主顶上去吧,我也类似的问题
头像
HuntXu
论坛版主
帖子: 5776
注册时间: 2007-09-29 3:09
送出感谢: 0
接收感谢: 6 次

Re: 摄像头驱动,求助!

#4

帖子 HuntXu » 2008-12-31 21:54

LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so cheese试试...
先装libv4l...
HUNT Unfortunately No Talent...
rzlt
帖子: 4
注册时间: 2008-12-15 2:15
送出感谢: 0
接收感谢: 0

Re: 摄像头驱动,求助!

#5

帖子 rzlt » 2009-01-01 16:14

嘿嘿,我的更背!启动cheese已经能看到了,可是如果启动不管SKYPE还是EKIGA结果都是没戏。skype多少还能出个花屏,算是承认俺有个摄像头,ekiga根本不认,说俺配置错误,真是见了鬼了
rzlt
帖子: 4
注册时间: 2008-12-15 2:15
送出感谢: 0
接收感谢: 0

Re: 摄像头驱动,求助!

#6

帖子 rzlt » 2009-01-01 16:36

另外,希望网友知之为知之,不知为不知,不要瞎指挥。说什么换个摄像头,换什么牌子什么型号能确保驱动成功呢?Easycam支持的列表在村里还真都没的卖,也不知道兼容产品都是什么。所以,这种GP话就不用说了。我也贴下我的USB设备列表:
附件
USB设备列表.png
头像
betawhh
帖子: 95
注册时间: 2008-11-25 23:15
送出感谢: 0
接收感谢: 0

Re: 摄像头驱动,求助!

#7

帖子 betawhh » 2009-01-01 16:42

代码: 全选

$ cheese

(cheese:2683): GStreamer-WARNING **: pad source:src returned caps which are not a real subset of its template caps

(cheese:2683): GStreamer-WARNING **: pad source:src returned caps which are not a real subset of its template caps

(cheese:2683): GStreamer-WARNING **: pad video_source:src returned caps which are not a real subset of its template caps
libv4l2: error converting / decoding frame data: v4l-convert: error destination buffer too small
rzlt
帖子: 4
注册时间: 2008-12-15 2:15
送出感谢: 0
接收感谢: 0

Re: 摄像头驱动,求助!

#8

帖子 rzlt » 2009-01-01 18:19

Ekiga解决了~ 双击Ekiga的图标,不管出什么,点取消,直接进到里面。然后找编辑-首选项-设置-视频设备。我的更改是这样:
1 默认的频道是1,我改成0
2 默认视频插件是V4L,我改成V4L2
另外提醒楼上各位,貌似很多问题是在更新系统或者联网安装系统的时候,某些包没有正确下载和更新导致的。我的经验是,每次开机联网,如果需要安装或者升级,都测下优选服务器。中国的网不稳的,今天这个服务器好,明天就是那个了。然后就是首次安装,老子坚决把网线拔了,省得有问题。
附件
Ekiga视频设置1.png
Ekiga视频设置2.png
Ekiga视频设置3.png
头像
HuntXu
论坛版主
帖子: 5776
注册时间: 2007-09-29 3:09
送出感谢: 0
接收感谢: 6 次

Re: 摄像头驱动,求助!

#9

帖子 HuntXu » 2009-01-01 20:38

2.6.27后都用v4l2...
本身能选择v4l1和v4l2的就选v4l2...
本身只用v4l1,强制使用libv4l...见4L...
HUNT Unfortunately No Talent...
头像
HuntXu
论坛版主
帖子: 5776
注册时间: 2007-09-29 3:09
送出感谢: 0
接收感谢: 6 次

Re: 摄像头驱动,求助!

#10

帖子 HuntXu » 2009-01-01 20:49

https://bugs.launchpad.net/ubuntu/+bug/267522
相同的报告到网上搜bug,一搜一大堆...
法国网址要翻墙...
另,最新的2.6.28内核已经有了部分gspca的驱动在内核树里,不急的话就等ubuntu更新,没必要自己下载gspca编译了...
HUNT Unfortunately No Talent...
llc
帖子: 33
注册时间: 2008-09-08 12:08
送出感谢: 0
接收感谢: 0

Re: 摄像头驱动,求助!

#11

帖子 llc » 2009-01-16 22:13

谢谢楼上 我把cam2卸载了

重新找了一个摄像头,一接上就可以用,用skype测试的。
不需要任何的其他驱动 哈哈

lsusb

信息是:
Bus 001 Device 002: ID 0ac8:301b Z-Star Microelectronics Corp. ZC0301 WebCam
回复

回到 “常用硬件支持”