!!老显卡!!我的显卡是tnt2m64,在ubuntu6.06中安装nvidia驱动时出现的问题。

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
tmp_123
帖子: 20
注册时间: 2006-06-05 10:45
送出感谢: 0
接收感谢: 0

!!老显卡!!我的显卡是tnt2m64,在ubuntu6.06中安装nvidia驱动时出现的问题。

#1

帖子 tmp_123 » 2006-06-14 19:59

1、如果安装 nvidia-glx, 配置好xorg.conf后,装上官方的nvidia7174驱动,进入桌面很正常,但重起动后,就无法进入桌面,必须重新安装nvidia7174驱动后才能进入桌面,每次进入ubuntu linux 都是如此,请问有办法吗?
另外,/etc/rc?.d中也没有nvidia-kernel方面的脚本,被我删了:)因为据说有冲突。nvidia-kernel 方面的包我也下了。
2、如果不装nvidia-glx,安装官方的nvidia7174驱动后,进入桌面时因无法加载glx、nvidia两个模块而失败。出错信息为:
failed to load module "glx" ( a require submodule could not be loaded, 0)
failed to load module "nvidia" ( module dose not exit)
可我sudo lsmod |grep nvidia 找到了nvidia,不知是怎么回事,请高手帮忙.谢了!
tmp_123
帖子: 20
注册时间: 2006-06-05 10:45
送出感谢: 0
接收感谢: 0

算了,自己终于找到原因了。

#2

帖子 tmp_123 » 2006-06-18 18:31

安装好nvidia驱动后,
将下面的代码加在rc.local内
#makedevice.sh ---nvidia
#!/bin/sh

error() {
echo "$(basename $0): fatal error, $1 failed"
exit 1
}

if [ ! -c /dev/.devfsd ]; then
for i in 0 1 2 3 4 5 6 7; do
node="/dev/nvidia$i"
rm -f $node
mknod $node c 195 $i || error "mknod \"$node\""
chmod 0666 $node || error "chmod \"$node\""
done
node="/dev/nvidiactl"
rm -f $node
mknod $node c 195 255 || error "mknod \"$node\""
chmod 0666 $node || error "chmod \"$node\""
fi

if [ -d /etc/udev/devices ]; then
for i in 0 1 2 3 4 5 6 7; do
node="/etc/udev/devices/nvidia$i"
rm -f $node
mknod $node c 195 $i || error "mknod \"$node\""
chmod 0666 $node || error "chmod \"$node\""
done
node="/etc/udev/devices/nvidiactl"
rm -f $node
mknod $node c 195 255 || error "mknod \"$node\""
chmod 0666 $node || error "chmod \"$node\""
fi

exit 0
#这些代码是在nvidia-kernel-legacy-source中的/nv/makedevice.sh中的代码。
这样一搞,就不会出现重起动nvidia无法加载的原因了。真是烦人。
回复

回到 “常用硬件支持”