ubuntu 8.04, geforce 3ti 200。能安装成功,但一重启后就不能用了,大家帮忙啊!

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
ninesunqian
帖子: 3
注册时间: 2009-01-11 15:49
送出感谢: 0
接收感谢: 0

ubuntu 8.04, geforce 3ti 200。能安装成功,但一重启后就不能用了,大家帮忙啊!

#1

帖子 ninesunqian » 2009-01-11 16:07

步骤是这样的:
关掉X: /etc/init.d/gdm stop
安装驱动:NVIDIA-Linux-x86-96.43.05-pkg1.run
修改: /etc/X11/xorg.conf
* 在"Screen"段中加入:Option "AddARGBGLXVisuals" "True" #(解决虚拟终端一片空白的问题)
* Modes "1680x1050@60" "1280x1024" "1024x768" "800x600" #(22寸hp显示器)
启动X: /etc/init.d/gdm stop
------------------
运行glxgears: 可以看到流畅滚动齿轮
安装了3D桌面: compizconfig-settings-manager, emerald。 玩了两下

-------------------
某次重启电脑后:出现“ubuntu is runing in low-praphics mode”,xwindow只能在800x600下运行
重新安装驱动后,没有问题,重启电脑后又坏掉了。
dmesg里有如下错误提示:
API mismatch: the client has the version 96.43.05, but
this kernel module has the version 71.86.04. Please
make sure that this kernel module and all NVIDIA driver
components have the same version.
API mismatch: the client has the version 96.43.05, but
this kernel module has the version 71.86.04. Please
make sure that this kernel module and all NVIDIA driver
components have the same version.

以为是驱动版本的问题:NVIDIA-Linux-x86-71.86.06-pkg1.run ,并安装,照样是“ubuntu is runing in low-praphics mode”。

怎么才能顺利把3TI200的驱动装上? 哪位大侠指点一下,先谢谢啦
ninesunqian
帖子: 3
注册时间: 2009-01-11 15:49
送出感谢: 0
接收感谢: 0

Re: ubuntu 8.04, geforce 3ti 200。能安装成功,但一重启后就不能用了,大家帮忙啊!

#2

帖子 ninesunqian » 2009-01-13 7:44

发现刚刚装上nvidia驱动的时候, 启动xwindow, xorg的日志里有: (==) Using config file: "/etc/X11/xorg.conf"

重启后的日志里有:(++) Using config file: "/tmp/dcg-Ilt1ZV5275/testserver.config"
显然,重启后使用的配置文件发生了错误。但不知是怎么来的,郁闷!
phomeray
帖子: 524
注册时间: 2006-05-30 20:48
送出感谢: 0
接收感谢: 0

Re: ubuntu 8.04, geforce 3ti 200。能安装成功,但一重启后就不能用了,大家帮忙啊!

#3

帖子 phomeray » 2009-01-13 9:47

ti200 只能装legacy的驱动,9631的貌似
7186的不支持
sudo apt-get install nvidia-glx,好像是这个,8.10里是sudo apt-get install nvidia-glx-96
或者去官网下载9631的驱动
sudo sh ./NV*.run
http://www.nvidia.com/object/linux_disp ... -9631.html
http://us.download.nvidia.com/XFree86/L ... 1-pkg1.run
回复

回到 “常用硬件支持”