我的摄像头已经被skype认出来了可是还是没有图像?

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
头像
wangwentao24
帖子: 340
注册时间: 2007-09-07 9:02
来自: 中国辽宁抚顺
送出感谢: 0
接收感谢: 0
联系:

我的摄像头已经被skype认出来了可是还是没有图像?

#1

帖子 wangwentao24 » 2009-01-18 10:33

如题。点击测试后是黑的没有图像。我用的是kubuntu8。04
尽量帮助新手 尽量推广linux 是我在享受free的同时 能作的最大回报了!

硬件是macbookpro 700 软件是美洲豹
硬件是ASUS K40 软件是lubuntu12.04
硬件是IBM T23 软件是windows xp深度优化版。
头像
lerosua
论坛版主
帖子: 8455
注册时间: 2007-11-29 9:41
送出感谢: 0
接收感谢: 0
联系:

Re: 我的摄像头已经被skype认出来了可是还是没有图像?

#2

帖子 lerosua » 2009-01-18 13:26

装个cheese测试一下摄像头是否完好
头像
olala
帖子: 26
注册时间: 2008-05-19 5:04
送出感谢: 0
接收感谢: 0

Re: 我的摄像头已经被skype认出来了可是还是没有图像?

#3

帖子 olala » 2009-01-20 8:09

我也是同样的问题
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

Re: 我的摄像头已经被skype认出来了可是还是没有图像?

#4

帖子 eexpress » 2009-01-20 8:43

摄像头:播放与录像
☎ mplayer tv:// -tv driver=v4l
☎ mencoder tv:// -tv driver=v4l -oac mp3lame -ovc lavc -o tt.mpeg

测试下吧。那 -tv 参数,可能不需要。
● 鸣学
头像
wangwentao24
帖子: 340
注册时间: 2007-09-07 9:02
来自: 中国辽宁抚顺
送出感谢: 0
接收感谢: 0
联系:

Re: 我的摄像头已经被skype认出来了可是还是没有图像?

#5

帖子 wangwentao24 » 2009-01-20 8:57

MPlayer 1.0rc2-4.2.3 (C) 2000-2007 MPlayer Team
CPU: Intel(R) Pentium(R) III Mobile CPU 1133MHz (Family: 6, Model: 11, Stepping: 1)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compiled with runtime CPU detection.
Creating config file: /home/wangwentao/.mplayer/config
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing tv://.
TV file format detected.
Selected driver: v4l
name: Video 4 Linux input
author: Alex Beregszaszi
comment: under development
=================================================================
WARNING: YOU ARE USING V4L DEMUXER WITH V4L2 DRIVERS!!!
As the V4L1 compatibility layer is broken, this may not work.
If you encounter any problems, use driver=v4l2 instead.
Bugreports on driver=v4l with v4l2 drivers will be ignored.
=================================================================
Selected device: USB 2.0 PC Camera
Capabilites: capture
Device type: 1
Supported sizes: 48x32 => 640x480
Inputs: 1
ioctl get channel failed: Invalid argument
ioctl set chan failed: Invalid argument
ioctl set chan failed: Invalid argument
Error: Cannot set norm!
Selected input hasn't got a tuner!
ioctl set picture failed: Invalid argument
The 'outfmt' of 'Planar YV12' is likely not supported by your card


MPlayer interrupted by signal 11 in module: demux_open
- MPlayer crashed by bad usage of CPU/FPU/RAM.
Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
- MPlayer crashed. This shouldn't happen.
It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
gcc version. If you think it's MPlayer's fault, please read
DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
won't help unless you provide this information when reporting a possible bug.
出来的是这个
尽量帮助新手 尽量推广linux 是我在享受free的同时 能作的最大回报了!

硬件是macbookpro 700 软件是美洲豹
硬件是ASUS K40 软件是lubuntu12.04
硬件是IBM T23 软件是windows xp深度优化版。
头像
wangwentao24
帖子: 340
注册时间: 2007-09-07 9:02
来自: 中国辽宁抚顺
送出感谢: 0
接收感谢: 0
联系:

Re: 我的摄像头已经被skype认出来了可是还是没有图像?

#6

帖子 wangwentao24 » 2009-01-20 8:59

用cheese没有图像。
尽量帮助新手 尽量推广linux 是我在享受free的同时 能作的最大回报了!

硬件是macbookpro 700 软件是美洲豹
硬件是ASUS K40 软件是lubuntu12.04
硬件是IBM T23 软件是windows xp深度优化版。
头像
lerosua
论坛版主
帖子: 8455
注册时间: 2007-11-29 9:41
送出感谢: 0
接收感谢: 0
联系:

Re: 我的摄像头已经被skype认出来了可是还是没有图像?

#7

帖子 lerosua » 2009-01-20 9:00

补充楼上的, 一些新式的摄像头driver 是 v4l2 了
回复

回到 “常用硬件支持”