很奇怪,系统开机提示音是单声道,但放电影却不会

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
头像
tonytam
帖子: 485
注册时间: 2006-09-23 12:28
送出感谢: 1 次
接收感谢: 0

很奇怪,系统开机提示音是单声道,但放电影却不会

#1

帖子 tonytam » 2009-02-18 19:10

自从我更换了声卡之后就这样,开机启动过程中会有强烈噪音,登录声响起前噪音消失,但登录声、系统提示音、网页Flash都是单声道。

但是使用“音乐播放器”、mplayer这些,又是双声道。

声卡是创新的老卡,系统的音效选项见附图。

lspci输出为:

代码: 全选

$ lspci |grep audio
02:0b.0 Multimedia audio controller: Ensoniq ES1370 [AudioPCI]
望达人指教
附件
Screenshot-声音首选项.png
头像
tonytam
帖子: 485
注册时间: 2006-09-23 12:28
送出感谢: 1 次
接收感谢: 0

Re: 很奇怪,系统开机提示音是单声道,但放电影却不会

#2

帖子 tonytam » 2009-02-19 19:49

顶上去。再求解
...
头像
tonytam
帖子: 485
注册时间: 2006-09-23 12:28
送出感谢: 1 次
接收感谢: 0

Re: 很奇怪,系统开机提示音是单声道,但放电影却不会

#3

帖子 tonytam » 2009-02-28 10:57

网页flash, flv, toten播放的,都是单声道,只有mplayer播放的,才是双声道,跪求帮助啊。
头像
tonytam
帖子: 485
注册时间: 2006-09-23 12:28
送出感谢: 1 次
接收感谢: 0

Re: 很奇怪,系统开机提示音是单声道,但放电影却不会

#4

帖子 tonytam » 2009-02-28 11:01

Rhythmbox播放歌曲也是双声道的。
头像
tonytam
帖子: 485
注册时间: 2006-09-23 12:28
送出感谢: 1 次
接收感谢: 0

Re: 很奇怪,系统开机提示音是单声道,但放电影却不会

#5

帖子 tonytam » 2009-02-28 11:06

/etc/modprobe.d/alsa-base文件如下:

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; : ; }
install snd-pcm /sbin/modprobe --ignore-install snd-pcm && { /sbin/modprobe --quiet snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer && { /sbin/modprobe --quiet snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq && { /sbin/modprobe --quiet snd-seq-midi ; /sbin/modprobe --quiet snd-seq-oss ; : ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe -Qb saa7134-alsa ; : ; }

# Load snd-seq for devices that don't have hardware midi;
# Ubuntu #26283, #43682, #56005; works around Ubuntu #34831 for
# non-Creative Labs PCI hardware
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe -Qb snd-seq ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
头像
tonytam
帖子: 485
注册时间: 2006-09-23 12:28
送出感谢: 1 次
接收感谢: 0

Re: 很奇怪,系统开机提示音是单声道,但放电影却不会

#6

帖子 tonytam » 2009-03-01 11:27

跪求解啊,达人们。我发现,当音量开到足够大的时候,另外一个耳机是电流声
回复

回到 “常用硬件支持”