[问题]升级之后ATI驱动没了,新的又装不了,如何解决?(已解决)

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
头像
donny
帖子: 335
注册时间: 2005-10-03 15:25
送出感谢: 0
接收感谢: 0

[问题]升级之后ATI驱动没了,新的又装不了,如何解决?(已解决)

#1

帖子 donny » 2006-07-02 14:52

系统升级到DAPPER后,发现以前安装的ATI8.24.8也被删了,后按照WIKI上的方法安装,连X都进不了,只好sudo dpkg-reconfigure xserver-xorg重新改了回来。
之后我把所有关于ATI和FGLRX的组件全卸载了,并且
sudo aptitude update
sudo aptitude install linux-restricted-modules-$(uname -r)
sudo aptitude install xorg-driver-fglrx

sudo aticonfig --initial
sudo aticonfig --overlay-type=Xv
但当我执行
sudo aticonfig --initial
时,却提示
Found fglrx primary device section
Nothing to do, terminating.
执行
sudo aticonfig --overlay-type=Xv
提示
Warning: Option 'VideoOverlay' doesn't affect running session.
Warning: Option 'OpenGLOverlay' doesn't affect running session.
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.fglrx-3
运行
fglrxinfo
还是显示
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.4.1)
请问是哪里出了问题
上次由 donny 在 2006-07-04 10:43,总共编辑 1 次。
头像
catinsnow
帖子: 773
注册时间: 2005-08-02 7:23
来自: 上海
送出感谢: 0
接收感谢: 1 次

#2

帖子 catinsnow » 2006-07-02 21:52

等一下,xorg.conf有误.我再发一份.
Ubuntu Intrepid
#P4 2.4
P4 2.4C
#1024MB
2048MB
#120G
500G+120G
Nvidia FX5700
#ATI9100 --拆了,受不了ATI的驱动.
头像
donny
帖子: 335
注册时间: 2005-10-03 15:25
送出感谢: 0
接收感谢: 0

#3

帖子 donny » 2006-07-02 23:26

新的邮件似乎忘了附上附件了
lhf8371
帖子: 33
注册时间: 2005-09-19 11:28
送出感谢: 0
接收感谢: 0

#4

帖子 lhf8371 » 2006-07-06 23:26

倒!!怎么解决的,说呀~
头像
donny
帖子: 335
注册时间: 2005-10-03 15:25
送出感谢: 0
接收感谢: 0

#5

帖子 donny » 2006-07-07 11:14

lhf8371 写了:倒!!怎么解决的,说呀~
:oops: 不好意思哦,我写在了我的BLOG上了,你可以去看看。
lhf8371
帖子: 33
注册时间: 2005-09-19 11:28
送出感谢: 0
接收感谢: 0

#6

帖子 lhf8371 » 2006-07-14 2:22

楼主,你说的方法我这里行不通呀~

我这里根据没10fglrx这个文件,咋办呢~

所以下面这个错误一直无法解决~

Warning: Option 'VideoOverlay' doesn't affect running session.
Warning: Option 'OpenGLOverlay' doesn't affect running session.
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.fglrx-3

是不是xorg.conf也需要改什么东西呢~
ordinary
帖子: 16
注册时间: 2005-04-14 12:29
送出感谢: 0
接收感谢: 0

#7

帖子 ordinary » 2006-08-05 4:00

我的也是这个问题,请问是怎么解决的?
头像
drivel
帖子: 1917
注册时间: 2006-07-08 9:21
来自: University of Science and Technology Beijing
送出感谢: 1 次
接收感谢: 0
联系:

#8

帖子 drivel » 2006-08-05 6:46

我的升级之后

代码: 全选

drivel@drivel-laptop:~$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: MOBILITY RADEON X600 Generic
OpenGL version string: 2.0.5814 (8.25.18)
头像
donny
帖子: 335
注册时间: 2005-10-03 15:25
送出感谢: 0
接收感谢: 0

#9

帖子 donny » 2006-08-05 9:50

ordinary 写了:我的也是这个问题,请问是怎么解决的?
看我的BLOG
回复

回到 “常用硬件支持”