当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 14 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [已解决]华硕N80耳机无声音,快崩溃了
帖子发表于 : 2009-04-28 20:37 

注册: 2007-05-11 13:43
帖子: 38
送出感谢: 1
接收感谢: 1
从8.10鼓捣到9.04都不能完美解决,快崩溃了.
是ALC633的芯片,默认无声,通过改/etc/modprobe.d/alsa-base文件加上options snd-hda-intel model=xxxxx 有声音 可是插上耳机没声音(耳机没问题),请问有用这个声卡芯片的解决的吗?谢谢! :em20

已解决,见7楼


最后由 xxid 编辑于 2009-05-30 23:35,总共编辑了 4 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 华硕N80耳机无声音,快崩溃了
帖子发表于 : 2009-04-28 21:16 
头像

注册: 2007-05-31 20:17
帖子: 207
地址: DUT
送出感谢: 0 次
接收感谢: 0 次
重新编译一下alsa呢?


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 华硕N80耳机无声音,快崩溃了
帖子发表于 : 2009-04-28 21:17 

注册: 2007-05-11 13:43
帖子: 38
送出感谢: 1
接收感谢: 1
试过了,不行,没声音..


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 华硕N80耳机无声音,快崩溃了
帖子发表于 : 2009-04-28 21:23 

注册: 2008-01-12 10:29
帖子: 39
送出感谢: 0 次
接收感谢: 0 次
需要装realtek的linux驱动
google一下就有
我的alc888也是耳机没声音,而且auto jack侦测无效


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 华硕N80耳机无声音,快崩溃了
帖子发表于 : 2009-04-29 9:25 

注册: 2007-05-11 13:43
帖子: 38
送出感谢: 1
接收感谢: 1
mofunzone 写道:
需要装realtek的linux驱动
google一下就有
我的alc888也是耳机没声音,而且auto jack侦测无效

编译alsa-util时候总出现这个错误。
代码:
Making all in include
make[1]: 正在进入目录 `/home/ming/realtek-linux-audiopack-5.11/alsa-utils-1.0.19/include'
make  all-am
make[2]: 正在进入目录 `/home/ming/realtek-linux-audiopack-5.11/alsa-utils-1.0.19/include'
make[2]:正在离开目录 `/home/ming/realtek-linux-audiopack-5.11/alsa-utils-1.0.19/include'
make[1]:正在离开目录 `/home/ming/realtek-linux-audiopack-5.11/alsa-utils-1.0.19/include'
Making all in alsactl
make[1]: 正在进入目录 `/home/ming/realtek-linux-audiopack-5.11/alsa-utils-1.0.19/alsactl'
Making all in init
make[2]: 正在进入目录 `/home/ming/realtek-linux-audiopack-5.11/alsa-utils-1.0.19/alsactl/init'
make[2]: 没有什么可以做的为 `all'。
make[2]:正在离开目录 `/home/ming/realtek-linux-audiopack-5.11/alsa-utils-1.0.19/alsactl/init'
make[2]: 正在进入目录 `/home/ming/realtek-linux-audiopack-5.11/alsa-utils-1.0.19/alsactl'
make[2]: 没有什么可以做的为 `all-am'。
make[2]:正在离开目录 `/home/ming/realtek-linux-audiopack-5.11/alsa-utils-1.0.19/alsactl'
make[1]:正在离开目录 `/home/ming/realtek-linux-audiopack-5.11/alsa-utils-1.0.19/alsactl'
Making all in alsaconf
make[1]: 正在进入目录 `/home/ming/realtek-linux-audiopack-5.11/alsa-utils-1.0.19/alsaconf'
Making all in po
make[2]: 正在进入目录 `/home/ming/realtek-linux-audiopack-5.11/alsa-utils-1.0.19/alsaconf/po'
mv: 无法 stat “t-ja.gmo”: 没有该文件或目录
make[2]: *** [ja.gmo] 错误 1
make[2]:正在离开目录 `/home/ming/realtek-linux-audiopack-5.11/alsa-utils-1.0.19/alsaconf/po'
make[1]: *** [all-recursive] 错误 1
make[1]:正在离开目录 `/home/ming/realtek-linux-audiopack-5.11/alsa-utils-1.0.19/alsaconf'
make: *** [all-recursive] 错误 1



页首
 用户资料  
 
6 楼 
 文章标题 : Re: 华硕N80耳机无声音,快崩溃了
帖子发表于 : 2009-05-04 9:12 

注册: 2006-11-17 9:53
帖子: 212
送出感谢: 0 次
接收感谢: 0 次
内核降级到2.6.27 据说可以解决问题


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 华硕N80耳机无声音,快崩溃了
帖子发表于 : 2009-05-07 21:07 

注册: 2007-05-11 13:43
帖子: 38
送出感谢: 1
接收感谢: 1
终于解决了,耳机也正常了!在国外一个网站找的方法,下面贴出来给大家分享下!(系统是9.04)至此我的N80所有硬件完美驱动,赞下Ubuntu!

解决方法很简单:

代码:
sudo gedit /etc/modprobe.d/alsa-base.conf


在文件最后添加
代码:
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=m51va
options snd-hda-intel enable_msi=1


保存,重启计算机即可! :em05


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 华硕N80耳机无声音,快崩溃了
帖子发表于 : 2009-05-11 17:06 

注册: 2009-04-30 12:15
帖子: 14
送出感谢: 0 次
接收感谢: 0 次
mark 留标!

:em04 :em04 :em04


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 华硕N80耳机无声音,快崩溃了
帖子发表于 : 2009-05-11 17:50 
头像

注册: 2009-05-05 22:27
帖子: 16
送出感谢: 0 次
接收感谢: 0 次
和我的一样,9.04的好像都是这样。我用ASLA重新编译之后我的硬件驱动直接是找不回来了,我想问问,有什么办法没???


页首
 用户资料  
 
10 楼 
 文章标题 : Re: [已解决]华硕N80耳机无声音,快崩溃了
帖子发表于 : 2009-05-30 10:32 

注册: 2008-10-23 16:45
帖子: 34
送出感谢: 0 次
接收感谢: 0 次
不错,学习。


_________________
Acer 4710G/T5300/Intel945/ATI2300/DDR667 3G/HD250G/Ubuntu9.04&Windows7RC


页首
 用户资料  
 
11 楼 
 文章标题 : Re: [已解决]华硕N80耳机无声音,快崩溃了
帖子发表于 : 2009-05-31 9:19 
头像

注册: 2009-02-05 20:08
帖子: 37
送出感谢: 0 次
接收感谢: 0 次
按照你的方法还是没声音~~唉!~郁闷死了


页首
 用户资料  
 
12 楼 
 文章标题 : Re: [已解决]华硕N80耳机无声音,快崩溃了
帖子发表于 : 2009-06-02 22:11 

注册: 2008-10-23 16:45
帖子: 34
送出感谢: 0 次
接收感谢: 0 次
我也在学习,郁闷了 。


_________________
Acer 4710G/T5300/Intel945/ATI2300/DDR667 3G/HD250G/Ubuntu9.04&Windows7RC


页首
 用户资料  
 
13 楼 
 文章标题 : Re: [已解决]华硕N80耳机无声音,快崩溃了
帖子发表于 : 2009-06-15 17:18 

注册: 2009-06-14 22:43
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
:em05 :em05 :em11 :em11 :em11
按照7楼的方法我顺利解决了
我的是华硕N80
哈哈 支持


页首
 用户资料  
 
14 楼 
 文章标题 : Re: [已解决]华硕N80耳机无声音,快崩溃了
帖子发表于 : 2009-10-14 18:46 

注册: 2009-10-13 4:18
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
useful,mark


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 14 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译