当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 39 篇帖子 ]  前往页数 1, 2, 3  下一页
作者 内容
1 楼 
 文章标题 : 【已解决】compaq CQ40 CQ45系列笔记本IDT声卡在Ubuntu9.04中无声的解决方法
帖子发表于 : 2009-05-01 10:58 
头像

注册: 2007-08-19 22:47
帖子: 27
地址: 无锡
送出感谢: 0 次
接收感谢: 0 次
我用的是CQ40-123AX 笔记本,声卡是IDT的。原来在Ubuntu 8.10中可以正常发声。升级到Ubuntu 9.04以后,发现音量控制还在,Mp3文件也能正常播放,就是没有声音出来。

参考以下两篇帖子以后,我解决了这个问题。

声卡codec:IDT 92HD71B7X在Ubuntu 8.10无声的解决方法

No audio in Jaunty 9.04

首先第一步,确认你的声卡型号
代码:
sudo head -1 /proc/asound/card0/codec#0


我这里显示是:Codec: IDT 92HD71B7X

第二步,编辑alsa-base.conf
代码:
sudo gedit /etc/modprobe.d/alsa-base.conf


找到文档底部区域,有很多options的地方,填入以下内容:

代码:
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=hp-dv5
options snd-hda-intel enable_msi=1


保存退出后重启计算机,应该就能听到久违的声音了。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 【已解决】compaq CQ40 CQ45系列笔记本IDT声卡在Ubuntu9.04中无声的解决方法
帖子发表于 : 2009-05-04 12:58 
头像

注册: 2009-04-26 21:01
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
我的是CQ45的机子,vista+ubuntu双系统。声卡也是 IDT 92HD71B7X。按此方法操作后还是没反应。目前机子还是哑的。 恳请LZ将编辑后的alsa-base.conf代码发出.......
先谢过了。 :em06 :em06


_________________
我是菜鸟,菜得惊天动地。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 【已解决】compaq CQ40 CQ45系列笔记本IDT声卡在Ubuntu9.04中无声的解决方法
帖子发表于 : 2009-05-04 16:12 

注册: 2009-05-04 16:09
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
所说方法的确有效
惠普CQ40 609AX 上成功


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 【已解决】compaq CQ40 CQ45系列笔记本IDT声卡在Ubuntu9.04中无声的解决方法
帖子发表于 : 2009-05-04 23:43 

注册: 2009-05-03 12:38
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
为什么我输入sudo gedit /etc/modprobe.d/alsa-base.conf后出现的文档是空白的呢 我也是这个型号的声卡 在出现的空白文档里保存了那段命令 重启还是没有声音


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 【已解决】compaq CQ40 CQ45系列笔记本IDT声卡在Ubuntu9.04中无声的解决方法
帖子发表于 : 2009-05-05 10:48 
头像

注册: 2009-04-26 21:01
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
在电脑出声之前这贴可不能沉.......
有空就来顶顶。


_________________
我是菜鸟,菜得惊天动地。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 【已解决】compaq CQ40 CQ45系列笔记本IDT声卡在Ubuntu9.04中无声的解决方法
帖子发表于 : 2009-05-06 12:50 
头像

注册: 2009-04-26 21:01
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
再顶,顶到代码出来为止....... :em11 :em11 :em11


_________________
我是菜鸟,菜得惊天动地。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 【已解决】compaq CQ40 CQ45系列笔记本IDT声卡在Ubuntu9.04中无声的解决方法
帖子发表于 : 2009-05-07 12:37 

注册: 2009-03-03 8:50
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
晚上回去试一下
我和与楼主一样的问题
电脑是CQ40-112au的


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 【已解决】compaq CQ40 CQ45系列笔记本IDT声卡在Ubuntu9.04中无声的解决方法
帖子发表于 : 2009-05-07 18:07 

注册: 2009-03-03 8:50
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
用楼主的方法已经解决了,谢谢


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 【已解决】compaq CQ40 CQ45系列笔记本IDT声卡在Ubuntu9.04中无声的解决方法
帖子发表于 : 2009-05-08 19:52 
头像

注册: 2009-04-26 21:01
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
DDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDDD


_________________
我是菜鸟,菜得惊天动地。


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 【已解决】compaq CQ40 CQ45系列笔记本IDT声卡在Ubuntu9.04中无声的解决方法
帖子发表于 : 2009-05-08 23:09 
头像

注册: 2009-04-20 12:42
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
查看声卡型号看不了,输入命令sudo head -1 /proc/asound/card0/codec#0 得到提示:head: 无法打开 “/proc/asound/card0/codec#0” 读取数据: 没有该文件或目录
怎么回事? :em23


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 【已解决】compaq CQ40 CQ45系列笔记本IDT声卡在Ubuntu9.04中无声的解决方法
帖子发表于 : 2009-05-08 23:34 
头像

注册: 2009-04-20 12:42
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
型号是Intel Corp. 82801DB (ICH4) ,按照官网上写的add 'options snd-intel8x0 ac97_quirk=2' in /etc/modprobe.d/alsa-base ,但是重启还是没有声音,郁闷了。。。


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 【已解决】compaq CQ40 CQ45系列笔记本IDT声卡在Ubuntu9.04中无声的解决方法
帖子发表于 : 2009-05-10 12:48 

注册: 2008-08-24 21:34
帖子: 618
地址: 福州
送出感谢: 1
接收感谢: 0 次
成功解决


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 【已解决】compaq CQ40 CQ45系列笔记本IDT声卡在Ubuntu9.04中无声的解决方法
帖子发表于 : 2009-05-11 17:10 

注册: 2009-05-11 17:05
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
成功解决,谢谢LZ!


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 【已解决】compaq CQ40 CQ45系列笔记本IDT声卡在Ubuntu9.04中无声的解决方法
帖子发表于 : 2009-05-11 19:49 
头像

注册: 2007-08-19 22:47
帖子: 27
地址: 无锡
送出感谢: 0 次
接收感谢: 0 次
大家好,我的alsa-base.conf全部内容如下,如果有需要请尽管参考


代码:
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=hp-dv5
options snd-hda-intel enable_msi=1
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2



页首
 用户资料  
 
15 楼 
 文章标题 : Re: 【已解决】compaq CQ40 CQ45系列笔记本IDT声卡在Ubuntu9.04中无声的解决方法
帖子发表于 : 2009-05-11 19:52 
头像

注册: 2007-08-19 22:47
帖子: 27
地址: 无锡
送出感谢: 0 次
接收感谢: 0 次
wslb1111 写道:
为什么我输入sudo gedit /etc/modprobe.d/alsa-base.conf后出现的文档是空白的呢 我也是这个型号的声卡 在出现的空白文档里保存了那段命令 重启还是没有声音


也许你的还是旧的alsa-base文档,你试试sudo gedit /etc/modprobe.d/alsa-base

如果还是没有,你需要再查查


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 39 篇帖子 ]  前往页数 1, 2, 3  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译