当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求助,还是intel845集成显卡问题
帖子发表于 : 2005-08-15 22:12 

注册: 2005-08-14 18:16
帖子: 125
送出感谢: 0 次
接收感谢: 0 次
我仔细看过论坛上关于intel845显卡的问题,但是下载回来的4种官方与非官方的驱动在安装的时候,都会提示:

ERROR: Kernel modules did not compile

The DRI drivers can not be installed without the latest kernel modules.
Installation will be aborted. See the dri.log file for information on
what went wrong.



请帮忙看看,不胜感谢!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-08-15 23:02 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
代码:
uname -r

显示出来后:
代码:
sudo apt-get install linux-headers-'uname -r'

先看行不行,有的人还需要做个链接到linux。


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-08-16 8:28 
头像

注册: 2005-05-19 18:38
帖子: 1989
地址: 湖南永州
送出感谢: 0 次
接收感谢: 1
照做就没事了

http://forum.ubuntu.org.cn/viewtopic.php?p=9386#9386


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-08-16 10:04 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
对啊,多向gnix_oag兄弟请教。。过来人嘛 :P


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-08-16 11:10 

注册: 2005-08-14 18:16
帖子: 125
送出感谢: 0 次
接收感谢: 0 次
yongyi 写道:
代码:
uname -r

显示出来后:
代码:
sudo apt-get install linux-headers-'uname -r'

先看行不行,有的人还需要做个链接到linux。


不行
yee@ubuntu:~$ uname -r
2.6.10-5-686
yee@ubuntu:~$ sudo apt-get install linux-headers-'uname -r'
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
E: 无法找到软件包 linux-headers-uname -r


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2005-08-16 11:12 

注册: 2005-08-14 18:16
帖子: 125
送出感谢: 0 次
接收感谢: 0 次
安装了linux-headers-2.6.10-5-686


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2005-08-16 11:13 

注册: 2005-08-14 18:16
帖子: 125
送出感谢: 0 次
接收感谢: 0 次
还是不行

ERROR: Kernel modules did not compile

The DRI drivers can not be installed without the latest kernel modules.
Installation will be aborted. See the dri.log file for information on
what went wrong.

dir.log内容如下

make DRM_MODULES=i810.o modules
make[1]: Entering directory `/home/yee/dripkg/drm/linux-core'
make -C /lib/modules/2.6.10-5-686/build SUBDIRS=`pwd` DRMSRCDIR=`pwd` modules
/usr/src/linux-headers-2.6.10-5-686/scripts/gcc-version.sh: line 11: gcc: command not found
/usr/src/linux-headers-2.6.10-5-686/scripts/gcc-version.sh: line 12: gcc: command not found
make[2]: Entering directory `/usr/src/linux-headers-2.6.10-5-686'
CC [M] /home/yee/dripkg/drm/linux-core/drm_auth.o
/bin/sh: gcc: command not found
make[3]: *** [/home/yee/dripkg/drm/linux-core/drm_auth.o] 错误 127
make[2]: *** [_module_/home/yee/dripkg/drm/linux-core] 错误 2
make[2]: Leaving directory `/usr/src/linux-headers-2.6.10-5-686'
make[1]: *** [modules] 错误 2
make[1]: Leaving directory `/home/yee/dripkg/drm/linux-core'
make: *** [i810.o] 错误 2


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2005-08-16 11:15 
头像

注册: 2005-04-10 16:54
帖子: 2625
地址: 温州大学
送出感谢: 0 次
接收感谢: 1
对,他的意思就是要你先安装linux-headers-2.6.10-5-686!


_________________
我心无畏,源自于我心无知。
图片


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2005-08-16 12:05 
头像

注册: 2005-05-19 18:38
帖子: 1989
地址: 湖南永州
送出感谢: 0 次
接收感谢: 1
还没安装 gcc

怎么编译啊

sudo apt-get install gcc


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2005-08-16 13:41 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
gnix_oag 写道:

楼主试过没?

真晕。。连编译工具啥都没装呀! :oops:


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2005-08-16 14:00 

注册: 2005-08-14 18:16
帖子: 125
送出感谢: 0 次
接收感谢: 0 次
yongyi 写道:
gnix_oag 写道:

楼主试过没?

真晕。。连编译工具啥都没装呀! :oops:


sorry,我对ubuntu不熟悉,以为照着首页上的步骤就可以更新了,没想到gcc的问题 :oops:


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2005-08-16 14:23 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
没问题啦。
看看这:
安装基本的编译工具 (build-essential):
http://www.ubuntu.org.cn/support/docume ... erm=build-


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2005-08-16 23:34 
头像

注册: 2005-04-10 16:54
帖子: 2625
地址: 温州大学
送出感谢: 0 次
接收感谢: 1
呵呵,
一回生二回熟,
楼主兄弟下回就会很清楚了!


_________________
我心无畏,源自于我心无知。
图片


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译