不能用USB鼠标

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
haospoke
帖子: 8
注册时间: 2005-08-05 15:43
来自: TA
送出感谢: 0
接收感谢: 0
联系:

不能用USB鼠标

#1

帖子 haospoke » 2005-08-16 0:43

刚刚装好了ubuntu,硬件支持的都还不错,但是唯独鼠标不能用,我的是USB的,不管是开机前拔下来还是启动后再插拔,根本就没有反应,是不是对USB的支持模块没有安装上?????

不只是我的鼠标,我尝试了U盘也是不行的,根本就不会自动认出来。请高手指教
头像
lyreopera
帖子: 771
注册时间: 2005-05-23 13:38
来自: gdsz
送出感谢: 0
接收感谢: 0

#2

帖子 lyreopera » 2005-08-16 0:44

我不是高手,我没这种事……

楼下继续……
……
头像
gnix_oag
帖子: 1994
注册时间: 2005-05-19 18:38
来自: 湖南永州
送出感谢: 0
接收感谢: 1 次
联系:

#3

帖子 gnix_oag » 2005-08-16 8:31

windows 操作系统有没有这个问题啊

好象是硬件问题,换个接口试试
头像
annerose
帖子: 105
注册时间: 2005-04-07 20:15
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 annerose » 2005-09-04 21:53

买个usb到ps/2的转接不就行了!也不贵,不愿意的话试试在bios里设一下关于usb的选项,记得以前用debain时默认是支持usb设备的
试着用它来代替windows吧,你会重新找回当年的感动!
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 yongyi » 2005-09-04 22:27

我特意找了同事的mp3,也没办法连上哦。
/etc/mtab:

/dev/hda11 / xfs rw 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
devpts /dev/pts devpts rw,gid=5,mode=620 0 0
tmpfs /dev/shm tmpfs rw 0 0
usbfs /proc/bus/usb usbfs rw 0 0
/dev/hda10 /boot ext3 rw 0 0
/dev/hda1 /media/hda1 vfat rw,noexec,nosuid,nodev,utf8,umask=000 0 0
/dev/hda5 /media/hda5 vfat rw,noexec,nosuid,nodev,utf8,umask=000 0 0
/dev/hda6 /media/hda6 vfat rw,noexec,nosuid,nodev,utf8,umask=000 0 0
/dev/hda7 /media/hda7 vfat rw,noexec,nosuid,nodev,utf8,umask=000 0 0
/dev/hda8 /media/hda8 vfat rw,noexec,nosuid,nodev,utf8,umask=000 0 0
tmpfs /dev tmpfs rw,size=10M,mode=0755 0 0

哪位兄弟支招呀?
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
suave
帖子: 34
注册时间: 2005-09-05 12:09
来自: Peking
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 suave » 2005-09-05 15:00

我的移动硬盘插上以后可以自动识别,装载,还弹出一个窗口,跟xp下的一样,速度更快。
头像
oneleaf
论坛管理员
帖子: 10218
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 102 次

#7

帖子 oneleaf » 2005-09-05 16:30

我使用的USB也没有任何问题。
当净其意如虚空,远离妄想及诸取,令心所向皆无碍
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#8

帖子 firehare » 2005-09-05 18:10

如果不是USB硬件的问题的话,那么请查看一下/etc/hotplug/usb目录下是否存在文件?如果没有的话,初步怀疑是用Server命令安装的系统,可能要安装相应的包!
我心无畏,源自于我心无知。
图片
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#9

帖子 firehare » 2005-09-06 8:26

如果还是不行的话,就要用绝招了,用Hotplug自己建一个.usermap文件和一个相应脚本!不过请先用lsusb,告诉我你的USB鼠标的VID和PID
我心无畏,源自于我心无知。
图片
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 yongyi » 2005-09-06 9:20

firehare 写了:如果不是USB硬件的问题的话,那么请查看一下/etc/hotplug/usb目录下是否存在文件?如果没有的话,初步怀疑是用Server命令安装的系统,可能要安装相应的包!

劲呀!
我的网络安装的!
yongyi@ubuntu:/etc/hotplug/usb$ ls
libgphoto2

yongyi@ubuntu:/usr/share$ lsusb
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
(现在mp3不在)

要怎么搞了?PS:你在我就不去google了:)
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#11

帖子 firehare » 2005-09-06 10:58

MP3在的时候,再用lsusb,这样才可能找出它的VID和PID
我心无畏,源自于我心无知。
图片
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#12

帖子 firehare » 2005-09-06 14:05

因为在*.usermap文件中要用!
我心无畏,源自于我心无知。
图片
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 yongyi » 2005-09-06 15:27

firehare 写了:MP3在的时候,再用lsusb,这样才可能找出它的VID和PID

yongyi@ubuntu:~$ lsusb
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 002: ID 04fc:757a Sunplus Technology Co., Ltd
Bus 001 Device 001: ID 0000:0000

这次有了!帮我看看怎么访问它。在MP3那也显示PC的了。
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
yongyi
帖子: 3025
注册时间: 2005-05-07 23:57
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 yongyi » 2005-09-06 15:49

看来是跟桌面环境有关了,我用xfce4的,发现其实已经认出来的了,只是没挂载上去而已。
yongyi@ubuntu:~$ sudo mkdir /media/flash
yongyi@ubuntu:~$ sudo mount /dev/sda1 /media/flash/

然后在/media/flash/ 下就找到mp3的东西了。
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#15

帖子 firehare » 2005-09-06 16:36

这样就好办了,我们可以用hotplug来具体实现自动挂载:
到/etc/hotplug/usb目录下,新建文件mp3.usermap

代码: 全选

# My Mp3
mp3            0x0003      0x04fc   0x757a    0x0000       0x0000       0x00         0x00            0x00            0x00            0x00               0x00               0x00000000


新建脚本文件 mp3,注意要加执行权限

代码: 全选

#!/bin/sh
case "$ACTION" in
   add)
        /bin/mount -t auto -o auto,sync,uid=1001,gid=100,umask=027 /dev/sda1 /media/mp3
   ;;
esac


至于如何挂载的话,你当然可以自己修改了,我这儿是设成了只允许你第一个用户看,当然是你自己了,如果其它人进入你的机器,就算是插上去了,也看不到内容!:)

然后sudo /etc/init.d/hotplug restart就可以了!祝你成功!!
我心无畏,源自于我心无知。
图片
回复

回到 “常用硬件支持”