当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 19 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 菜鸟安装ati9.5驱动基本成功! 附过程!
帖子发表于 : 2009-05-18 21:27 
头像

注册: 2008-04-08 14:09
帖子: 45
送出感谢: 0 次
接收感谢: 0 次
安装过程我参考的9.4的,这个http://wiki.cchtml.com/index.php/Ubuntu_Jaunty_Installation_Guide。英文的,让我很是纠结,不过 磕磕绊绊的算是装上了! :em06
顺便把步骤写下,英语水平比我这个低手还低的可以看看 :em04
安装之前先下载安装这几个关联程序 :
sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++5 dkms

1.下载9.5驱动。驱动下载参考这位筒子的帖子 viewtopic.php?f=42&t=203948
2.创建deb包。打开终端sh ati-driver-installer-9-5-x86.x86_64.run --buildpkg Ubuntu/jaunty
3.安装deb包:
32位的:sudo dpkg -i xorg-driver-fglrx_*.deb fglrx-kernel-source_*.deb fglrx-amdcccle_*.deb
64位的:sudo dpkg -i xorg-driver-fglrx_*.deb fglrx-kernel-source_*.deb fglrx-amdcccle_*.deb
貌似这俩命令是一样的 :em20
关于64位的系统貌似另有解释 ,我没看!64位系统的同志们再自己看吧!
4.生成一个新的xorg.conf 文件 sudo aticonfig --initial -f 如果没有错误的话就是安装成功了。重启就ok了。 :em11


ps: 我的是3650的显卡,如果装完驱动就直接重启的话,不知道为什么,总是不可避免的花屏或者黑屏。参考无数帖子后,发现把xorg改下就可以启动,虽然,开机的时候仍会闪几下,但终归是装上了,基本不影响使用。附我的xorg:
Section "Module"
Load "glx"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

另 我执行 sudo aticonfig --initial -f后出现这个
Uninitialised file found, configuring.
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.fglrx-4
求解! :em06


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 菜鸟安装ati9.5驱动基本成功! 附过程!
帖子发表于 : 2009-05-18 21:42 
头像

注册: 2007-03-07 9:35
帖子: 198
送出感谢: 0 次
接收感谢: 0 次
恭喜恭喜一下哈。 :em11


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 菜鸟安装ati9.5驱动基本成功! 附过程!
帖子发表于 : 2009-05-18 22:04 
头像

注册: 2008-12-19 13:44
帖子: 2337
地址: 东8区
送出感谢: 0 次
接收感谢: 0 次
补充下不支持29内核或者30内核。29的要补丁的


_________________
代码:
 
       \   ,__,
        \  (oo)____
           (__)    )\
              ||--|| * 
 


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 菜鸟安装ati9.5驱动基本成功! 附过程!
帖子发表于 : 2009-05-18 22:06 
头像

注册: 2007-01-28 23:00
帖子: 2682
地址: @江西|南昌@
送出感谢: 0 次
接收感谢: 0 次
fglrx.
close source 的驱动吧!


_________________

Do as you would be done by !


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 菜鸟安装ati9.5驱动基本成功! 附过程!
帖子发表于 : 2009-05-18 22:07 
头像

注册: 2008-10-14 21:54
帖子: 880
送出感谢: 0 次
接收感谢: 2
ATI的显卡还真麻烦,上次帮一个同学装ubuntu
用ATI官方的驱动,花屏了。


_________________
地狱可以想象,天堂却无法描述。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 菜鸟安装ati9.5驱动基本成功! 附过程!
帖子发表于 : 2009-05-19 0:20 

注册: 2008-08-24 21:34
帖子: 618
地址: 福州
送出感谢: 1
接收感谢: 0 次
为什么不直接sudo sh *·run解决呢?


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 菜鸟安装ati9.5驱动基本成功! 附过程!
帖子发表于 : 2009-05-19 4:16 
头像

注册: 2009-02-23 14:37
帖子: 278
地址: 北京
送出感谢: 0 次
接收感谢: 0 次
这个驱动在性能上比9.4有很大提升,可惜跟视频播放器的兼容性依旧~~~


_________________
ThinkPad X220i
i7-2620M CPU
8G DDR3 1333 RAM
INTEL SSDMCEAC180E3 - openSUSE 12.3 / Windows 7 Ultimate
HGST HTS725050A7E630 - main storage
咳咳。。。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 菜鸟安装ati9.5驱动基本成功! 附过程!
帖子发表于 : 2009-05-19 4:25 
头像

注册: 2009-02-23 14:37
帖子: 278
地址: 北京
送出感谢: 0 次
接收感谢: 0 次
compiz/kwin+垂直同步+播放器全屏=黑屏


_________________
ThinkPad X220i
i7-2620M CPU
8G DDR3 1333 RAM
INTEL SSDMCEAC180E3 - openSUSE 12.3 / Windows 7 Ultimate
HGST HTS725050A7E630 - main storage
咳咳。。。


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 菜鸟安装ati9.5驱动基本成功! 附过程!
帖子发表于 : 2009-05-19 8:28 

注册: 2008-08-24 21:34
帖子: 618
地址: 福州
送出感谢: 1
接收感谢: 0 次
先凑合着吧


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 菜鸟安装ati9.5驱动基本成功! 附过程!
帖子发表于 : 2009-05-19 9:51 
头像

注册: 2008-12-19 13:44
帖子: 2337
地址: 东8区
送出感谢: 0 次
接收感谢: 0 次
fhm476 写道:
为什么不直接sudo sh *·run解决呢?

不推荐这样


_________________
代码:
 
       \   ,__,
        \  (oo)____
           (__)    )\
              ||--|| * 
 


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 菜鸟安装ati9.5驱动基本成功! 附过程!
帖子发表于 : 2009-05-20 0:22 

注册: 2008-08-24 21:34
帖子: 618
地址: 福州
送出感谢: 1
接收感谢: 0 次
pcbird 写道:
fhm476 写道:
为什么不直接sudo sh *·run解决呢?

不推荐这样
这样有什么问题吗?我一直都是这样装的,似乎也没出现什么事情,而且卸载也只要一条命令而已,蛮方便的。


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 菜鸟安装ati9.5驱动基本成功! 附过程!
帖子发表于 : 2009-05-20 0:37 
头像

注册: 2007-07-16 19:43
帖子: 1362
地址: tangshan
送出感谢: 0 次
接收感谢: 0 次
ati 老卡行吗?9.04显卡让我很郁闷


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 菜鸟安装ati9.5驱动基本成功! 附过程!
帖子发表于 : 2009-05-20 0:39 
头像

注册: 2008-12-19 13:44
帖子: 2337
地址: 东8区
送出感谢: 0 次
接收感谢: 0 次
没指望了


_________________
代码:
 
       \   ,__,
        \  (oo)____
           (__)    )\
              ||--|| * 
 


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 菜鸟安装ati9.5驱动基本成功! 附过程!
帖子发表于 : 2009-05-21 0:41 
头像

注册: 2008-11-01 20:43
帖子: 17322
系统: 自动检测比较好
送出感谢: 44
接收感谢: 11
10 楼 pcbird
文章标题 : Re: 菜鸟安装ati9.5驱动基本成功! 附过程!
有新帖发表于 : 2009-05-19 9:51
头像

注册: 2008-12-19 13:44
帖子: 1665
地址: 这个星球
fhm476 写道:
为什么不直接sudo sh *·run解决呢?

不推荐这样

为什么呢?


_________________
谁是我?KL.Uiq8 YinMeng


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 菜鸟安装ati9.5驱动基本成功! 附过程!
帖子发表于 : 2009-05-21 2:05 
头像

注册: 2008-05-03 23:05
帖子: 383
送出感谢: 0 次
接收感谢: 0 次
参考此地址:http://wiki.cchtml.com/index.php/Ubuntu_Jaunty_Installation_Guide

9.04 AMD_64刚装了9.5驱动成功降落~对比一下(本人HD3200):

用mesa时 glxgears: 200fps左右
用9.5催化剂: glxgears: 1000fps左右

smplayer和mplayer全屏均正常(vo均为xv)

$cat Xorg.0.log | grep WW
警告依旧, 不明白是怎么回事的看 http://forum.ubuntu.org.cn/viewtopic.php?f=48&t=193923&start=0
其中12楼是用源里受限驱动时我发的帖子

$cat Xorg.0.log | grep EE
暂时没发现错误

X的内存泄漏:刚开机大概半小时,还看不出来,但X开机只有不到120M的res(top查看),天灵灵地灵灵,千万不要再漏了 :em20


_________________
~~~~面条与米饭不可兼得~~~~


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 19 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译