当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题][郁闷]把Dapper装在移动硬盘上,我怎么总是失败?
帖子发表于 : 2006-08-01 9:54 
头像

注册: 2006-01-18 12:55
帖子: 1347
地址: 也许真的没有人理解
送出感谢: 0 次
接收感谢: 1
:em19 太失败了!
研究两天了,先是用3.5寸的大移动硬盘装,分区搞了半天,最后总算给装上了,结果启动不了(启动硬盘根本没反应,系统卡死)。

今天又在2.5寸的移动硬盘上装,装好之后似乎GRUB能启动了,可是在Mounting root filesystem时发生错误,找不到……
我可是严格按照http://old.ubuntu.org.cn/screenshots/breezyonusb的方法去做的,结果不行。

详细说明:移动硬盘40G,有三个区,ext3(被识别为盘上的第七个分区),swap(被识别为第六个)和FAT32。全部为扩展分区。

屏幕是这样显示的:
代码:
mount: Mounting /dev/sda7 on /root failed: No such device
mount: Mounting /root/dev on /dev/.static/dev failed: No such file or directory
mount: Mounting /sys on /root/sys failed: No such file or directory
mount: Mounting /proc on /root/proc failed: No such file or directory


可是在虚拟机中启动很正常,就是单独出来启动出现这样的错误。
(计算机是SATA硬盘,会不会有什么关系?)
怎么会这样?! :em21 谁来给个解释! 在线等。


_________________
MacBook Pro 15" User
Cocoa Programmer


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-08-02 11:42 
头像

注册: 2006-07-14 18:56
帖子: 345
地址: Apple Valley, Planet Tux, Linux System
送出感谢: 0 次
接收感谢: 0 次
http://www.ubuntuforums.org/showthread.php?t=80811上面说的做

还有最好不要在虚拟机下面安装,那样可能会有些问题。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-08-03 10:56 
头像

注册: 2006-01-18 12:55
帖子: 1347
地址: 也许真的没有人理解
送出感谢: 0 次
接收感谢: 1
装Breezy就没事,装Dapper就出问题。
奇怪,dapper不是对USB移动硬盘安装的支持更好吗。


_________________
MacBook Pro 15" User
Cocoa Programmer


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-08-14 20:19 

注册: 2006-03-23 18:31
帖子: 32
送出感谢: 0 次
接收感谢: 0 次
我也碰到了一样的问题,root文件系统mount不了。从升级到6.06就一直郁闷到现在,哎……
后来索性把NB的硬盘和移动硬盘换了过来,只用linux了。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: [问题][郁闷]把Dapper装在移动硬盘上,我怎么总是失败?
帖子发表于 : 2006-08-22 16:15 

注册: 2006-05-08 17:22
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
JangMunho 写道:
:em19 太失败了!
研究两天了,先是用3.5寸的大移动硬盘装,分区搞了半天,最后总算给装上了,结果启动不了(启动硬盘根本没反应,系统卡死)。

今天又在2.5寸的移动硬盘上装,装好之后似乎GRUB能启动了,可是在Mounting root filesystem时发生错误,找不到……
我可是严格按照http://old.ubuntu.org.cn/screenshots/breezyonusb的方法去做的,结果不行。

详细说明:移动硬盘40G,有三个区,ext3(被识别为盘上的第七个分区),swap(被识别为第六个)和FAT32。全部为扩展分区。

屏幕是这样显示的:
代码:
mount: Mounting /dev/sda7 on /root failed: No such device
mount: Mounting /root/dev on /dev/.static/dev failed: No such file or directory
mount: Mounting /sys on /root/sys failed: No such file or directory
mount: Mounting /proc on /root/proc failed: No such file or directory


可是在虚拟机中启动很正常,就是单独出来启动出现这样的错误。
(计算机是SATA硬盘,会不会有什么关系?)
怎么会这样?! :em21 谁来给个解释! 在线等。


呵呵,我最近已经成功地把gentoo都给装到移动硬盘上了,非常地爽,拿到哪里都可以插上去就用,就上网。ubuntu相对来说比较简单,应该不是问题。

你的问题,可能是在/dev/sda7 上:新的主板和新的linux,会把所有本地硬盘也认作scsi设备,如果你有一个本地固定硬盘(猜测,特别是SATA硬盘),它就是/dev/sda了,这时你的活动硬盘就变成/dev/sdb啦。

你测试一下看你的移动硬盘是不是变成/dev/sdb了?如果是再做相应的调整。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: [问题][郁闷]把Dapper装在移动硬盘上,我怎么总是失败?
帖子发表于 : 2006-09-27 12:23 

注册: 2006-09-27 9:00
帖子: 13
送出感谢: 0 次
接收感谢: 0 次
ant 写道:
JangMunho 写道:
:em19 太失败了!
研究两天了,先是用3.5寸的大移动硬盘装,分区搞了半天,最后总算给装上了,结果启动不了(启动硬盘根本没反应,系统卡死)。

今天又在2.5寸的移动硬盘上装,装好之后似乎GRUB能启动了,可是在Mounting root filesystem时发生错误,找不到……
我可是严格按照http://old.ubuntu.org.cn/screenshots/breezyonusb的方法去做的,结果不行。

详细说明:移动硬盘40G,有三个区,ext3(被识别为盘上的第七个分区),swap(被识别为第六个)和FAT32。全部为扩展分区。

屏幕是这样显示的:
代码:
mount: Mounting /dev/sda7 on /root failed: No such device
mount: Mounting /root/dev on /dev/.static/dev failed: No such file or directory
mount: Mounting /sys on /root/sys failed: No such file or directory
mount: Mounting /proc on /root/proc failed: No such file or directory


可是在虚拟机中启动很正常,就是单独出来启动出现这样的错误。
(计算机是SATA硬盘,会不会有什么关系?)
怎么会这样?! :em21 谁来给个解释! 在线等。


呵呵,我最近已经成功地把gentoo都给装到移动硬盘上了,非常地爽,拿到哪里都可以插上去就用,就上网。ubuntu相对来说比较简单,应该不是问题。

你的问题,可能是在/dev/sda7 上:新的主板和新的linux,会把所有本地硬盘也认作scsi设备,如果你有一个本地固定硬盘(猜测,特别是SATA硬盘),它就是/dev/sda了,这时你的活动硬盘就变成/dev/sdb啦。

你测试一下看你的移动硬盘是不是变成/dev/sdb了?如果是再做相应的调整。



I think so too!

以下都是指linux安装于移动硬盘or第二硬盘情况
楼主在用VM装系统的时候,要保持硬盘结构和真实环境一致(用VMware装了这么久linux系统--真的好久,光装了,没怎么用,sigh--我觉得在移动硬盘上装系统,or 机器两块固定硬盘各装一OS都要注意此点!!)
1.有几个硬盘-这个其实还好说:
a.如在VM中不反映出pc中的固定硬盘,就是不需要加载,那么在用移动硬盘启动pc时,只是没有挂载固定硬盘而已;如果对于两个固定硬盘装不同的OS,也是同样道理。
b.如果需要挂载xp(for example,MS的系统)下的硬盘/分区,则要在VMware中添加相应的硬盘,并保证节点正确(至于是不是要“独立-持久”,根据个人需要)。
--考虑到移动硬盘的移动性,应该是不用挂载xp下的分区的(可以在移动硬盘上分一个fat32的分区用于共享);而第二硬盘一般都要调用xp下的内容,所以需要挂载对应的硬盘(在VMware下也可只添加分区,则linux只需挂载相应的分区即可)
2.硬盘所在节点--通道号和主从之类的,如IDE0:0(对应hda),IDE0:1(对应hdb),IDE1:0(对应hdc),SCSI 0:0(对应sda)...--一定要和真实环境一样,否则会在pc启动时造成找不到系统的错误,如楼主得到的提示。
移动硬盘被认成SCSI硬盘,不管是pc真实启动环境还是VM启动环境。
a.如果pc里只有ide接口的硬盘,则在VMware中设scsi 0:0即可,安装正常后可以在pc上启动(pc支持usb启动,启动后可能进不了X,是调用显卡驱动的问题,/etc/X11/xorg.conf里面有设置,这个我还没有搞明白...)
b.如果PC里有了一块串口硬盘,移动硬盘在VMware中的节点设置就要小心了,最好在pc启动过程中看看移动硬盘对应的是什么节点,在VMware中设置相应的就行了(本人没有串口硬盘,故没有加以实践,故对应的scsi?:?,本人不敢瞎猜,还需要大家来实践总结)


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-09-29 8:56 

注册: 2006-02-28 15:44
帖子: 80
送出感谢: 0 次
接收感谢: 0 次
估计是因为你设备编号的问题,因为大多的sata硬盘在系统中也是映射到sdX设备的,按你的情况,很可能sda设备是你的原始硬盘,而不是你的移动硬盘。这个也是移动硬盘启动系统常遇到的问题,就是在启动的时候不能很好的标识定位本身,以保证启动项目的一些基础设置的一致性,特别是设备编号等等,而大多的启动工具又不支持卷标等一些可以表征设备特性的内容作为稳定设备信息的方式。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-10-05 15:40 

注册: 2006-09-23 13:37
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
I cannot open the link now. Can you?

http://old.ubuntu.org.cn/screenshots/breezyonusb

The proxy server received an invalid response from an upstream server.

=====


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译