当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求解:ubuntu9.04 intel 945GM集成显卡芯片组 显示问题
帖子发表于 : 2009-06-24 19:07 

注册: 2008-11-09 18:56
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
小弟用的是compaq v3172UT笔记本电脑
显卡是intel 945GM集成显卡
安装ubuntu 9.04

目前遇到问题是显示器分辨率最高只有1024*768(4:3)
其余还有2个低分辨率
刷新为0
附件:
文件注释: 显示设置
.png
.png [ 476.22 KiB | 被浏览 3257 次 ]



还有一个问题是,桌面特效无法开启
附件:
文件注释: 无法开启桌面效果
.png
.png [ 437.19 KiB | 被浏览 3254 次 ]



目前找不到方法解决。

看到其他人说intel的不用另外安装驱动也一切正常,不知我这个是怎么回事,请大家不吝赐教,谢谢!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 求解:ubuntu9.04 intel 945GM集成显卡芯片组 显示问题
帖子发表于 : 2009-06-24 22:39 
头像

注册: 2008-08-24 9:41
帖子: 252
送出感谢: 0 次
接收感谢: 1
我的也是intel 集成驱动,本来不打算弄驱动(vesa的就可以完成显示),只是放电影有点卡,而且竟然最基本的tuxracer也卡的不能玩,于是发狠google了一番,终于弄好了,至少tuxracer不卡,证明设置起作用,voila:

下面的步骤仅供参考:
1、安装显卡驱动xorg-video-intel,就是intel的显卡驱动
2、设置xorg.conf,arch里面的xorg.conf在/etc/X11下面
在Section "module"里面,要加载glx,dri 这两个选项
在Section "driver"里面,把原来的通用"vesa"换成"intel",
通过以上两步,就用上了intel的驱动,而且是direct rendering
这时运行
glxinfo | grep -i rend
显示
direct rendering: Yes
OpenGL renderer string: Software Rasterizer
3、opengl 这一项仍然是软件驱动,需要进一步改成硬件驱动,根据网上的说法,将用户名加入video组
sudo gpasswd -a yourname video

在xorg.conf增加
EndSection
Section "DRI"
mode 0666
EndSection
这时,再运行glxinfo | grep -i rend
direct rendering: Yes
OpenGL renderer string: Mesa DRI Intel(R) 945GM GEM 20090418 2009Q1 x86/MMX/SSE2
可见opengl已经用上了intel的驱动,再运行tuxracer,终于不卡,证明显卡设置成功 :em05

以上经验来自arch,仅供参考


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 求解:ubuntu9.04 intel 945GM集成显卡芯片组 显示问题
帖子发表于 : 2009-06-24 22:58 
头像

注册: 2008-10-01 0:20
帖子: 845
系统: ubuntu kylin14.04.3
送出感谢: 1
接收感谢: 0 次
以下方法均来自于本论坛,楼主说
cccmercury 写道:
目前找不到方法解决。
,不知是为什么,为了说理充分,我把来源链接也附上:
引用:
方法一:
来源:http://forum.ubuntu.org.cn/viewtopic.php?f=94&t=198462

执行下列命令,修改compiz的配置
sudo gedit /etc/xdg/compiz/compiz-manager

新起一行,增加SKIP_CHECKS=yes, 保存
重启系统,3D正常开启
资料来源:https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/363821
方法二:
来源:sudo gedit /usr/bin/compiz,看看你的显卡是否在黑名单,注释掉相关选项即可。
# blacklist based on the pci ids
# See http://wiki.compiz-fusion.org/Hardware/Blacklist for details
#T=" 1002:5954 1002:5854 1002:5955" # ati rs480
#T="$T 1002:4153" # ATI Rv350
#T="$T 8086:2982 8086:2992 8086:29a2 8086:2a02 8086:2a12" # intel 965
#T="$T 8086:2a02 " # Intel GM965
T="$T 8086:3577 8086:2562 " # Intel 830MG, 845G (LP: #259385)
方法三:
来源:http://forum.ubuntu.org.cn/viewtopic.php?f=94&t=114571
下面是解决方法:
首先备份一下配置文件
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.back

然后修改一下xorg.conf的配置

sudo gedit /etc/X11/xorg.conf

找到所有的Section “Device”段
将该段内的Driver设置为“Intel”, 保存。

然后卸载掉现在的驱动
sudo apt-get remove xserver-xorg-video-intel

再安装驱动
sudo apt-get install xserver-xorg-video-intel

配置显卡
sudo dpkg-reconfigure -phigh xserver-xorg

在弹出的界面中选择显卡品牌,屏幕分辨率等参数。

再执行下列命令,修改compiz的配置
sudo gedit /etc/xdg/compiz/compiz-manager

新起一行,增加SKIP_CHECKS=yes, 保存

执行sudo apt-get install compizconfig-settings-manager
安装compiz的配置管理器

之后重启系统。然后就能在System/Preferences/Appearance中打开显示特效了。我开的Normal。

有人说一上来选择Extra不行,需要现开Normal,成功后再改成Extra就可以了。

但是这个时候有一个Bug就是你的电影播放器(用Xv做驱动的)不能再正常播放电影了,比如(Totem,Mplayer)不能用了,需要修改一下!
Mplayer: 打开Mplayer ,单击右键,打开Prefernces,在Video选项卡里修改驱动,
把驱动由Xv改成 X11 X11(XImage/Shm)
保存就可以了,可以用你的Mplayer电影了!但是有时候你的Mplayer不能够全屏,这个时候修改

做如下修改:/home/crazier/.mplayer/config文件,我的用户名是crazier
就用这个目录,你把crazier改成你自己的用户目录就可以了
sudo gedit /home/crazier/.mplayer/config 添加
zoom=yes
这行就可以了,看看你的Mplayer是不是可以全屏了呢!

但是Totem还是不行的!

在终端中输入: gstreamer-properties
出现 multimemedia systems selector 修改Totem 的驱动 ,在Video选项卡中 Default Output中改为
X Window System(N0 Xv)然后保存,即可!
如果还 不行,那就把这个给xserver-xgl给安装上:
sudo apt-get install xserver-xgl
重新启动就可以用你的Totem看电影了,很爽!至此,我所遇到的问题都完美解决!
愿你也能马到成功!!
方法四:
来源:http://forum.ubuntu.org.cn/viewtopic.php?f=94&t=206788
一、升级intel显卡驱动
系统-系统管理-新立得软件管理包, 设置-软件库-第三方软件,添加 以下两个地址
deb http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu jaunty main
deb-src http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu jaunty main
刷新,会提示有两个部分需要升级(intel显卡驱动)
如果出现错误提示:
GPG签名验证错误: http://ppa.launchpad.net intrepid Release: 由于没有公钥,下列签名无法
进行行验证: NO_PUBKEY 5A9BF3BB4E5E17B5
解决方法:下载密匙
gpg --keyserver subkeys.pgp.net --recv 5A9BF3BB4E5E17B5
添加密匙

]或者直接用以下方法 升级 intel显卡驱动
卸载掉现在的驱动
sudo apt-get remove xserver-xorg-video-intel
再安装驱动
sudo apt-get install xserver-xorg-video-intel


二、运行sudo gedit /etc/X11/xorg.conf

Section “Device”
Identifier “Configured Video Device”
EndSection
修改为
Section “Device”
Identifier “intel”
EndSection


Section “Screen”
Identifier “Default Screen”
Monitor “Configured Monitor”
Device “Configured Video Device”
EndSection
修改为
Section “Screen”
Identifier “Default Screen”
Monitor “Configured Monitor”
Device “intel”
EndSection


三、修改compiz的配置
sudo gedit /etc/xdg/compiz/compiz-manager
新起一行,增加 SKIP_CHECKS=yes, 保存

四、安装compiz的配置管理器
运行 sudo apt-get install compizconfig-settings-manager
或者直接用新立德软件包管理器搜索并安装compizconfig-settings-manager

五、重启系统,打开系统-首选项- compizconfig设置管理器
至此成功打开桌面效果和3D


_________________
自由软件爱好者


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 求解:ubuntu9.04 intel 945GM集成显卡芯片组 显示问题
帖子发表于 : 2009-06-25 19:28 

注册: 2008-11-09 18:56
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
非常感谢两位提供建议!

遗憾的是,这些方法似乎并不适合我的状况。 :em06

目前分辨率问题还是不能解决。
另外,
引用:
三、修改compiz的配置
sudo gedit /etc/xdg/compiz/compiz-manager
新起一行,增加 SKIP_CHECKS=yes, 保存

开启特效时,画面一片空白。 :em20

想首先解决分辨率问题,继续寻找方法。 :em11
希望大家继续给予支持,谢谢!


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 求解:ubuntu9.04 intel 945GM集成显卡芯片组 显示问题
帖子发表于 : 2009-06-25 20:10 
头像

注册: 2008-04-26 12:41
帖子: 10971
送出感谢: 11
接收感谢: 38
:em06


_________________
[新手必读]wubi安装常见问题(FAQ)
[分享]装双系统的同学必看——Windows与Linux系统共享交换分区的方法
kde下唯美的暗黑内透主题(无需编译)
无穷老机上的Trinity Desktop Environment


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 求解:ubuntu9.04 intel 945GM集成显卡芯片组 显示问题
帖子发表于 : 2009-08-03 14:32 

注册: 2009-06-05 20:58
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
3L!


i'm ok!

Thx!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译