当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [已解决]更新alsa1.0.20之后每次开机都回到80%音量
帖子发表于 : 2009-07-28 21:13 

注册: 2009-03-18 0:25
帖子: 87
送出感谢: 0 次
接收感谢: 0 次
安装了realtek下载的最新驱动程序和,又试过alsa下载的1.0.20,无论音量调到什么位置,每次重启开机后都回到80%音量。

我的电脑是SONY VAIO NS140E,声卡是intel主板集成的realtek芯片alc262系列。

无解了好几天,google找不到, :em20 ,请大家帮帮忙,谢谢了!


最后由 Sinned 编辑于 2009-07-29 22:31,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 更新alsa1.0.20之后每次开机都回到80%音量
帖子发表于 : 2009-07-28 21:14 

注册: 2009-03-18 0:25
帖子: 87
送出感谢: 0 次
接收感谢: 0 次
SONY VAIO NS140E

Intel® Core® 2 Duo Processor T5800 (2GHz)
Intel® Centrino® processor technology
800MHz Front Side Bus Speed
2MB L2 Cache

250GB hard drive, Serial ATA
3GB DDR2 800 Dual Channel SDRAM

Mobile Intel® Graphics Media Accelerator 4500MHD with Intel® Clear Video technology with up to 1750MB (max) (depending on RAM configuration) total available graphics memory
Mobile Intel® GM45 Express Chipset

15.4" Screen
1280 x 800 Resolution
XBRITE-ECO™ LCD Technology

Intel® High Definition Audio Sound System

Fast Ethernet (RJ-45) Protocol
10Base-T/100Base-TX/1000Base-T
Integrated V.92/V.90 Modem (RJ-11)
Wireless LAN: Intel® WiFi Link 5100AGN (802.11a/b/g/n)

Built-in CD/DVD-RW drive

QWERTY keyboard, 82 kyes with 2.5mm stroke and 19.05mm pitch
Built-in 1.3 megapixel MOTION EYE® camera and microphone
Electro-Static touch pad
Biometric Fingerprint Sensor Trusted Platform Module(TPM) TCG Ver 1.2 compliant

Memory Stick Duo™ media slot with MagicGate® functionality
EpxressCard® 3/4 slot
SD memory card slot

官方介绍
http://www.sonystyle.com/webapp/wcs/stores/servlet/CategoryDisplay?catalogId=10551&storeId=10151&langId=-1&categoryId=8198552921644586399&parentCategoryId=1615


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 更新alsa1.0.20之后每次开机都回到80%音量
帖子发表于 : 2009-07-28 21:14 
头像

注册: 2007-09-29 3:09
帖子: 5773
送出感谢: 0 次
接收感谢: 3
调整后执行alsactl store保存状态


_________________
HUNT Unfortunately No Talent...


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 更新alsa1.0.20之后每次开机都回到80%音量
帖子发表于 : 2009-07-28 21:22 
头像

注册: 2009-05-20 19:32
帖子: 2462
送出感谢: 0 次
接收感谢: 2
irc <fvw> say: debian 的话 /etc/init.d/alsa-utils 服务要启用


_________________
irc 聊天室
ubuntu-cn 的irc 频道为
irc.ubuntu.com 8001 #ubuntu-cn
UTF8编码 可用 irssi xchat pidgin weechat 登录

http://webchat.freenode.net/?channels=ubuntu-cn
irc://irc.freenode.net/ubuntu-cn


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 更新alsa1.0.20之后每次开机都回到80%音量
帖子发表于 : 2009-07-28 21:23 
头像

注册: 2009-05-20 19:32
帖子: 2462
送出感谢: 0 次
接收感谢: 2
irc <fvw> say: 内部通过alsactl 开关机保存音量


_________________
irc 聊天室
ubuntu-cn 的irc 频道为
irc.ubuntu.com 8001 #ubuntu-cn
UTF8编码 可用 irssi xchat pidgin weechat 登录

http://webchat.freenode.net/?channels=ubuntu-cn
irc://irc.freenode.net/ubuntu-cn


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 更新alsa1.0.20之后每次开机都回到80%音量
帖子发表于 : 2009-07-28 21:52 

注册: 2009-03-18 0:25
帖子: 87
送出感谢: 0 次
接收感谢: 0 次
我在启动里面加了命令:/sbin/alsactl restore,好像有效解决了


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 更新alsa1.0.20之后每次开机都回到80%音量
帖子发表于 : 2009-07-28 21:54 

注册: 2009-03-18 0:25
帖子: 87
送出感谢: 0 次
接收感谢: 0 次
O_O_BOT 写道:
irc <fvw> say: debian 的话 /etc/init.d/alsa-utils 服务要启用


alsa-utils我有装的,请问如何启动这个服务?


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 更新alsa1.0.20之后每次开机都回到80%音量
帖子发表于 : 2009-07-28 21:59 

注册: 2009-03-18 0:25
帖子: 87
送出感谢: 0 次
接收感谢: 0 次
HuntXu 写道:
调整后执行alsactl store保存状态
这个命令用sudo执行了,但好像没有效,每次开机依旧回到80%音量


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 更新alsa1.0.20之后每次开机都回到80%音量
帖子发表于 : 2009-07-29 19:35 

注册: 2009-03-18 0:25
帖子: 87
送出感谢: 0 次
接收感谢: 0 次
重新安装一次1.0.20之后,现在每次重启都在静音了...

无奈

:em20


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 更新alsa1.0.20之后每次开机都回到80%音量
帖子发表于 : 2009-07-29 20:30 

注册: 2009-03-18 0:25
帖子: 87
送出感谢: 0 次
接收感谢: 0 次
在wiki里面找到:

在系统启动时恢复Alsa混音器设置
运行一次'alsactl'命令创建 '/etc/asound.state' 文件
alsactl store
编辑 '/etc/rc.conf' 文件,添加 'alsa' 到DAEMONS行,使得系统启动时运行。这样就可以在每次关机时保存混音器设置,启动的时候自动恢复设置。

但我没有/etc/rc.conf这个文件,怎么办?


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 更新alsa1.0.20之后每次开机都回到80%音量
帖子发表于 : 2009-07-29 22:30 

注册: 2009-03-18 0:25
帖子: 87
送出感谢: 0 次
接收感谢: 0 次
再装多个pulseaudio,问题彻底解决了

:em04


页首
 用户资料  
 
12 楼 
 文章标题 : Re: [已解决]更新alsa1.0.20之后每次开机都回到80%音量
帖子发表于 : 2009-07-29 22:42 
头像

注册: 2007-05-06 2:46
帖子: 15634
送出感谢: 0 次
接收感谢: 2
引用:
pulseaudio

我这简装的也有啊,你那怎会没有

倒是音量删了系统原来的gnome-media,gstreamerX

换用gnome-alsamixer比较有记性


:em06


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译