当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]升级xserver-xorg-core后出现问题.
帖子发表于 : 2006-08-22 10:56 

注册: 2006-01-18 18:11
帖子: 254
送出感谢: 0 次
接收感谢: 0 次
我的机器安装的KUBUNTU6.06,已经安装了nvidia-glx,以前使用一切正常.但在今天升级了xserver-xorg-core后,就不能进行X了.启动到安全模式下运行startx,出现如下错误:
Failed to load /usr/lib/xorg/modules/extensions/libGLcore.so
Failed to load module "GLcore" (loader failed, 7)
请问一下,该如何解决这个问题?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-08-22 11:44 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
代码:
$ l /usr/lib/xorg/modules/extensions/libGLcore.so
/usr/lib/xorg/modules/extensions/libGLcore.so
$ uname -r
2.6.15-26-686

你看你的是那个版本了。我这里有这个文件。
如果要测试,可以在xorg.conf里面找到。
$ cat /etc/X11/xorg.conf|grep glcore
看能不能先注视掉这行,或者换其他的模块,比如glx


_________________
● 鸣学


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-08-22 13:01 

注册: 2006-07-10 22:50
帖子: 380
送出感谢: 0 次
接收感谢: 0 次
我的同有这样的问题!下在处理。


页首
 用户资料  
 
4 楼 
 文章标题 : hehe
帖子发表于 : 2006-08-22 13:33 

注册: 2006-08-19 14:04
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
将nvidia-kernel nvidia-glx卸载,然后再安装一次试试看
或者直接使用xorg-x11作为OpenGL库,毕竟,linux下普通用户对显卡性能的挖掘不够。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-08-22 14:38 

注册: 2006-01-18 18:11
帖子: 254
送出感谢: 0 次
接收感谢: 0 次
试过了,没有用.
其他的用户也在反映这个问题.估计是core包的问题,准备降级处理一下试试.


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-08-22 16:58 
头像

注册: 2006-02-20 15:15
帖子: 36
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
我也遇到同样问题。刚才上英文论坛查了一下,无数人遭了这个升级的毒手。目前好像只有降级才能解决。英文论坛上提供的方法如下:

sudo apt-get install xserver-xorg-core=1:1.0.2-0ubuntu10

重启系统应该就可以了。

我还没来得及试,希望在我的电脑上也可以解决。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-08-22 17:45 
头像

注册: 2005-11-11 5:10
帖子: 208
送出感谢: 0 次
接收感谢: 0 次
一样的问题,
用sudo apt-get install xserver-xorg-core=1:1.0.2-0ubuntu10 试试先


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-08-23 10:10 
头像

注册: 2006-02-20 15:15
帖子: 36
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
今天ubuntu又放出来一个xserver-xorg-core 10.4的升级版本,升级后就没有再出现这个问题。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-08-23 13:26 

注册: 2006-07-10 22:50
帖子: 380
送出感谢: 0 次
接收感谢: 0 次
Hantao 写道:
今天ubuntu又放出来一个xserver-xorg-core 10.4的升级版本,升级后就没有再出现这个问题。


有谁升级成功了?


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-08-24 10:06 

注册: 2006-07-05 17:05
帖子: 79
送出感谢: 0 次
接收感谢: 0 次
大BUG,有点搞笑的全球错误.


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2006-08-25 11:07 
头像

注册: 2005-12-01 1:21
帖子: 53
送出感谢: 0 次
接收感谢: 0 次
我升级以后就OK了
昨天还以为ubuntu又被自己给玩死了


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译