当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 菜鸟安装nvidia185全记录图文版{老鸟绕过}
帖子发表于 : 2009-09-11 2:39 
头像

注册: 2009-03-31 12:16
帖子: 37
地址: 北京人在国外
送出感谢: 0 次
接收感谢: 0 次
本人很菜,一些脱裤子放屁的做法请大家见谅

1。我忘了我的显卡型号,所以用kubuntu的桌面插件 硬件信息,得知本人的是 Geforce8400 GS

2。上nvidia官网,发现自己对nvidia的产品型号一窍不通于是点击
附件:
1.png
1.png [ 772.55 KiB | 被浏览 1084 次 ]



再点如图的。。。
附件:
2.png
2.png [ 375.13 KiB | 被浏览 1084 次 ]



得到。。。
附件:
3.png
3.png [ 295.76 KiB | 被浏览 1084 次 ]

知道了产品系列 (图里写成家族了 :em06 ),准备下载

3。点击nvidia的驱动下载按钮, 选择产品家族,操作系统 和语言后,点搜索,出来了185,右键另存(否则浏览器会打开run文件), 保存时把文件名该的简单一些,放在home下,

4。打开新立德,搜索nvidia,把安装的全部彻底卸载 成败在此一举
附件:
4.png
4.png [ 206.04 KiB | 被浏览 1084 次 ]



5。打开终端
代码:
sudo apt-get install build-essential


安装编译环境, 然后重启

再此参照卞锦生http://forum.ubuntu.org.cn/viewtopic.php?f=42&t=180313卞锦生 同志表示无尽的感谢 :em42

6。拿出纸笔,抄下如下命令
代码:
sudo /etc/init.d/gdm stop
                                      sudo rmmod nvidia
                                      sudo rm -r -f /lib/modules/2.6.27-9-generic/kernel/drivers/video/nvidia
                                      sudo sh NV.run


当然了,第一行用K 的朋友们改成kdm就是了,最后一行的文件名用你自己的了。

7。ctrl+alt+F1 进入文本模式, 输入用户名,密码登录
8。把纸上的命令敲进去
9。之后的就狂选YES就是了
Kdm对KDE好一点,gdm就是对gnom好一点 都有的,自己看着办
10。 完了后
代码:
sudo reboot



在开机时看到了nvidia的splashscreen,成了


_________________
What can you do without freedom?
-William Wallace
只要心理不滑坡,办法总比问题多

安装最适合你的nvidia驱动http://forum.ubuntu.org.cn/viewtopic.php?f=42&t=226039


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 菜鸟安装nvidia185全记录图文版{老鸟绕过}
帖子发表于 : 2009-09-11 18:30 

注册: 2008-06-22 12:56
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
谢谢LZ的帖子,但我跟着做了一遍后,还是有问题。

在编译结束后,出现一个error:Unable to load the kernel module 'nvidia.ko',不知LZ知道怎么解决吗?

我现在的系统是Ubuntu9.04,用光盘安装的,装完后到现在一直是800 * 600 的分辨率,我的笔记本实际应该是1280 * 800。但Nvidia的驱动就是装不上,选受限驱动也不行。

同样的机器,记得以前8.04用wubi硬盘安装方式没问题,但这次光盘安装就是显示有问题,找了不少帖子也没有解决问题。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 菜鸟安装nvidia185全记录图文版{老鸟绕过}
帖子发表于 : 2009-09-12 5:56 
头像

注册: 2009-03-31 12:16
帖子: 37
地址: 北京人在国外
送出感谢: 0 次
接收感谢: 0 次
Leon.PAL4 写道:
谢谢LZ的帖子,但我跟着做了一遍后,还是有问题。

在编译结束后,出现一个error:Unable to load the kernel module 'nvidia.ko',不知LZ知道怎么解决吗?

我现在的系统是Ubuntu9.04,用光盘安装的,装完后到现在一直是800 * 600 的分辨率,我的笔记本实际应该是1280 * 800。但Nvidia的驱动就是装不上,选受限驱动也不行。

同样的机器,记得以前8.04用wubi硬盘安装方式没问题,但这次光盘安装就是显示有问题,找了不少帖子也没有解决问题。


我也是菜鸟 :em06 :em06 :em06 :em06 :em06 :em06

不好乙烯 :em20

建议一句 build essential了吗


_________________
What can you do without freedom?
-William Wallace
只要心理不滑坡,办法总比问题多

安装最适合你的nvidia驱动http://forum.ubuntu.org.cn/viewtopic.php?f=42&t=226039


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 菜鸟安装nvidia185全记录图文版{老鸟绕过}
帖子发表于 : 2009-09-16 16:43 
头像

注册: 2007-12-17 18:07
帖子: 1285
地址: 西安
送出感谢: 1
接收感谢: 1
:em06 好奇怪都说联想的笔记本不在支持之列,请联系OEM厂商


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 菜鸟安装nvidia185全记录图文版{老鸟绕过}
帖子发表于 : 2009-09-16 17:10 
头像

注册: 2008-11-21 20:26
帖子: 36913
送出感谢: 1
接收感谢: 36
受限驱动里不能直接装么?


_________________
讨厌我的人可以试着点一下
浏览全部ubuntu技巧


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 菜鸟安装nvidia185全记录图文版{老鸟绕过}
帖子发表于 : 2009-09-16 22:30 

注册: 2008-06-22 12:56
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
linkejian104 写道:
建议一句 build essential了吗

已经安装了,完全是照着帖子做的。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 菜鸟安装nvidia185全记录图文版{老鸟绕过}
帖子发表于 : 2009-09-16 22:32 

注册: 2008-06-22 12:56
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
tenzu 写道:
受限驱动里不能直接装么?

受限驱动试过,可以安装,但重启后进入系统会出错。有个提示,说是只能进低分辨率的图形界面。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 菜鸟安装nvidia185全记录图文版{老鸟绕过}
帖子发表于 : 2009-09-16 22:55 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
Leon.PAL4 写道:
tenzu 写道:
受限驱动里不能直接装么?

受限驱动试过,可以安装,但重启后进入系统会出错。有个提示,说是只能进低分辨率的图形界面。

装完成以后,可能还需要在纯终端下(Ctrl+Alt+F1可以进入),执行nvidia-xconfig之后生成新的xorg.conf文件,然后手动修改此文件,加入想要的分辨率。更详细的做法论坛里的硬件支持板块有贴子的,时间比较久了,搜索下坛子,也许能找到。


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 菜鸟安装nvidia185全记录图文版{老鸟绕过}
帖子发表于 : 2009-09-17 17:23 

注册: 2008-03-24 9:06
帖子: 18
送出感谢: 0 次
接收感谢: 0 次
/lib/modules/2.6.27-9-generic/kernel/drivers/video/nvidia

这个路径中的2.6.27-9-generic在9.04中是不存在的,9.04中是2.6.28-11-generic和2.6.28-15-generic,是不是,要把这两个里面的nvidia文件夹都删掉阿


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 菜鸟安装nvidia185全记录图文版{老鸟绕过}
帖子发表于 : 2009-09-22 18:22 

注册: 2009-09-19 20:50
帖子: 598
送出感谢: 0 次
接收感谢: 2
elementwater 写道:
/lib/modules/2.6.27-9-generic/kernel/drivers/video/nvidia

这个路径中的2.6.27-9-generic在9.04中是不存在的,9.04中是2.6.28-11-generic和2.6.28-15-generic,是不是,要把这两个里面的nvidia文件夹都删掉阿

把2.6.28-15-generic里面的nvidia文件夹都删掉就可以了

另外要提醒大家,删掉原有驱动重启后出现选择什么low Gaphics之类的时要选择要选择带有console这个代词的这一项,表示退出x-server,进入控制台。如果直接用Ctrl+Alt+F1进入控制台会发生无法exit the x-server的错误而无法安装。
楼主没说清楚,我被这个问题搞得焦头烂额了,发出来希望不要有更多人犯错。


_________________
aMule 2.3.1 is coming...
真正动态的 amule-dlp is coming...
本人帐号在2011年1月被盗,在2011年1月3日17:19到2010年1月6日13:34之间本帐号发的一切帖子、短信等与本人无关!
amule-dlp 开发动态
amule-dlp on Google Code
WebArchiver - 基于 wget 的网页归档工具(PyQt4 GUI 前端)
Linux 2.6.34 编译笔记


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 菜鸟安装nvidia185全记录图文版{老鸟绕过}
帖子发表于 : 2009-10-14 0:03 
头像

注册: 2009-03-31 12:16
帖子: 37
地址: 北京人在国外
送出感谢: 0 次
接收感谢: 0 次
Bill Lee 写道:
elementwater 写道:
/lib/modules/2.6.27-9-generic/kernel/drivers/video/nvidia

这个路径中的2.6.27-9-generic在9.04中是不存在的,9.04中是2.6.28-11-generic和2.6.28-15-generic,是不是,要把这两个里面的nvidia文件夹都删掉阿

把2.6.28-15-generic里面的nvidia文件夹都删掉就可以了

另外要提醒大家,删掉原有驱动重启后出现选择什么low Gaphics之类的时要选择要选择带有console这个代词的这一项,表示退出x-server,进入控制台。如果直接用Ctrl+Alt+F1进入控制台会发生无法exit the x-server的错误而无法安装。
楼主没说清楚,我被这个问题搞得焦头烂额了,发出来希望不要有更多人犯错。

我没说删完后重启吧??? :em20


_________________
What can you do without freedom?
-William Wallace
只要心理不滑坡,办法总比问题多

安装最适合你的nvidia驱动http://forum.ubuntu.org.cn/viewtopic.php?f=42&t=226039


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:风过云烟 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译