当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : HPCQ机子IDT声卡不发声的解决方法
帖子发表于 : 2009-09-25 23:05 

注册: 2009-02-09 20:44
帖子: 50
送出感谢: 0 次
接收感谢: 0 次
试了很多方法只有http://forum.ubuntu.com.cn/viewtopic.php?f=42&t=199912&sid=2c558e2492aa676cc97c878b1f773ec7&start=0才能用。在此对 caryloo 表示感谢。
如果还是不行的话,请直接拷贝以下内容到/etc/modprobe.d/alsa-base.conf中(请注意先备份,最后要重启)
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=hp-dv5
options snd-hda-intel enable_msi=1
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2


页首
 用户资料  
 
2 楼 
 文章标题 : Re: HPCQ机子IDT声卡不发声的解决方法
帖子发表于 : 2009-10-17 20:28 

注册: 2009-02-09 20:44
帖子: 50
送出感谢: 0 次
接收感谢: 0 次
如果还不行,编辑/etc/group文件,把audio:X:数字:pluse中的pluse改为你的登录用户名。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: HPCQ机子IDT声卡不发声的解决方法
帖子发表于 : 2009-10-22 15:10 

注册: 2009-09-13 0:16
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
liguanyao, 你好,我的电脑型号是hp compaq cq40-422tx,我在网上也找了很长时间有关声卡的设置,都行不通,你的方法也是,不知道你好有没有其他解决办法了,希望你可以不吝赐教,期待回复


页首
 用户资料  
 
4 楼 
 文章标题 : Re: HPCQ机子IDT声卡不发声的解决方法
帖子发表于 : 2010-01-19 22:14 

注册: 2009-02-09 20:44
帖子: 50
送出感谢: 0 次
接收感谢: 0 次
很抱歉啊,cq的这些机子用的声卡好像都跟ubunut和不来,我也经常装新系统后就花大量的时间在这个声音上面,实在找不到好的办法,你只能试多几次咯


页首
 用户资料  
 
5 楼 
 文章标题 : Re: HPCQ机子IDT声卡不发声的解决方法
帖子发表于 : 2010-01-19 22:24 

注册: 2008-10-31 19:06
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
我也是HP CQ 真是要整死个人,原来那台笔记本用的挺正常的


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译