当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 新手提问:帮我解决下显卡驱动安装问题,谢谢!
帖子发表于 : 2009-10-25 9:37 
头像

注册: 2009-10-09 16:21
帖子: 295
送出感谢: 0 次
接收感谢: 0 次
我的笔记本显卡是ati mobility radeon9700 64M的,笔记本是海尔H30。我从ati官网上下载了该显卡的驱动程序。以下是我的安装过程。请高手帮忙看看如何解决。

****@ubuntu:~$ sudo sh /home/****/software/ati-driver-installer-9-3-x86.x86_64.run
[sudo] password for ****:
Created directory fglrx-install.rFTHoF
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.593...........................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
==================================================
ATI Technologies Linux Driver Installer/Packager
==================================================

Error: ./default_policy.sh does not support version
default:v2:i686:lib::none:2.6.28-16-generic; make sure that the version is being
correctly set by --iscurrentdistro

Removing temporary directory: fglrx-install.rFTHoF


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 新手提问:帮我解决下显卡驱动安装问题,谢谢!
帖子发表于 : 2009-10-25 9:42 
头像

注册: 2009-10-09 16:21
帖子: 295
送出感谢: 0 次
接收感谢: 0 次
每次启动系统后都会花屏两次,播放视频也卡得要死。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 新手提问:帮我解决下显卡驱动安装问题,谢谢!
帖子发表于 : 2009-10-25 9:56 

注册: 2007-12-17 12:24
帖子: 58
地址: 重庆
送出感谢: 0 次
接收感谢: 0 次
其实你是不用再安装驱动的!!应为系统是自带开源驱动的!!我的是ATI mobility radeon X1300 就不用再去安装AMD官方的驱动了!!


你应该直接在桌面点击右键然后选择最后一项!然后选择虚礼桌面,然后选择最后一个效果看看行不行!如果行就不用再安装驱动了!!!

AMD官方的驱动对以前的老卡支持很烂的


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 新手提问:帮我解决下显卡驱动安装问题,谢谢!
帖子发表于 : 2009-10-25 13:44 
头像

注册: 2009-10-09 16:21
帖子: 295
送出感谢: 0 次
接收感谢: 0 次
今天 在添加删除程序中看到有专门对于ati显卡优化的程序,明天早上下来试试,不知道行不行。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 新手提问:帮我解决下显卡驱动安装问题,谢谢!
帖子发表于 : 2009-10-25 20:01 
头像

注册: 2008-11-01 3:02
帖子: 51
地址: 水星
送出感谢: 0 次
接收感谢: 0 次
看看这篇.或许有帮助.

viewtopic.php?f=42&t=166489


_________________
爱走.心碎.人憔悴...

喝不尽的杯中酒.斩不尽的心中愁...

问世间情为何物.只叫人伤碎心.痛彻骨...


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 新手提问:帮我解决下显卡驱动安装问题,谢谢!
帖子发表于 : 2009-10-26 12:13 
头像

注册: 2009-10-09 16:21
帖子: 295
送出感谢: 0 次
接收感谢: 0 次
今天安装了那ati显卡优化后直接进不去系统了,一直是花屏,又得重装,气死我了,好不容易都配置好了。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 新手提问:帮我解决下显卡驱动安装问题,谢谢!
帖子发表于 : 2009-10-26 12:44 
头像

注册: 2009-10-09 16:21
帖子: 295
送出感谢: 0 次
接收感谢: 0 次
123826776 写道:
看看这篇.或许有帮助.

viewtopic.php?f=42&t=166489


谢谢,那个解决方案好像不错,不过我现在进不去界面了,直接花屏卡在那了。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 新手提问:帮我解决下显卡驱动安装问题,谢谢!
帖子发表于 : 2009-10-26 14:27 
头像

注册: 2005-08-14 19:53
帖子: 3998
送出感谢: 1
接收感谢: 2
不知道是不是支持你的内核。因为驱动有些老了。推荐你还是不要折腾了,装9.10,不用装驱动,开源驱动性能足够了

现在花屏解决方法google一下,先进安全模式,恢复备份的xorg.conf


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 新手提问:帮我解决下显卡驱动安装问题,谢谢!
帖子发表于 : 2009-10-26 14:50 
头像

注册: 2009-10-09 16:21
帖子: 295
送出感谢: 0 次
接收感谢: 0 次
jarryson 写道:
不知道是不是支持你的内核。因为驱动有些老了。推荐你还是不要折腾了,装9.10,不用装驱动,开源驱动性能足够了

现在花屏解决方法google一下,先进安全模式,恢复备份的xorg.conf


楼上能说的具体点,我太菜,不知道如何恢复xorg.conf在不进入桌面的情况下,我现在进不去了。


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 新手提问:帮我解决下显卡驱动安装问题,谢谢!
帖子发表于 : 2009-10-26 18:02 
头像

注册: 2009-10-09 16:21
帖子: 295
送出感谢: 0 次
接收感谢: 0 次
终于在修复模式下恢复正常了。多谢8楼给的方法。我进入修复模式后进入使用根用户输入“apt-get autoremove xorg-driver-fglrx”后重新启动就正常了。


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 新手提问:帮我解决下显卡驱动安装问题,谢谢!
帖子发表于 : 2009-10-27 9:46 
头像

注册: 2009-10-09 16:21
帖子: 295
送出感谢: 0 次
接收感谢: 0 次
我是彻底没办法了,我按这个页面的指令——http://wiki.cchtml.com/index.php/Ubuntu_Intrepid_Installation_Guide ——一路装下去,最后终于安装完成了,可是最后键入“fglrxinfo”以后显示段错误,什么"couldn't find RGB GLX visual",我上网查了一下,好像大部分都是nvidia显卡有此问题。找了很多资料,试过无数改动,还是无法正常启动。

我安装后重启,系统提示——

Failed to load /usr/lib/xorg/module/extensions/libglx.so
Failed to load "glx"
Failed to load "fglrx"

只能以低画质图形界面启动,我是彻底没辙了,也没有时间在继续鼓捣了,还是卸了换回开源的驱动吧。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译