当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 9.10 下 显卡驱动问题: SystemError: installArchives() failed
帖子发表于 : 2009-11-06 9:43 
头像

注册: 2006-08-20 11:26
帖子: 79
送出感谢: 0 次
接收感谢: 0 次
代码:
Downloading the packages...
dpkg-exec: Running dpkg

(Reading database ... 114271 files and directories currently installed.)
Removing nvidia-96-kernel-source ...
nvidia-96-kernel-source: Removing nvidia-96-kernel-source

dpkg-exec: Running dpkg

Selecting previously deselected package nvidia-185-kernel-source.
(Reading database ... 114234 files and directories currently installed.)
Unpacking nvidia-185-kernel-source (from .../nvidia-185-kernel-source_185.18.36-0ubuntu9_i386.deb) ...
nvidia-185-kernel-source: Installing nvidia-185-kernel-source

nvidia-185-kernel-source: Preparing nvidia-185-kernel-source

Unpacking nvidia-glx-185 (from .../nvidia-glx-185_185.18.36-0ubuntu9_i386.deb) ...
nvidia-185-kernel-source: Unpacking nvidia-185-kernel-source

nvidia-185-kernel-source: Preparing to configure nvidia-185-kernel-source

nvidia-glx-185: Installing nvidia-glx-185

nvidia-glx-185: Preparing nvidia-glx-185

dpkg-divert: rename involves overwriting `/usr/lib/nvidia/libGL.so.1.xlibmesa' with
  different file `/usr/lib/libGL.so.1', not allowed
dpkg: error processing /var/cache/apt/archives/nvidia-glx-185_185.18.36-0ubuntu9_i386.deb (--unpack):
 subprocess new pre-installation script returned error exit status 2
Errors were encountered while processing:
 /var/cache/apt/archives/nvidia-glx-185_185.18.36-0ubuntu9_i386.deb
Traceback (most recent call last):
  File "interface.py", line 432, in <module>
    a.mainMenu()
  File "interface.py", line 295, in mainMenu
    a.driverMenu('nvidia')
  File "interface.py", line 333, in driverMenu
    self.process(self.abstract.install, package)
  File "interface.py", line 391, in process
    myFunction(myArgs)
  File "/usr/lib/python2.6/dist-packages/Envy/abstraction.py", line 155, in install
    self.pkg.install(packages, self.widget)
  File "/usr/lib/python2.6/dist-packages/Envy/packagemanager.py", line 164, in install
    self.cache.commit(UiFetchProgress(widget, self.isText), UiInstallProgress(widget, self.isText))
  File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 318, in commit
    raise SystemError("installArchives() failed")
SystemError: installArchives() failed



安装驱动时候出现的错误,无论哪一个版本的驱动都会出现这个错误。
请大虾帮忙!
谢谢


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 9.10 下 显卡驱动问题: SystemError: installArchives() failed
帖子发表于 : 2009-11-06 9:54 
头像

注册: 2008-03-25 15:49
帖子: 25876
地址: 谁知道?
送出感谢: 8
接收感谢: 10
靠`` 乍一看楼主 头像还以为是大小眼儿呢 :em91
用开源的驱动不好么? :em20


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 9.10 下 显卡驱动问题: SystemError: installArchives() failed
帖子发表于 : 2009-11-08 10:24 
头像

注册: 2006-08-20 11:26
帖子: 79
送出感谢: 0 次
接收感谢: 0 次
当然有开源的驱动最好,但是如何安装开源的驱动呢?


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 9.10 下 显卡驱动问题: SystemError: installArchives() failed
帖子发表于 : 2009-11-08 11:24 
头像

注册: 2008-03-25 15:49
帖子: 25876
地址: 谁知道?
送出感谢: 8
接收感谢: 10
比较麻烦 搜 开源驱动 开3d OK
每种显卡的方法还不大一样 偶的A卡


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译