UBUNTU安装NV官方驱动,分辨率过低的调整解决办法

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
xf22cn
帖子: 75
注册时间: 2007-08-01 12:35
送出感谢: 0
接收感谢: 0

UBUNTU安装NV官方驱动,分辨率过低的调整解决办法

#1

帖子 xf22cn » 2010-01-29 19:27

UBUNTU安装NV官方驱动,分辨率过低的调整解决办法

系统为新安装的系统,没有装过限制驱动。
以下操作均在在终端进行:
1、直接下载官方驱动备用:
wget http://cn.download.nvidia.com/XFree86/Linux-x86/190.53/NVIDIA-Linux-x86-190.53-pkg1.run

2、安装支援包
代码请直接复制粘贴:
sudo apt-get install build-essential linux-headers-`uname -r`
sudo apt-get install make
sudo apt-get install gcc
sudo apt-get install libc6-dev

3、按下“ctrl + alt + F2”,以ROOT用户登录
/etc/init.d/gdm stop
sh ./NVIDIA-Linux-x86-190.53-pkg1.run
按提示装好驱动

4、启动后分辨率过低解决办法:
正常登录桌面,然后启动终端
运行以下命令
gksu displayconfig-gtk
输入密码后,弹出显示器安装界面
选择对应的显示器型号。如果实在找不到正确的显示器型号,可以试试看在制造商中选择“通用”,右边的型号选择自己显示器支持的最大分辨率。注意:LCD是液晶,Monitor是CRT。如果是宽屏显示器,勾选下方的“宽屏显示器“选框即可。
完成选择后,单击确定,接受设置。然后重新启动GDM或者直接重新启动系统。
开启终端,运行以下命令
gksu nvidia-settings
就可以自己设置分辨率了。

5、固定分辨率不变
即使如此设置,也有可能在重新启动后分辨率降低,采用以下办法来解决:
打开终端
sudo gedit /etc/X11/xorg.conf


Section "Screen"项下,
DefaultDepth 24

SubSection "Display"
之间,插入以下内容
Option "TwinView" "0"
Option "metamodes" "1440x900_60 +0+0"
请注意,中间的1440x900_60请改为自己的分辨率与刷新率

我的修改好以后是这个样子的:
Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "1440x900_60 +0+0"
SubSection "Display"
Virtual 1440 900
Depth 24
Modes "800x600@56" "800x600@60" "1280x768@60" "1280x720@60" "1280x800@60" "1440x900@60"
EndSubSection
EndSection

6、安装3D桌面:
运行以下命令以取得所有软件包:
sudo apt-get install python-compizconfig compizconfig-settings-manager compiz-plugins compiz-wrapper compiz-core compiz-gnome libemeraldengine0 emerald libdecoration0 compiz-fusion-plugins-extra fusion-icon compizconfig-backend-gconf
snolice
帖子: 98
注册时间: 2009-05-31 0:44
送出感谢: 0
接收感谢: 0

Re: UBUNTU安装NV官方驱动,分辨率过低的调整解决办法

#2

帖子 snolice » 2010-12-06 10:43

试一下5 :em11
一座城市,一片荒芜。
头像
nanotu
帖子: 14
注册时间: 2009-03-31 16:11
送出感谢: 0
接收感谢: 0

Re: UBUNTU安装NV官方驱动,分辨率过低的调整解决办法

#3

帖子 nanotu » 2010-12-06 19:43

支持,正在为显卡驱动的事情烦恼 :em20
回复

回到 “常用硬件支持”