当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1038 篇帖子 ]  前往页数 1, 2, 3, 4, 5 ... 70  下一页
作者 内容
1 楼 
 文章标题 : ati官方驱动(非开源)的安装配置(08/01/19),compiz用户不推荐更新
帖子发表于 : 2006-10-01 9:33 
头像

注册: 2006-05-13 4:02
帖子: 10606
送出感谢: 0 次
接收感谢: 7
主要参考 http://wiki.cchtml.com/index.php/

fglrx驱动(即官方闭源驱动)现已支持aiglx,但并不理想,请耐心等待下一个版本。想尝试beryl/compiz(即桌面效果)的可用本8.1驱动(支持9500至HD2900),但有迟钝感;或之前的版本,如8.40+xgl;或者用开源驱动(非ati官方,但支持更老的显卡)ati/radeon+aiglx(无需安装),后者有些特性可能不支持或速度慢,但资源占用相对较少。另外开源驱动对x1k以上系列显卡支持不好(以后会有所改善)。

另外,某些显卡可能会遇到重启以后无法进入x,或者在安装完系统后黑屏,请参考一下这里: http://forum.ubuntu.org.cn/viewtopic.php?t=40830 也可以自己搜索论坛。


方法0:这个是安装自带官方驱动,版本是8.34.8(feisty)/8.37.6(gutsy),不支持aiglx。
最简单的是找到系统-系统管理-受限驱动管理器,输入密码,把ATI图形加速驱动钩上,然后系统会要求下载和安装必要的软件,安装完毕后请重启电脑。此时查看受限驱动管理器应该是“已启用”。如果不行,那么请继续往下看。

方法一:安装自带驱动,feisty的8.34.8/gutsy的8.37.6驱动,仅支持9500至x1900显卡,不支持aiglx。
如果你曾经用过方法二,需要先执行
代码:
sudo lrm-manager
并把原来装过的4个包彻底删除。
代码:
sudo apt-get autoremove --purge fglrx*

安装驱动
代码:
sudo apt-get update
sudo apt-get install linux-restricted-modules-$(uname -r)
sudo apt-get install xorg-driver-fglrx fglrx-control
sudo depmod -a

配置驱动
代码:
sudo dpkg-reconfigure xserver-xorg
在选择驱动时,选择fglrx,其他一般保持默认即可。

或者用
代码:
sudo aticonfig --initial -f
以上方法只能两者择一。

然后
代码:
sudo aticonfig --ovt=Xv

如果执行出错,则把备份的xorg.conf.xx改名,用mv命令。
其实本语句相当于在/etc/X11/xorg.conf的Device段添加两行:
代码:
Option      "VideoOverlay"      "on"
Option      "OpenGLOverlay"     "off"

并且
代码:
sudo gedit /etc/X11/xorg.conf
添加两段
代码:
Section "Extensions"
        Option  "Composite" "0"
EndSection

Section "ServerFlags"
        Option  "AIGLX" "off"
EndSection
注意,上面这两段非常重要!

重启系统

确认是否正常运行(类似,版本号可以不同)
代码:
fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9600 Generic
OpenGL version string: 2.0.6011 (8.28.8)


*方法二:自己编译驱动8.40.4,只支持9500至X1900显卡,老显卡不支持。如要开compiz,需另装xserver-xgl。
注意,每次内核升级后都必须重新编译。不支持aiglx。
安装编译所必须的工具
代码:
sudo apt-get update
sudo apt-get install module-assistant build-essential fakeroot dh-make debhelper debconf libstdc++5 linux-headers-$(uname -r)

创建deb包
注意:执行下面的命令的前提是,你必须cd到你下载的驱动的当前目录。不知道什么是cd命令的话,把下面的xxx.run的部分删掉,然后把你的驱动直接拖到终端,其余部分不变。终端在主菜单的附件子菜单。

Feisty:
代码:
bash *.run --buildpkg Ubuntu/feisty

gutsy:
代码:
bash *.run --buildpkg Ubuntu/gutsy

屏蔽fglrx核心模块
注意,如果你已经安装了linux-restricted-modules的话,那么此步必做。否则可以跳过(一般都要做)。
代码:
sudo gedit /etc/default/linux-restricted-modules-common
代码:
DISABLED_MODULES=""
改成
代码:
DISABLED_MODULES="fglrx"

安装deb包
代码:
sudo dpkg -i xorg-driver-fglrx_*.deb fglrx-kernel-source*.deb fglrx-amdcccle*.deb

移除旧的fglrx
如果你是第一次做,那么会提示你这个文件找不到。别管他,继续往下做就是。
代码:
sudo rm /usr/src/fglrx-kernel*.deb
sudo apt-get -f install

编译内核模块并安装
代码:
sudo module-assistant prepare
sudo module-assistant update
sudo module-assistant build fglrx
cd /usr/src
sudo dpkg -i fglrx-kernel-*.deb
sudo depmod -a

配置驱动
注意,如果以前装过fglrx驱动,此步无须再做。
代码:
sudo dpkg-reconfigure xserver-xorg
在选择驱动时,选择fglrx
或者用
代码:
sudo aticonfig --initial -f
以上方法只能两者择一。
然后
代码:
sudo aticonfig --ovt=Xv

如果执行出错,则把备份的xorg.conf.xx改名,用mv命令。
其实本语句相当于在/etc/X11/xorg.conf的Device段添加两行:
代码:
Option      "VideoOverlay"      "on"
Option      "OpenGLOverlay"     "off"

并且
代码:
sudo gedit /etc/X11/xorg.conf
添加两段
代码:
Section "Extensions"
        Option  "Composite" "0"
EndSection

Section "ServerFlags"
        Option  "AIGLX" "off"
EndSection
上面这两段很重要!(在7.04中,如果你用了sudo dpkg-reconfigure来配置的话,第一段应该已经有了)。
重启系统

确认驱动是否正确安装(可以类似于)
代码:
$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI MOBILITY RADEON X600 SE
OpenGL version string: 1.4 (2.1.7059 Release)
代码:
$ glxinfo | grep render
direct rendering: Yes #如果开启了xgl,那么这里一定是No,还有其他一些信息。


*方法三:自己编译最新驱动8.1,支持9500及以上显卡,老显卡不支持,支持aiglx。
注意:
1。仅该版本才支持到HD2900,并支持aiglx。
2。如果要尝试aiglx+compiz,请参考: http://forum.ubuntu.org.cn/viewtopic.php?t=83802 的最后一步。或者,按照3D区置顶的方法安装最新的compiz。
3。用xgl和aiglx差不多,也有迟钝感。
4。如果不需要compiz/beryl,则强烈推荐安装该驱动,会有非常大的性能改善,以及大量bug修正。

[color=red]每次内核升级后不必再重新编译。

下载地址

发行注记
引用:
New Features

This release of the ATI Catalyst™ Linux driver introduces support for the following new features:
New Supported Operating Systems

This release of the ATI Catalyst Linux software suite introduces support for the following new operating systems

* RedHat Enteprise Linux 5.1
* RedHat Enteprise Linux 4.6
* Ubuntu 7.10 (Gutsy Gibbon)

Resolved Issues

The following section provide a brief description of resolved issues with the latest version of the ATI Catalyst™ Linux software suite. These include:

* Corruption will no longer be noticed in the lower right corner of the display or on the mouse pointer after the system is running for a long period of time
* Connecting a display device that supports 1680x1050 to a system running Linux will no longer result in a maximum display resolution of 1280x1024 only being available
* Custom mode lines in xorg.conf will no longer be ignored by the fglrx driver
* Suspending to RAM or DISK on kernel version 2.6.23 or later no longer fails

Known Issues

The following section provides a brief description of known issues associated with the latest version of ATI Catalyst™ Linux software suite. These issues include:

* On workstation hardware 3D applications will be corrupted if the screen width is not an integer multiple of 64 pixels, for example with a 1680x1050 wide screen display. Further details can be found in topic number 737-31720
* There is no support for video playback on the second head in dual head mode. Further details can be found in topic number 737-26985
* Desktop corruption may be noticed when dragging the overlay/video when using dual-display mode. Further details can be found in topic number 737-29578
* A black screen may be observed on some hardware when switching to the console or leaving the X window system when a Vesa framebuffer console driver is used. Further details can be found in topic number 737-30687
* Display flicker may be noticed when the gnome screen-saver starts
* Diagonal tearing may be noticed when playing a video file using a video player that utilizes the XVideo extension
* Video playback may look blocky when playing a video file using a video player that utilizes the XVideo extension
* Video Playback may display wrong colors and additional shadow images when cropping or expanding a video file using a video player that utilizes the XVideo extension
* Building RPM packages for Mandriva may fail


安装自动编译所必须的工具
代码:
sudo apt-get update
sudo apt-get install build-essential fakeroot dh-make debhelper debconf libstdc++5 dkms

创建deb包
注意:执行下面的命令的前提是,你必须cd到你下载的驱动的当前目录。不知道什么是cd命令的话,把下面的xxx.run的部分删掉,然后把你的驱动直接拖到终端,其余部分不变。终端在主菜单的附件子菜单。

gutsy:
代码:
bash *.run --buildpkg Ubuntu/gutsy

屏蔽fglrx核心模块
注意,如果你已经安装了linux-restricted-modules的话,那么此步必做。否则可以跳过(一般都要做)。
代码:
sudo nano /etc/default/linux-restricted-modules-common
代码:
DISABLED_MODULES=""
改成
代码:
DISABLED_MODULES="fglrx"

如果/etc/modprobe.d/blacklist-restricted文件存在,那么需要
代码:
sudo nano /etc/modprobe.d/blacklist-restricted
并把blacklist fglrx用#注释掉。
安装deb包
代码:
sudo dpkg -i xorg-driver-fglrx_*.deb fglrx-kernel-source*.deb fglrx-amdcccle*.deb

移除旧的fglrx
如果你是第一次做,那么会提示你这个文件找不到。别管他,继续往下做就是。
代码:
sudo rm /usr/src/fglrx-kernel*.deb
sudo apt-get -f install

配置驱动
注意,如果以前装过fglrx驱动,此步无须再做。
代码:
sudo dpkg-reconfigure xserver-xorg
在选择驱动时,选择fglrx
或者用
代码:
sudo aticonfig --initial -f
以上方法只能两者择一。
然后
代码:
sudo aticonfig --ovt=Xv

如果执行出错,则把备份的xorg.conf.xx改名,用mv命令。
其实本语句相当于在/etc/X11/xorg.conf的Device段添加两行:
代码:
Option      "VideoOverlay"      "on"
Option      "OpenGLOverlay"     "off"

并且
代码:
sudo gedit /etc/X11/xorg.conf
添加两段
代码:
Section "Extensions"
        Option  "Composite" "0"
EndSection

Section "ServerFlags"
        Option  "AIGLX" "off"
EndSection
上面这两段很重要!如果想开启aiglx,则这两段应该是:
代码:
Section "Extensions"
        Option  "Composite" "1"
EndSection

Section "ServerFlags"
        Option  "AIGLX" "on"
EndSection


重启系统

确认驱动是否正确安装(可以类似于)
代码:
fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI MOBILITY RADEON X600 SE
OpenGL version string: 2.1.7170 Release
代码:
$ glxinfo | grep render
direct rendering: Yes #如果开启了xgl,那么这里一定是No,还有其他一些信息。

------------------------------------------------------------------------------------------------------------------------------
常见错误:

0。如果你的宽屏显示器无法正确设置分辨率(大于1280x1024),则需手动修改xorg.conf文件,如
代码:
Section "Monitor"
       Option "DPMS"
       Identifier "samsung-monitor"
       VendorName "Samsung"
       ModelName "SyncMaster 205BW"
       HorizSync 31.4 - 80.0
       VertRefresh 56.000 - 75.000
       Modeline "1680x1050" 146.25 1680 1784 1960 2240 1050 1053 1059 1089
EndSection

Section "Screen"
   Identifier   "samsung-screen"
   Device      "samsung-device"
   Monitor      "samsung-monitor"
   Defaultdepth   24
   SubSection "Display"
      Depth   24
      Modes      "1680x1050"
   EndSubSection
EndSection


1。如果你碰到2D加速很慢的情况,在/etc/X11/xorg.conf 的 Device section(就是有fglrx的那段)中添上
代码:
Option      "XaaNoOffscreenPixmaps"


2。如果没有3D加速,可尝试
代码:
sudo mkdir /lib/modules/$(uname -r)/volatile
sudo ln -sf /lib/modules/$(uname -r)/misc/fglrx.ko /lib/modules/$(uname -r)/volatile/fglrx.ko


3。另外,如果你想用图形化的工具配置显卡的话,比如双头显示,则可以
代码:
gksu fireglcontrol
如果是用方法二的用
代码:
gksu amdcccle
当然,图形界面的功能比较有限,最强大的还是aticonfig。最新版的控制中心有些新东西,大家可以试试。

4。如果说/usr/X11R6/lib/modules/dri/fglrx_dri.so缺失,则执行
代码:
sudo ln -s /usr/lib/ /usr/X11R6/lib/modules


5。如果执行fglrxinfo出现 libGL.so.1: cannot open shared object file,则
代码:
sudo ln /usr/lib/libGL.so.1.2 /usr/lib/libGL.so.1
sudo chmod o+r /usr/lib/libGL.so.1.2


6。gutsy无法休眠。安装7.12版本驱动,已经修正。

7。如果还有其他问题,比如nforce3的芯片(主要是asus的K8N),说你仍然运行于mesa,无3d加速,可以看这里:
http://wiki.cchtml.com/index.php/Troubleshootinghttp://wiki.cchtml.com/index.php/Ubuntu ... tion_Guide


_________________
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo


最后由 zhuqin_83 编辑于 2008-01-19 12:51,总共编辑了 100 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-10-01 9:43 
头像

注册: 2006-05-12 0:52
帖子: 781
地址: Chongqing China
送出感谢: 0 次
接收感谢: 0 次
sudo depmod -a是什么意思?


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-10-01 10:05 
头像

注册: 2006-05-13 4:02
帖子: 10606
送出感谢: 0 次
接收感谢: 7
不知道,查man好了。man depmod,我很懒的 :D


_________________
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-10-05 3:55 

注册: 2005-11-08 10:12
帖子: 224
送出感谢: 0 次
接收感谢: 0 次
不好意思,很早就试过了,不行的。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-10-10 1:56 
头像

注册: 2005-04-06 21:15
帖子: 2200
地址: 安徽黄山
送出感谢: 0 次
接收感谢: 0 次
Section "Extensions"
Option "Composite" "0"
EndSection
最后再加,不然 dpkg-reconfigure时会覆盖掉。
我的用官方bin文件装好编译下内核可以驱动出3D加速,不过20秒内系统必挂。


_________________
生命不息,灌水不止,我师父是白娘子.另热烈庆祝本人blog访问量突破2w大关.
被高手bs,向小白显摆.


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-10-10 11:13 
头像

注册: 2006-05-13 4:02
帖子: 10606
送出感谢: 0 次
接收感谢: 7
ct 写道:
Section "Extensions"
Option "Composite" "0"
EndSection
最后再加,不然 dpkg-reconfigure时会覆盖掉。
我的用官方bin文件装好编译下内核可以驱动出3D加速,不过20秒内系统必挂。

谢谢提醒,我没有注意,已经修改了。


_________________
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-10-17 11:30 
头像

注册: 2006-05-18 18:24
帖子: 189
地址: 四川广安
送出感谢: 0 次
接收感谢: 0 次
用自带驱动无法装上,编译也老是出错,在dapper下编译是没有问题的,不知有谁成功安装了的


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2006-10-17 11:30 
头像

注册: 2006-05-18 18:24
帖子: 189
地址: 四川广安
送出感谢: 0 次
接收感谢: 0 次
经过许多次失败终于装上了,原来是少了这句:
代码:
sudo ln -sf bash /bin/sh

还是谢谢楼主了。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2006-10-27 14:06 

注册: 2005-11-25 15:07
帖子: 15
送出感谢: 0 次
接收感谢: 0 次
这个是我在官方wiki上找的:

Install instructions for Ubuntu 6.06 (Dapper Drake) and 6.10 (Edgy Eft)
Install the kernel drivers. These drivers should be installed by default, but it's better to make sure they are installed. You need the package linux-$arch, where you replace $arch by the CPU architecture for the machine. This is 386 for Intel Pentium, 686 for Celeron, Pentium Pro, Pentium II, Pentium III, and Pentium 4 without Hyper-Threading. 686-smp for Pentium 4 with Hyper-Threading, or k7 or k7-smp for AMD athlon. On 64-bit systems, this may be amd64-generic, amd64-k8, amd64-k8-smp, or amd64-xeon.

sudo apt-get install linux-686
or
sudo apt-get install linux-k7
or
...You also need to install the restricted-modules package that match ***exactly*** the kernel you are running, as well as specific required packages: (if you ran the previous command, make sure to reboot on your new kernel, otherwise this will install the wrong kernel modules !)

sudo apt-get update
sudo apt-get install linux-restricted-modules-$(uname -r)
sudo apt-get install xorg-driver-fglrx fglrx-controlPlease note that the fglrx-control package is not compulsory as it seems to be buggy (but wont affect your machine in anyway ).

If the restricted-modules package for the kernel you are running is not available (it happens sometimes with K/Ubuntu), you may have to opt for running a kernel for which this package is available or to install the drivers directly from the setup script provided by ATI ( https://support.ati.com/ics/support/def ... olderID=27)

Once the above packages are correctly installed, run these commands:

sudo aticonfig --initial
sudo aticonfig --overlay-type=Xv// This next step seems unnecessary to me, as aticonfig --initial will patch your xorg.conf to make it work with your card perfectly)

After this, run:

sudo dpkg-reconfigure xserver-xorgOf course, make sure to choose the "fglrx" driver, and not the "ati" or any other one.

Then go back and edit xorg.conf with your favorite editor, perhaps:

sudo nano /etc/X11/xorg.confand make sure that under the "Device" sections, the Driver is set to

Driver "fglrx"+++++++++++++++++++++++++ For EDGY Users ONLY !!!

As ATI are well known not to be able to provide correct drivers for their hardware, you will have to deactivate the composite extension in /etc/X11/xorg.conf

add the following lines at the end of your xorg.conf

Section "Extensions"
Option "Composite" "false"
EndSection+++++++++++++++++++++++++

It appears that fglrx is often unstable, at least on AMD64. System may lock on 8.25 driver. 3D accell may not work on 8.28. The 8.26.18 driver may be your best bet, as of Sept2006. Instructions for updating drivers are at: http://wiki.cchtml.com/index.php/Ubuntu ... r_Manually But I recommend 8.26 at this time, not 8.28.

Reboot.

Confirm it worked, by issuing the "fglrxinfo" command:

$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9700 Generic
OpenGL version string: 2.0.5755 (8.24.8)
Source: http://wiki.cchtml.com/index.php/Ubuntu ... tion_Guide

You may see a message Xlib: extension "XFree86-DRI" missing on display ":1.0. If the line load "dri" in Section "Module" is missing from your /etc/X11/xorg.conf then add it. However this message doesn't not necessarily indicate a problem.

If fglrxinfo gives you the following, your installation is not completed correctly:

$ fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.4.1)In this case, watch for these things:

Make sure that the resctricted-modules package installed correspond to the kernel your are running and that you can load the fglrx driver, wether by issuing the command "sudo modprobe fglrx" or by verifying that the module appears in the list of loaded modules, by issuing the command "lsmod";

It may be necessary to establish a symbolic link for the /usr/lib/dri folder, by issuing the following command: "sudo ln -s /usr/lib/dri /usr/lib/xorg/modules/dri";

You may have to deload the radeon and dri modules, by issuing "sudo rmmod radeon" and "sudo rmmod dri";

Make sure you deload the module ati-agp by issuing "sudo rmmod ati-agp" and blacklist it in /etc/modprobe.d/blacklist.


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2006-10-28 9:36 

注册: 2005-09-09 18:13
帖子: 141
送出感谢: 0 次
接收感谢: 0 次
顶,原来我就是没加最后一句,怎么都出不来,多谢楼主


_________________
给我一个支点,我可以撬起地球仪!
Ubuntu Edgy Eft
Thinkpad T60
T2300(1.66G) 512M(667MHz) X1300(64M) 60G


页首
 用户资料  
 
11 楼 
 文章标题 : 为什么会出现E: 无法找到软件包 module-assistant
帖子发表于 : 2006-10-29 1:48 

注册: 2006-10-28 21:39
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
matianxg@matianxg-desktop:~$ sudo apt-get install module-assistant build-essential
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
E: 无法找到软件包 module-assistant

装很多东西都是这样,是怎么回事呢?


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2006-10-30 22:04 

注册: 2006-07-23 15:02
帖子: 200
送出感谢: 0 次
接收感谢: 0 次
我是按照楼主方法1做的

但是fglrxinfo 命令 得到的结果不还是这个:
display: :0.0 screen: 0
OpenGL vendor string: Tungsten Graphics, Inc.
OpenGL renderer string: Mesa DRI R300 20060815 AGP 1x TCL
OpenGL version string: 1.2 (1.3 Mesa 6.5.1)


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2006-10-31 5:47 
头像

注册: 2006-05-13 4:02
帖子: 10606
送出感谢: 0 次
接收感谢: 7
我又修改了一下,你试试看行不行。


_________________
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2006-10-31 10:43 

注册: 2006-07-23 15:02
帖子: 200
送出感谢: 0 次
接收感谢: 0 次
sudo aticonfig --ovt=Xv,执行到这里的时候,提示

Warning: Option 'VideoOverlay' doesn't affect running session.
Warning: Option 'OpenGLOverlay' doesn't affect running session.
aticonfig: Writing to '/etc/X11/xorg.conf' failed. No such file or directory.
No ATI fglrx device was found in the file: '/etc/X11/xorg.conf'.
Please run 'aticonfig --initial' or change the 'Driver' part of your configuration
file to "fglrx" and run aticonfig again.


然后我aticonfig --initial,提示
Uninitialised file found, configuring.
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.original-0
aticonfig: Writing to '/etc/X11/xorg.conf' failed. Bad file descriptor.


我之前没有执行过方法2,我的是笔记本,x300显卡


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2006-10-31 11:00 
头像

注册: 2006-05-13 4:02
帖子: 10606
送出感谢: 0 次
接收感谢: 7
lk_517 写道:
sudo aticonfig --ovt=Xv,执行到这里的时候,提示

Warning: Option 'VideoOverlay' doesn't affect running session.
Warning: Option 'OpenGLOverlay' doesn't affect running session.
aticonfig: Writing to '/etc/X11/xorg.conf' failed. No such file or directory.
No ATI fglrx device was found in the file: '/etc/X11/xorg.conf'.
Please run 'aticonfig --initial' or change the 'Driver' part of your configuration
file to "fglrx" and run aticonfig again.


然后我aticonfig --initial,提示
Uninitialised file found, configuring.
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.original-0
aticonfig: Writing to '/etc/X11/xorg.conf' failed. Bad file descriptor.


我之前没有执行过方法2,我的是笔记本,x300显卡


sudo dpkg-reconfigure xserver-xorg is a better way.


_________________
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1038 篇帖子 ]  前往页数 1, 2, 3, 4, 5 ... 70  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译