当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 24 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 升级到Breezy后Nvidia的驱动不行
帖子发表于 : 2005-09-06 16:32 

注册: 2005-09-04 21:03
帖子: 106
送出感谢: 0 次
接收感谢: 0 次
只能用nv

用nvidia就出现

(WW) The NVIDIA GeForce2 Ti GPU installed in this system is
(WW) supported through the NVIDIA Legacy drivers. Please visit
(WW) http://www.nvidia.com/object/unix.html for more
(WW) information. The 1.0-7667 NVIDIA driver will ignore this
(WW) GPU. Continuing probe...
(EE) No devices detected.

意思就是对开我这种显示卡不能用这个驱动?
但是不用的话,屏幕是偏的呀

我在FC3下是使旧一点的驱动
那在Breezy下有法子吗?

3x


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-09-06 16:42 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
也去下载旧的来安装试试。

我的有点奇怪的,386内核可以成功装上显卡驱动,但686的不行。


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-09-07 9:51 

注册: 2005-09-04 21:03
帖子: 106
送出感谢: 0 次
接收感谢: 0 次
装旧版本的不行呀也

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Wed Sep 7 09:26:03 2005

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : false
no questions : false
silent : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
force tls : (not specified)
force compat32 tls : (not specified)
X install prefix : /usr/X11R6
OpenGL install prefix : /usr
compat32 install prefix : (not specified)
installer install prefix: /usr
utility install prefix : /usr
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : /usr/src/linux-source-2.6.12
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: No)
-> No precompiled kernel interface was found to match your kernel; this means
that the installer will need to compile a new kernel interface.
-> Using the kernel source path '/usr/src/linux-source-2.6.12' as specified by
the '--kernel-source-path' commandline option.
-> Kernel source path: '/usr/src/linux-source-2.6.12'
-> Performing CC test with CC="cc".
-> gcc-version-check failed:

You appear to be compiling the NVIDIA kernel module with a different compile
r than the one that was used to compile the running kernel. This may be fin
e, but there are cases where this can lead to instability. The compiler use
d to compile the kernel was gcc 3.4; the current compiler is gcc 4.0.

If you know what you are doing and want to ignore the gcc version check, sel
ect "No" to continue installation. Otherwise, select "Yes" to abort install
ation, set the CC environment variable to the name of the compiler used to c
ompile your kernel, and restart installation. Abort now? (Answer: No)
ERROR: If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the appropriate nvidia-installer command line option.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-10-16 22:21 

注册: 2005-05-31 9:42
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
可能是编译的问题,版本高了。那个linux-restricted-modules...也要装


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-10-16 23:46 
头像

注册: 2005-09-16 7:32
帖子: 43
送出感谢: 0 次
接收感谢: 0 次
apt-get install nvidia-glx-legacy


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2005-10-17 9:47 

注册: 2005-05-31 9:42
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
下载了nvidia的驱动,相应的kernel source和kernel header,但是安装编译时一个是gcc版本高了,是4.0的,内核是用3.4编译的,忽略后错误说nvidia.ko无法编入内核,说source不对。大家有没有成功的经验?


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2005-10-17 9:49 

注册: 2005-05-31 9:42
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
对了,装nvidia-glx那个驱动屏幕有点偏,所以就想用官方的驱动,有没有调整屏幕的软件?我只想解决这个问题。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2005-10-17 10:44 

注册: 2005-05-31 9:42
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
刚才用gcc 3.3 编译了,虽然没有gcc的警告,但是还是说source不对,但是源里面没有kernel-source-2.6.12,最高的只有2.6.11,那个linux-source倒是有,也装了。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2005-10-17 11:01 
头像

注册: 2005-08-14 21:55
帖子: 58436
地址: 长沙
送出感谢: 4
接收感谢: 272
z5488 写道:
apt-get install nvidia-glx-legacy


$ glxgears
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual

$ glxinfo
name of display: :0.0
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x21 24 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x22 24 dc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
段错误


_________________
● 鸣学


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2005-10-17 12:38 

注册: 2005-09-29 1:16
帖子: 85
送出感谢: 0 次
接收感谢: 0 次
我的是Geforce 2 GTS 的 ,各种方法都试过了 ,没一个行的通的 ,快疯了
kernel-source kernel-header 装的都是对应我的内核2.6.12-9-386的
如果build官方驱动最新的 编译完startx就提示说新驱动不支持我的GPU ,如果编译老版的驱动就提示 ERROR NVIDIA KERNEL MODULE 什么的 直接安装 nvidia-glx-legacy 也不行……

后来看了一种方法
m-a prepare
m-a a-i nvidia-legacy 然后手动安装nvidia-kernel 的话,屏幕闪了一下好像要进去似的然后又退出来了
Xorg.0.log 里说
(II) Initializing extension GLX

*** If unresolved symbols were reported above, they might not
*** be the reason for the server aborting.

Fatal server error:
Caught signal 11. Server aborting

里面明明
(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.7174
Module class: XFree86 Video Driver
这应该是已经加载了吧 , 为什么还是不行呢 ? 快崩溃了


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2005-10-17 12:46 

注册: 2005-05-31 9:42
帖子: 31
送出感谢: 0 次
接收感谢: 0 次
屏幕偏移的问题已经通过xvidtune在xorg.conf里面添加修正解决.
驱动还是不知道为什么,我的是2.6.12.-9.686,编译后说我的source不对


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2005-10-17 13:53 

注册: 2005-09-29 1:16
帖子: 85
送出感谢: 0 次
接收感谢: 0 次
刚刚下载了7174版本的驱动 ,然后就装上了 ,呵呵,发帖庆祝一下


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2005-10-17 14:28 
头像

注册: 2005-08-14 21:55
帖子: 58436
地址: 长沙
送出感谢: 4
接收感谢: 272
feex 写道:
刚刚下载了7174版本的驱动 ,然后就装上了 ,呵呵,发帖庆祝一下

NVIDIA-Linux-x86-1.0-7676-pkg1.run。刚下的。怎么你的那个版本。还要到字符模式安装。字符界面好像还要下载支持包。是不?


_________________
● 鸣学


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2005-10-17 15:40 
头像

注册: 2005-08-14 21:55
帖子: 58436
地址: 长沙
送出感谢: 4
接收感谢: 272
搞惨。NVIDIA-Linux-x86-1.0-7676-pkg1.run编译内核,下了gcc4.0的那个。下了kernek-source-2.6.11,还设置路径。说需要gcc3.4。晕。


_________________
● 鸣学


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2005-10-17 17:14 
头像

注册: 2005-09-16 7:32
帖子: 43
送出感谢: 0 次
接收感谢: 0 次
参考罢,我看见e文就头痛,注意做标记的一段,看原文链接,贴的不好

http://www.ubuntuforums.org/showthread. ... ght=nvidia

引用:
HOWTO: Latest NVIDIA drivers - 3 Days Ago
[This guide has been adapted to work on Ubuntu Breezy (I had written one for Ubuntu Hoary). I've done only few changes in order to make it work on Breezy.]

NOTE if you want to install the NVIDIA drivers you can do it in 2 ways:
1) If you use GNOME click on System/Help/Ubuntu 5.10 Starter Guide/hardware (it's on the left part of the window) and read point 1

This is the usual (and easier) way (but I've never used it). It will allow you to install nvidia driver 7667.

2) If you need another driver version or you have problems with method 1 or you are using a kernel you have compiled (thus lacking the restricted modules required for method 1) or you want to try something different you can follow my guide.

In this guide you will use the nvidia installer (I've tried v.7667), in this way you can install every version you wish (even the latest release)

Make sure you graphic card is not among the ones which are NOT SUPPORTED by looking at the list you will find in the NOTES SECTION *

You need 7676 version only if you have Geforce 7800, otherwise is useless (and it has some bugs). If you haven't got this graphic card PLEASE try 7667, it's more stable.

Download the installer from this page according to your architecture (32bit or 64bit)
http://www.nvidia.com/object/unix.html

Before you start you have to make sure the following things are installed (see points "a","b","c"). If not, you can install them following these steps:

Open either Terminal or Konsole and type:

uname -r (this will tell you the name and version of the kernel you are using)

Open either Synaptic or Kynaptic

a) press the "Search" button and put "header" in the search field

you will see a list of files, find "linux-headers-the name you got from uname -r"

for example if your kernel is "2.6.10-5-386", the headers will be "linux-headers-2.6.10-5-386"

click on the files and select "Mark for installation"

b) press the "Search" button and put "linux-source" in the search field

you will see a list of files, find "linux-source-the name you got from uname -r"

click on the file and select "Mark for installation"

c) press the "Search" button and put "build-essential" in the search field

click on the file and select "Mark for installation"


d) Press the "Apply" button.

You can close Synaptic (or Kynaptic) after it has finished installing the headers.


Ok, now let's begin:

1) uninstall nvidia-glx (if you don't have it just go to step 2)

2) remove the file manually:
sudo rm /etc/init.d/nvidia-glx

3) sudo apt-get install gcc-3.4

ctl-alt-f1 (so as to get to the command line, not a windowed terminal, but out of the graphical interface GUI)

login with your username and password (if required)

sudo /etc/init.d/gdm stop (or "kdm stop" if you use KDE)

cd “directory where you have the nvidia installer”

CC=gcc-3.4

export CC

If you have Ubuntu 64bit type: **
sudo sh NVIDIA-Linux-x86_64-1.0-7667-pkg2.run

Otherwise if you have Ubuntu 32 bit type:
sudo sh NVIDIA-Linux-x86-1.0-7667-pkg2.run

If you have Ubuntu 64bit you can't install OpenGL32bit compatibility libraries, so when the installer asks whether to install it just answer no OR you may want to try a workaround which Draugen found but which I haven't tried myself (look at the PROBLEMS SECTION at the end of the guide: point 5).

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup

sudo nano /etc/X11/xorg.conf
scroll the file down until you find the line with “Modules” and comment out (by putting a "#" before the line) the 2 lines I put in blue and add Load "glx". It should look like the example below:


Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
#Load "dri"
#Load “GLcore”
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "vbe"

Then find the section Device and make sure the word I put in red is “nvidia”:

Section "Device"
Identifier "NVIDIA Corporation NV40 [GeForce 6200 TurboCache]"
Driver "nvidia"
BusID "PCI:1:0:0"


CTRL+O to save (yes, use the same name and overwrite the file)
CTRL+X to exit

sudo /etc/init.d/gdm start (or "kdm start" if you use KDE)

Now you have installed the new nvidia driver.

If you want a "control panel" which shows the settings of your card you might want to install "Nvidia-settings" (this part of the guide has been taken from the Unofficial Ubuntu Starter Guide) although they driver works fine also without it (the choice it's up to you).

Open Terminal or Konsole and type

sudo apt-get install nvidia-settings

sudo gedit /usr/share/applications/NVIDIA-Settings.desktop (you can use "kate" instead of "gedit" in KDE)

Insert the following lines into the new file:

[Desktop Entry]
Name=NVIDIA Settings
Comment=NVIDIA Settings
Exec=nvidia-settings
Icon=
Terminal=false
Type=Application
Categories=Application;System;


Save the file and exit.

Restart your computer

You will be able to see "Nvidia settings" in the menu (the one from which you launch all the applications)

Enjoy!
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
NOTES SECTION

* Below are the legacy GPUs that are no longer supported in the unified driver.
These GPUs will continue to be maintained through the special legacy NVIDIA
GPU driver releases.

NVIDIA chip name Device PCI ID
------------------------------- -------------------------------
RIVA TNT 0x0020
RIVA TNT2/TNT2 Pro 0x0028
RIVA TNT2 Ultra 0x0029
Vanta/Vanta LT 0x002C
RIVA TNT2 Model 64/Model 64 Pro 0x002D
Aladdin TNT2 0x00A0
GeForce 256 0x0100
GeForce DDR 0x0101
Quadro 0x0103
GeForce2 GTS/GeForce2 Pro 0x0150
GeForce2 Ti 0x0151
GeForce2 Ultra 0x0152
Quadro2 Pro 0x0153
----------------------------------------------------------------



** the name of the installer may vary:
e.g. it could be NVIDIA-Linux-x86_64-1.0-7667-pkg1.run.

So just put the name of the installer you've downloaded from Nvidia website.
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------

PROBLEMS SECTION

1) If the installer reports that the “Framebuffer” kernel module conflicts with the drivers you will have to recompile your kernel and disable this function
Here's a HOWTO for kernel compilation for newbies
http://www.ubuntuforums.org/showthre...5&page=1&pp=10

2) If the installer complains in this way (this is an example of part of the error):
...
nvidia: version magic '2.6.10-5-386 preempt 386 gcc-3.4' should be
'2.6.10-5-386 preempt 386 gcc-3.3'
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details.
...

This means the installer tries to use gcc-3.4 instead of gcc-3.3(the right one).Type this before launching NVIDIA installer:

CC=gcc-3.3
export CC

The number of the version of gcc has to be the same as the 2nd one reported in the error by nvidia installer (i.e. the word I put in red instead of the one I put in blue)

then run nvidia installer again.

3) If the installer complains in this way:
...
ERROR: Unable to find the development tool `cc` in your path; please make sure
that you have the package 'gcc' installed. If gcc is installed on your
system, then please check that `cc` is in your PATH.

The user Reid has suggested this solution:

To find out where 'gcc' is located I did:
Code:

which gcc


which returned:
Code:

/usr/bin/gcc


then I made a symbolic link to gcc called cc so programs trying to use 'cc' would get gcc, with this code:
Code:

sudo ln -s /usr/bin/gcc /usr/bin/cc

Then try the installer again.

4) If you have an AGP graphic card and your system freezes but you can still move the mouse pointer you will have to do this:
sudo nano /etc/X11/xorg.conf
Add the lines in red at this section of the file:

Section "Device"
Identifier "NVIDIA Corporation NV40 [GeForce 6200 TurboCache]"
Driver "nvidia"
BusID "PCI:1:0:0"
Option "NvAGP" "0"
Option "RenderAccel" "Off"
Option "IgnoreDisplayDevices" "DFP,TV"
Option "NoRenderExtension" "Off"
Option "Accel" "Off"
Option "AllowGLXWithComposite" “Off”


EndSection


This will either disable 3d acceleration or make it slower (sorry but I haven't got an AGP card so I haven't tried them myself)

If this doesn't work for you try asking at this Forum and you might be talking to some of the developers of the NVIDIA drivers (there's a Linux section) (it's very useful)
http://www.nvnews.net/vbulletin/forumdisplay.php?f=14

5) If you have Ubuntu 64bit you will have some problems when trying to install OpenGL32bit compatibility libraries, so yuomay want to try a workaround suggested by Draugen but which I haven't tried myself

type:

sudo mkdir /emul
sudo mkdir /emul/ia32-linux
sudo mkdir /emul/ia32-linux/usr

sudo ln -s /usr/lib32 /emul/ia32-linux/usr/lib


if /usr/lib32 does not exist, you need to do this

Type:

sudo apt-get install ia32-libs lib32gcc1 lib32stdc++6

without which the opengl compat libs probably won't be much use anyway

there are more 32bit libs as well. check synaptic.


Alberto


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 24 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译