完美解决ATI显卡刷新率配置

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
头像
kras
帖子: 16
注册时间: 2010-06-27 11:39
送出感谢: 0
接收感谢: 0

完美解决ATI显卡刷新率配置

#1

帖子 kras » 2010-06-27 12:10

1、首先生成xorg.conf文件
user@ubuntu ~# sudo service gdm stop
user@ubuntu ~# sudo Xorg -configure
user@ubuntu ~# sudo mv ~/xorg.conf.new /etc/X11/xorg.conf
user@ubuntu ~# sudo service gdm start
2、找到显示器的水平刷新率、垂直刷新率
sudo ddcprobe | grep monitorrange
[sudo] password for tolerance:
monitorrange: 30-71, 50-160
30-71表示水平刷新率, 50-160表示垂直刷新率

提示:这是有品牌的显示器都会用这个命令查询到,如果是杂牌的显示器则需要看显示器背后的铭牌,找到型号上网找下水平刷新率、垂直刷新率。
3、配置xorg.conf
先备份:sudo cp /etc/X11/xorg.conf ~/xorg.conf.back
打开XServer配置文件 /etc/X11/xorg.conf
sudo vim /etc/X11/xorg.conf
找到 Monitor这个节点在下面添加两行:
HorizSync 30-71 #填上自己显示器的水平刷新率
VertRefresh 50-160 #填上自己显示器的垂直刷新率
再找到Screen这个节点, 在列出的分辨率后加上你想要的刷新率,例如我的配置是这样的:
Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies Inc RV350 AS [Radeon 9550]"
Monitor "PH107E/V/S/G"
Defaultdepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768_85"

EndSubSection
EndSection
提示:在这两段里添加红色的代码部分,重启Xservice后就成功了。
另:INTEL显卡的刷新率正在试验中。。。。。。
上次由 kras 在 2010-07-13 11:28,总共编辑 1 次。
不要问哥,哥命令还木有记全。
头像
kras
帖子: 16
注册时间: 2010-06-27 11:39
送出感谢: 0
接收感谢: 0

Re: 完美解决ATI显卡刷新率配置

#2

帖子 kras » 2010-07-12 20:13

INTEL集成显卡的刷新率(945平台)
在Section "Device"的EndSecion前添加如下代码。
引用:

Option "DynamicTwinView" "False"

保存,退出,重新登录后即可(就在生成的文件直接加入这段代码)
不要问哥,哥命令还木有记全。
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

Re: 完美解决ATI显卡刷新率配置

#3

帖子 leeaman » 2010-07-12 20:15

支持一个,我是看显示器铭牌的参数的
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
头像
acid303
帖子: 547
注册时间: 2009-04-03 16:06
送出感谢: 1 次
接收感谢: 2 次

Re: 完美解决ATI显卡刷新率配置

#4

帖子 acid303 » 2010-07-12 21:03

kras 写了: 3、配置xorg.conf
先备份:sudo /etc/X11/xorg.conf ~/xorg.conf.back
貌似少了点东西
头像
kras
帖子: 16
注册时间: 2010-06-27 11:39
送出感谢: 0
接收感谢: 0

Re: 完美解决ATI显卡刷新率配置

#5

帖子 kras » 2010-07-13 11:30

acid303 写了:
kras 写了: 3、配置xorg.conf
先备份:sudo /etc/X11/xorg.conf ~/xorg.conf.back
貌似少了点东西
:em03 不好意思确实少了点东西 应该是:sudo cp /etc/X11/xorg.conf ~/xorg.conf.back
不要问哥,哥命令还木有记全。
回复

回到 “常用硬件支持”