当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 24 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 升了内核,ATI 又挂了! 求助
帖子发表于 : 2010-07-01 16:28 
头像

注册: 2008-11-13 11:48
帖子: 61
系统: ubuntu 13.04
送出感谢: 0 次
接收感谢: 0 次
升级过程中出错代码如下,重新安装fglrx 也会返回相同代码:

代码:
error! bad return status for module build on kernel: 2.6.32-23-generic (x86_64)


症状: ati控制中心可以正常开启,硬件驱动中无法开启受限驱动,特效无法开启.

硬件驱动中点了开启受限驱动后,ati控制中心无法开启,重启后有可开启,

菜鸟发贴,请多多指教.. :em06

ati mobility radeon hd 3470 series

Catalyst版本:10.6
驱动程序包版本:8.741-100



update: 在下楼中贴出的log中发现大量的 lib32,是不是因为我前几天编译chromiumos 建的32-64bit 交叉编译环境的缘故?
代码:
#Steps that we can't easily represent in debhelper files or .in files yet
dh_install -pfglrx    "arch/x86/usr/X11R6/lib/libAMD*.so*"           "usr/lib32/fglrx"
dh_install -pfglrx "arch/x86/usr/X11R6/lib/*.so*"           "usr/lib32/fglrx"
dh_installdirs -pfglrx "usr/lib32/fglrx"
dh_install -pfglrx "arch/x86/usr/X11R6/lib/modules/dri"     "usr/lib32/fglrx"
dh_install -pfglrx "arch/x86/usr/lib/*"                     "usr/lib32/fglrx"
for i in \
         debian/fglrx/usr/lib32/fglrx/dri/fglrx_dri.so \
         debian/fglrx/usr/lib32/fglrx/libGL.so.* \
         ; do execstack -q $i; execstack -c $i; done




还有一个问题: 用ppa升级了 ibus1.3 之后 拼音打字时好时坏,有时按键无反应,必须按两下shift才能回复正常,
sun-pinyin 正常..

update2:应该是和我装得其他软件冲突了,我已经重装,一切正常...很有可能是因为启动画面变得粗糙我修改了好多出地方....

我再国外论坛逛了好几天,发现有相同得问题,当其解决方法对我不凑效...郁闷....
谢谢大家关注...


_________________
代码:
apt-get money


最后由 bozhi21cn 编辑于 2010-07-08 14:05,总共编辑了 3 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 升了内核,ATI 又挂了! 求助
帖子发表于 : 2010-07-01 23:17 
头像

注册: 2008-11-13 11:48
帖子: 61
系统: ubuntu 13.04
送出感谢: 0 次
接收感谢: 0 次
自己顶起....


_________________
代码:
apt-get money


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 升了内核,ATI 又挂了! 求助
帖子发表于 : 2010-07-01 23:27 
头像

注册: 2008-11-13 11:48
帖子: 61
系统: ubuntu 13.04
送出感谢: 0 次
接收感谢: 0 次
附上日志:
/var/lib/dkms/fglrx/8.741/build/make.log

代码:
DKMS make.log for fglrx-8.741 for kernel 2.6.32-23-generic (x86_64)
2010年 07月 01日 星期四 23:19:36 CST
AMD kernel module generator version 2.1
doing Makefile based build for kernel 2.6.x and higher
rm -rf *.c *.h *.o *.ko *.GCC* .??* *.symvers
make -C /lib/modules/2.6.32-23-generic/build SUBDIRS=/var/lib/dkms/fglrx/8.741/build/2.6.x modules
make[1]: 正在进入目录 `/usr/src/linux-headers-2.6.32-23-generic'
  CC [M]  /var/lib/dkms/fglrx/8.741/build/2.6.x/firegl_public.o
In file included from /var/lib/dkms/fglrx/8.741/build/2.6.x/firegl_public.c:451:
/var/lib/dkms/fglrx/8.741/build/2.6.x/drm_proc.h: In function ‘FGLDRM__vma_info’:
/var/lib/dkms/fglrx/8.741/build/2.6.x/drm_proc.h:497: warning: format ‘%08lx’ expects type ‘long unsigned int’, but argument 5 has type ‘phys_addr_t’
  CC [M]  /var/lib/dkms/fglrx/8.741/build/2.6.x/kcl_acpi.o
  CC [M]  /var/lib/dkms/fglrx/8.741/build/2.6.x/kcl_agp.o
  CC [M]  /var/lib/dkms/fglrx/8.741/build/2.6.x/kcl_debug.o
  CC [M]  /var/lib/dkms/fglrx/8.741/build/2.6.x/kcl_ioctl.o
  CC [M]  /var/lib/dkms/fglrx/8.741/build/2.6.x/kcl_io.o
  CC [M]  /var/lib/dkms/fglrx/8.741/build/2.6.x/kcl_pci.o
  CC [M]  /var/lib/dkms/fglrx/8.741/build/2.6.x/kcl_str.o
  CC [M]  /var/lib/dkms/fglrx/8.741/build/2.6.x/kcl_wait.o
  LD [M]  /var/lib/dkms/fglrx/8.741/build/2.6.x/fglrx.o
ld: internal error in output_symtab_index, at ../../gold/object.h:1086
make[2]: *** [/var/lib/dkms/fglrx/8.741/build/2.6.x/fglrx.o] 错误 1
make[1]: *** [_module_/var/lib/dkms/fglrx/8.741/build/2.6.x] 错误 2
make[1]:正在离开目录 `/usr/src/linux-headers-2.6.32-23-generic'
make: *** [kmod_build] 错误 2
build failed with return value 2


_________________
代码:
apt-get money


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 升了内核,ATI 又挂了! 求助
帖子发表于 : 2010-07-01 23:47 
头像

注册: 2008-11-13 11:48
帖子: 61
系统: ubuntu 13.04
送出感谢: 0 次
接收感谢: 0 次
证实此文件不存在
/var/lib/dkms/fglrx/8.741/build/2.6.x/fglrx.o

why? :em20


_________________
代码:
apt-get money


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 升了内核,ATI 又挂了! 求助
帖子发表于 : 2010-07-01 23:54 
头像

注册: 2008-04-27 12:15
帖子: 1026
送出感谢: 0 次
接收感谢: 0 次
头像不错,帮不上忙


_________________
oneleaf 的教导记心间:《学习linux几点忠告》


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 升了内核,ATI 又挂了! 求助
帖子发表于 : 2010-07-02 0:24 
头像

注册: 2008-11-13 11:48
帖子: 61
系统: ubuntu 13.04
送出感谢: 0 次
接收感谢: 0 次
从官网上下载了10.6的包,然后编译制作deb,出错如下:

代码:
./ati-driver-installer-10-6-x86.x86_64.run --buildpkg Ubuntu/lucid
Created directory fglrx-install.SQDmOL
Verifying archive integrity... All good.
Uncompressing ATI Catalyst(TM) Proprietary Linux Driver-8.741.........................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
==================================================
 ATI Technologies Linux Driver Installer/Packager
==================================================
Generating package: Ubuntu/lucid
./packages/Ubuntu/ati-packager.sh: 385: cannot create /tmp/pkg_build.out: Permission denied
Package build failed!
Package build utility output:
dpkg-buildpackage: set CFLAGS to default value: -g -O2
dpkg-buildpackage: set CPPFLAGS to default value:
dpkg-buildpackage: set LDFLAGS to default value: -Wl,-Bsymbolic-functions
dpkg-buildpackage: set FFLAGS to default value: -g -O2
dpkg-buildpackage: set CXXFLAGS to default value: -g -O2
dpkg-buildpackage: source package fglrx-installer
dpkg-buildpackage: source version 2:8.741-0ubuntu1
dpkg-buildpackage: source changed by ATI Technologies Inc. <http://ati.amd.com/support/driver.html>
 debian/rules build
dpkg-buildpackage: host architecture amd64
#Create important strings
for i in 10fglrx \
          dkms.conf \
          fglrx.install \
          fglrx-dev.install \
          fglrx-amdcccle.install \
          overrides/fglrx; do \
      sed -e "s|#XMODDIR#|usr/lib/fglrx/xorg/modules|"     \
         -e "s|#XMODDIR32#||" \
         -e "s|#DRIDIR32#|usr/lib32/fglrx|"   \
         -e "s|#LIBDIR#|lib64|"       \
         -e "s|#DRIDIR#|usr/lib/fglrx|"       \
         -e "s|#CVERSION#|8.741|"   \
         -e "s|#XARCH#|x750_64a|"   \
         -e "s|#ARCH#|x86_64|"   \
         debian/$i.in > debian/$i;      \
   done
# remove exec bit on everything
find arch \
      etc \
      lib \
      module \
      usr \
      x750_64a     -type f | xargs chmod -x
find: `module': No such file or directory
# set executable on user apps
find arch/x86_64/usr/sbin \
      arch/x86_64/usr/X11R6/bin \
      usr/sbin/ -type f | xargs chmod a+x
# set exec bit on scripts
find lib etc debian -name "*.sh" -type f | xargs chmod +x
# Generate modaliases
sh -e debian/modaliases/fglrx_supported \
      lib/modules/fglrx/build_mod/fglrxko_pci_ids.h > \
      debian/modaliases/fglrx-modules.alias.override
dh build
   dh_testdir
   dh_auto_configure
   dh_auto_build
   dh_auto_test
 debian/rules binary
#Steps that we can't easily represent in debhelper files or .in files yet
dh_install -pfglrx    "arch/x86/usr/X11R6/lib/libAMD*.so*"           "usr/lib32/fglrx"
dh_install -pfglrx "arch/x86/usr/X11R6/lib/*.so*"           "usr/lib32/fglrx"
dh_installdirs -pfglrx "usr/lib32/fglrx"
dh_install -pfglrx "arch/x86/usr/X11R6/lib/modules/dri"     "usr/lib32/fglrx"
dh_install -pfglrx "arch/x86/usr/lib/*"                     "usr/lib32/fglrx"
for i in \
         debian/fglrx/usr/lib32/fglrx/dri/fglrx_dri.so \
         debian/fglrx/usr/lib32/fglrx/libGL.so.* \
         ; do execstack -q $i; execstack -c $i; done
/bin/sh: execstack: not found
/bin/sh: execstack: not found
/bin/sh: execstack: not found
/bin/sh: execstack: not found
make: *** [binary-arch] Error 127
dpkg-buildpackage: error: debian/rules binary gave error exit status 2
dpkg-buildpackage: set CFLAGS to default value: -g -O2
dpkg-buildpackage: set CPPFLAGS to default value:
dpkg-buildpackage: set LDFLAGS to default value: -Wl,-Bsymbolic-functions
dpkg-buildpackage: set FFLAGS to default value: -g -O2
dpkg-buildpackage: set CXXFLAGS to default value: -g -O2
dpkg-buildpackage: source package fglrx-installer
dpkg-buildpackage: source version 2:8.741-0ubuntu1
dpkg-buildpackage: source changed by ATI Technologies Inc. <http://ati.amd.com/support/driver.html>
 debian/rules build
dpkg-buildpackage: host architecture amd64
#Create important strings
for i in 10fglrx \
          dkms.conf \
          fglrx.install \
          fglrx-dev.install \
          fglrx-amdcccle.install \
          overrides/fglrx; do \
      sed -e "s|#XMODDIR#|usr/lib/fglrx/xorg/modules|"     \
         -e "s|#XMODDIR32#||" \
         -e "s|#DRIDIR32#|usr/lib32/fglrx|"   \
         -e "s|#LIBDIR#|lib64|"       \
         -e "s|#DRIDIR#|usr/lib/fglrx|"       \
         -e "s|#CVERSION#|8.741|"   \
         -e "s|#XARCH#|x750_64a|"   \
         -e "s|#ARCH#|x86_64|"   \
         debian/$i.in > debian/$i;      \
   done
# remove exec bit on everything
find arch \
      etc \
      lib \
      module \
      usr \
      x750_64a     -type f | xargs chmod -x
find: `module': No such file or directory
# set executable on user apps
find arch/x86_64/usr/sbin \
      arch/x86_64/usr/X11R6/bin \
      usr/sbin/ -type f | xargs chmod a+x
# set exec bit on scripts
find lib etc debian -name "*.sh" -type f | xargs chmod +x
# Generate modaliases
sh -e debian/modaliases/fglrx_supported \
      lib/modules/fglrx/build_mod/fglrxko_pci_ids.h > \
      debian/modaliases/fglrx-modules.alias.override
dh build
   dh_testdir
   dh_auto_configure
   dh_auto_build
   dh_auto_test
 debian/rules binary
#Steps that we can't easily represent in debhelper files or .in files yet
dh_install -pfglrx    "arch/x86/usr/X11R6/lib/libAMD*.so*"           "usr/lib32/fglrx"
dh_install -pfglrx "arch/x86/usr/X11R6/lib/*.so*"           "usr/lib32/fglrx"
dh_installdirs -pfglrx "usr/lib32/fglrx"
dh_install -pfglrx "arch/x86/usr/X11R6/lib/modules/dri"     "usr/lib32/fglrx"
dh_install -pfglrx "arch/x86/usr/lib/*"                     "usr/lib32/fglrx"
for i in \
         debian/fglrx/usr/lib32/fglrx/dri/fglrx_dri.so \
         debian/fglrx/usr/lib32/fglrx/libGL.so.* \
         ; do execstack -q $i; execstack -c $i; done
/bin/sh: execstack: not found
/bin/sh: execstack: not found
/bin/sh: execstack: not found
/bin/sh: execstack: not found
make: *** [binary-arch] Error 127
dpkg-buildpackage: error: debian/rules binary gave error exit status 2
Removing temporary directory: fglrx-install.SQDmOL


不生成deb直接安装也出错,log如下:

fglrx-install.log

代码:
Errors during DKMS module removal
Errors during DKMS module removal
[Error] Kernel Module : Failed to add fglrx-8.741 to DKMS


_________________
代码:
apt-get money


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 升了内核,ATI 又挂了! 求助
帖子发表于 : 2010-07-02 2:47 

注册: 2010-02-07 0:44
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
http://wiki.cchtml.com/index.php/Ubuntu ... tion_Guide
New kernel installed?

In theory, DKMS should automatically install the fglrx kernel module for your new kernel the first time you boot it. Should you need to manually install it:

代码:
$ sudo dkms build -m fglrx -k `uname -r`
$ sudo dkms install -m fglrx -k `uname -r`


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 升了内核,ATI 又挂了! 求助
帖子发表于 : 2010-07-02 8:26 
头像

注册: 2007-10-18 17:40
帖子: 1006
送出感谢: 0 次
接收感谢: 0 次
ubuntu源中的受限驱动,其实就是amd官方驱动的deb打包优化版。

装源中的驱动,多好


_________________

千帖户,享有论坛特权!


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 升了内核,ATI 又挂了! 求助
帖子发表于 : 2010-07-02 8:59 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
开源驱动更加好


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 升了内核,ATI 又挂了! 求助
帖子发表于 : 2010-07-02 9:35 
头像

注册: 2009-04-03 16:06
帖子: 547
送出感谢: 1
接收感谢: 2
貌似楼主没有卸载源里的闭源驱动就去安装官网的闭源驱动,两个版本的文件混在一起出问题了


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 升了内核,ATI 又挂了! 求助
帖子发表于 : 2010-07-02 9:47 
头像

注册: 2009-07-02 11:24
帖子: 762
地址: SCUT
送出感谢: 0 次
接收感谢: 0 次
昨晚升级了内核,ati显卡一切正常 :em09


_________________
twitter
blog


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 升了内核,ATI 又挂了! 求助
帖子发表于 : 2010-07-02 12:54 
头像

注册: 2008-11-13 11:48
帖子: 61
系统: ubuntu 13.04
送出感谢: 0 次
接收感谢: 0 次
edisonchan 写道:
http://wiki.cchtml.com/index.php/Ubuntu_Lucid_Installation_Guide
New kernel installed?

In theory, DKMS should automatically install the fglrx kernel module for your new kernel the first time you boot it. Should you need to manually install it:

代码:
$ sudo dkms build -m fglrx -k `uname -r`
$ sudo dkms install -m fglrx -k `uname -r`



我运行了这个,然后提示


代码:
sudo dkms build -m fglrx -k `uname -r`

Error! Invalid number of parameters passed.
Usage: build -m <module> -v <module-version>


改了一下依旧
代码:
sudo dkms build -m fglrx -k 2.6.32-23-generic

Error! Invalid number of parameters passed.
Usage: build -m <module> -v <module-version>


_________________
代码:
apt-get money


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 升了内核,ATI 又挂了! 求助
帖子发表于 : 2010-07-02 12:55 
头像

注册: 2008-11-13 11:48
帖子: 61
系统: ubuntu 13.04
送出感谢: 0 次
接收感谢: 0 次
john.wu 写道:
ubuntu源中的受限驱动,其实就是amd官方驱动的deb打包优化版。

装源中的驱动,多好



是安装的源中的,但是升级了内核不能用了....所以才实验了官方的..


_________________
代码:
apt-get money


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 升了内核,ATI 又挂了! 求助
帖子发表于 : 2010-07-02 12:56 
头像

注册: 2008-11-13 11:48
帖子: 61
系统: ubuntu 13.04
送出感谢: 0 次
接收感谢: 0 次
leeaman 写道:
开源驱动更加好



理念不错,效果... :em20


_________________
代码:
apt-get money


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 升了内核,ATI 又挂了! 求助
帖子发表于 : 2010-07-02 12:58 
头像

注册: 2008-11-13 11:48
帖子: 61
系统: ubuntu 13.04
送出感谢: 0 次
接收感谢: 0 次
acid303 写道:
貌似楼主没有卸载源里的闭源驱动就去安装官网的闭源驱动,两个版本的文件混在一起出问题了



是升级内核之后出了问题,然后才去安装官方的,,我卸载了所有驱动,然后重装,问题依旧..


_________________
代码:
apt-get money


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 24 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 1 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译