当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 安装显卡后启动异常
帖子发表于 : 2010-07-31 13:28 
头像

注册: 2010-04-30 21:12
帖子: 149
送出感谢: 1
接收感谢: 0 次
各位大侠:
我的事戴尔的笔记本,装ubuntu10.04后没办法关机,一直卡在关机的画面那里。后来装了显卡驱动,可以正常关机了,可是启动的时候 UBUNTU 的标志变得很大很模糊 :em06 ,我想改回以前那样的精致的启动画面,怎么办?还有就是有一个老问题,播放有声音 的文件时插上耳塞时耳塞和机器都同时响 :em21 有人说是没装声卡驱动,可我不会装啊,在网上看到还要自己改代码。。。。。不会啊!

希望知道的朋友说一下,谢谢!! :em01


_________________
向那些疯狂的家伙们致敬
他们特立独行,
他们桀惊不逊,
他们惹事生非,
他们格格不入,
他们用与众不同的眼光看待事物,
他们不喜欢墨守成规,
他们也不愿安于现状。

你可以赞美他们,引用他们,反对他们,
质疑他们,颂扬或是诋毁他们,
但唯独不能漠视他们。
因为他们改变了事物。
他们推动人类向前发展。

或许他们是别人眼里的疯子,
但他们却是我们眼中的天才。

因为只有那些疯狂到以为自己能够改变世界的人,
才能真正地改变世界。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 安装显卡后启动异常
帖子发表于 : 2010-07-31 18:35 
头像

注册: 2007-03-06 18:14
帖子: 626
地址: 常德--重庆
送出感谢: 0 次
接收感谢: 0 次
笔记本型号是啥?显卡呢?声卡是哪个芯片?
显卡驱动装好后可能反而不支持什么东东了(我不用ubuntu,所以不晓得ubuntu启动时实现图形化用的是什么东西),其实也没多少必要管这个咯,系统正常启动就行。
声卡耳塞和音响同时响,这个不是声卡驱动没装,没装就不响了。可能是声卡驱动模块挂载的参数有一点问题。我没有笔记本,只能给你说一下大概方向。比如我的archlinux更改这个参数是在/etc/modprobe.d/modprobe.conf,ubuntu应该也有类似的文件。修改的方法大概是加上类似如下的一行:
代码:
options snd-hda-intel model=dell

而后面的model=XXX就是关键,不同的笔记本可能就不同,http://www.kernel.org/doc/Documentation/sound/alsa/HD-Audio-Models.txt,这个页面里面有这个model的详细说明。


_________________
ABIT Rocket AV8 ,AMD3500,创见DDR433 1GB,希捷IDE250GB,MSI6200a,7130电视卡,Archlinux


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 安装显卡后启动异常
帖子发表于 : 2010-08-09 0:51 
头像

注册: 2010-04-30 21:12
帖子: 149
送出感谢: 1
接收感谢: 0 次
davidlone, 正在尝试,谢谢!!谢谢你很用心的回答!!!!!! :em11


_________________
向那些疯狂的家伙们致敬
他们特立独行,
他们桀惊不逊,
他们惹事生非,
他们格格不入,
他们用与众不同的眼光看待事物,
他们不喜欢墨守成规,
他们也不愿安于现状。

你可以赞美他们,引用他们,反对他们,
质疑他们,颂扬或是诋毁他们,
但唯独不能漠视他们。
因为他们改变了事物。
他们推动人类向前发展。

或许他们是别人眼里的疯子,
但他们却是我们眼中的天才。

因为只有那些疯狂到以为自己能够改变世界的人,
才能真正地改变世界。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 安装显卡后启动异常
帖子发表于 : 2010-08-26 3:08 
头像

注册: 2010-04-30 21:12
帖子: 149
送出感谢: 1
接收感谢: 0 次
:em06 还是没弄好啊,哪位大侠再帮帮忙啊 :em06


_________________
向那些疯狂的家伙们致敬
他们特立独行,
他们桀惊不逊,
他们惹事生非,
他们格格不入,
他们用与众不同的眼光看待事物,
他们不喜欢墨守成规,
他们也不愿安于现状。

你可以赞美他们,引用他们,反对他们,
质疑他们,颂扬或是诋毁他们,
但唯独不能漠视他们。
因为他们改变了事物。
他们推动人类向前发展。

或许他们是别人眼里的疯子,
但他们却是我们眼中的天才。

因为只有那些疯狂到以为自己能够改变世界的人,
才能真正地改变世界。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 安装显卡后启动异常
帖子发表于 : 2010-08-29 22:48 

注册: 2010-08-11 21:39
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
代码:
sudo gedit /etc/default/grub


加一行 GRUB_GFXPAYLOAD_LINUX=1024x768x32

其中1024x768x32为你要设置的分辨率。这个分辨率要你的显卡在VBE状态下支持,否则启动过程黑屏,保存后运行

代码:
sudo update-grub


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译