linux-headers 文件和 非开源模块 关于显卡ATI mobility radeon x2300驱安装的问题

声卡/显卡/打印机/USB设备等硬件问题(网卡问题请发上面的网卡板块)
回复
baihualinqq
帖子: 4
注册时间: 2009-07-16 10:47
送出感谢: 0
接收感谢: 0

linux-headers 文件和 非开源模块 关于显卡ATI mobility radeon x2300驱安装的问题

#1

帖子 baihualinqq » 2010-09-12 13:06

大家好,我遇到的问题是这样的:我的显卡是ATI mobility radeon x2300,安装后发现系统好像没有给它配上驱动, 特效开不了,网上有人说它是HD2xxx系列的,于是我去官网下了一个驱动,(不知大家有没有其它可用的驱动推荐)想安装它,有教程说:要下载 linux-headers 文件和 非开源模块,这是安装驱动所必须的。我的内核版本显示是laptop 2.6.32-21-generic 我装的是10.04桌面版,为了下载这些linux-headers 文件和 非开源模块,我照网上说的在终端输入

sudo apt-get install linux-headers-2.6.32-21 linux-headers-2.6.32-21-generic linux-restricted-modules-generic

正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
linux-headers-2.6.32-21 已经是最新的版本了。
linux-headers-2.6.32-21 被设置为手动安装。
linux-headers-2.6.32-21-generic 已经是最新的版本了。
E: 无法找到软件包 linux-restricted-modules-generic

我想知道无法找到软件包是我的源有问题吗?另外linux-restricted-modules-generic这个是通用的吗,要不要同内核版本匹配呢?比如写成linux-restricted-modules-2.6.32-21-generic

还有教程说装驱动必需先装sudo apt-get install linux-restricted-modules-generic restricted-manager-kde,那么restricted-manager-kde是什么,它也是安装驱动前所必需装的软件包吗

看在我这个菜鸟这么辛苦求教的份上,还请大家多多指教,感激不尽!!!
头像
wzssyqa
帖子: 4010
注册时间: 2008-04-07 17:36
来自: 泰安人在阜新
送出感谢: 0
接收感谢: 0

Re: linux-headers 文件和 非开源模块 关于显卡ATI mobility radeon x2300驱安

#2

帖子 wzssyqa » 2010-09-12 23:44

請勿重複發貼,如果長期無人 回答,可以考慮自己頂帖,但是不要重複發貼
头像
jarryson
帖子: 4002
注册时间: 2005-08-14 19:53
送出感谢: 1 次
接收感谢: 2 次
联系:

Re: linux-headers 文件和 非开源模块 关于显卡ATI mobility radeon x2300驱安

#3

帖子 jarryson » 2010-09-13 0:45

闭源驱动不支持的。闭源驱动只支持R600以及以上的。x2300不属于HD显卡系列

9.10以上的版本你的显卡应该直接就可以开启特效的。也就是使用开源驱动。
回复

回到 “常用硬件支持”